• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

nvidia geforce FX 5200

suicide

Trucker Horst
Themenstarter #1
Hi, ich hab mir eine neue Kiste gekauft und dort ist eine nvidia geforce fx 5200 verbaut.
Nun will ich XFree86 zum laufen bringen.

Ich starte also xf86cfg und will meine Karte raussuchen und muss feststellen das sie nicht in der Liste ist.

Ich versuche ein paar andere Geforce Karten auszusuchen, Resultat: "No Screens found".

Ich schmeisse Google an, finde aber nichts brauchbares.

Nun installiere ich den nvidia-driver port.
ich lade das nvidia.ko modul.
Ich starte xf86cfg und nun kann ich nichtmal mehr x configurieren, denn alles was kommt ist eine wirre Anordnung von unsinnigen Zeichen und nichts geht mehr.

Ich weiß nicht mehr was ich tun soll, komme hierher und frage euch ob ihr eine Ahnung habt welche Karte ich aussuchen soll, bzw ob ich etwas mit dem nvidia treiber falsch gemacht habe, oder ob ich den überhaupt brauche. ;)
 

guslan

Active Member
#2
Also unter /usr/ports/x11/nvidia-driver kannst du die Treiber über ports installieren, was auch besser ist. Du kannst die FreeBSD Treiber auch von nvidia direkt runterladen.
http://www.nvidia.de/object/freebsd_1.0-4365_de

Beachte die Schritte!! Du brauchts FreeBSD 4.7 oder höher und im Kernel müssen folgende Einträge sein
options USER_LDT
options SYSVSHM

Weiteres steht im Readme! Hab die selbe Grafikkarte und die funzt bei mir.
 

thomasf

Well-Known Member
#3
@suicide
wähle beim einrichten des xservers NICHT die Kartendatenbank(also nicht die Karte direkt) sondern nur den nv Treiber, dann gehts. Ich hab die gleiche Karte und bei mir funktioniert das so. Der port ist nur für die 3d Beschleunigung gedacht,die bei mir allerding auch nicht funktioniert. (hatte das vor einer Weile mal versucht)
..meint Tip bezieht sich übrigends auf das einrichten mit sysinstall (xf86cfg -textmode)
 

suicide

Trucker Horst
Themenstarter #4
Ich danke euch, werd das erstmal mit nv probieren, ansonsten mal kernel recompilen.
Wusste nicht das ich die zwei Options in der Config brauche.