• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

NVIDIA, richtigen Treiber finden und nutzen: Fragen dazu und Tips erwünscht.

pit234a

Well-Known Member
Themenstarter #1
Nun habe ich ja neue HW im alten Gewand und dabei auch wieder eine neue GraKa, eine NVIDIA GTX1060.
Mein System ist derzeit 11.2-RELEASE.
Deshalb machte ich mich wieder auf die Suche, nach dem passenden Treiber für die Karte. Meine alte Karte war auch NVIDIA, irgendwas mit 700 und brauchte den 340er Treiber.
Ich beschreibe mal meine Suche und denke, das dadurch meine Probleme deutlich werden.

https://www.nvidia.com/Download/index.aspx?lang=en-us
da gab ich die Eckdaten ein und erfuhr, dass ein Treiber 417.01 ( https://www.nvidia.de/Download/driverResults.aspx/140386/de ) gültig sei. Wenn ich auf der verlinkten Seite anschaute, welche Karten von diesem Treiber unterstützt werden, war auch meine alte Karte dabei. Also, dachte ich mir, brauche ich gar keinen neuen Treiber und scheiterte damit natürlich.
Bei meiner letzten Konfiguration hatte ich den 340er aus den Ports bauen müssen, weil es ansonsten zu Fehlern kam. Deshalb wollte ich also nun den 417er aus den Ports bauen und sehe:
Code:
find /usr/ports/x11 -type d -iname "nvidia*"
/usr/ports/x11/nvidia-xconfig
/usr/ports/x11/nvidia-settings
/usr/ports/x11/nvidia-driver-304
/usr/ports/x11/nvidia-driver-340
/usr/ports/x11/nvidia-driver
Oih.
Deshalb nach den Paketen gesehen und :
Code:
pkg search nvidia
nvidia-driver-390.87           NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-driver-304-304.137_1    NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-driver-340-340.107_1    NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-settings-396.24         Display Control Panel for X NVidia driver
nvidia-texture-tools-2.0.8.1_10 Texture Tools with support for DirectX 10 texture formats
nvidia-xconfig-396.24          Tool to manipulate X configuration files for the NVidia driver
Also immerhin einen 390er!
Den installierte ich dann und konnte den schließlich benutzen, ich nutze ihn gerade eben und alles geht ganz gut.

Mein neues, sehr viel schnelleres System legt aber gelegentliche Kunstpausen ein, muss manchmal nachdenken, ob es auch reagieren möchte. Das ist seltsam für mich. Außerdem ist mir bisher einmal der Bildschirm total eingefroren (was natürlich zahlreiche Ursachen haben kann), obwohl es für mich dazu keinen offensichtlichen Grund gab (über ssh war der PC erreichbar und hatte jede Menge freie Ressourcen, reagiert auch gut und flüssig).

Also, kurz und gut, ich bin da noch am Arbeiten und keineswegs durch damit.
Aber irgendwo in mir nagt die Frage nach dem richtigen NVIDIA-Treiber für meine GraKA.

Soll ich vielleicht den 417er-Treiber von NVIDIA downloaden und versuchen, den zu kompilieren?
Ist der 390er für mich in Ordnung und state of the art?
Soll ich vielleicht generell nach 12 upgraden, weil es da einige Korrekturen gab?
Und wie zum Teufel finde ich denn für FreeBSD am einfachsten und passendsten den korrekten Treiber für meine NVIDIA-Karte? (ich meine, dass ich schon mal eine bessere Seite benutzt hatte, als die oben verlinkte, die immer alle Produkte zu jedem Treiber zeigt).

Freue mich auf Antworten und: das ist kein brennendes Problem. Ich arbeite mit dem PC.
 
#2
Moin !

Nimm den aktuellsten Treiber aus den Ports und gut ist !

Habe hier eine GTX750 , also schon einen Tag älter als deine Karte
und alles läuft klasse mit dem aktuellen Treiber !

Wird schon einen Grund haben das die 4XX-Treiber noch nicht
drin sind !

:ugly:
 

pit234a

Well-Known Member
Themenstarter #4
Danke für die Antwort.

Mein Problem ist, dass ich vielleicht übervorsichtig bin und überall einen Hinterhalt vermute. Zusätzlich habe ich immer größere Probleme, Dokumentation zu lesen und auch zu verstehen.

Auf der oben genannten NVIDIA-Seite mit den "Supported Products" hatte ich nämlich nachgesehen, bevor ich die neue Karte eingebaut hatte. Allerdings für meinen damals noch aktuellen und laufenden Treiber, den 340er. Und unter dem waren beide Karten als Supported" gelistet, so dass ich glaubte, ich brauche gar keinen Treiberwechsel. War aber nicht so.
Dann crashte mein System beim Booten mit dem neu installierten 390er Treiber zunächst und ich erinnerte mich, dass ich den 340er aus den Ports hatte bauen müssen, weil der ansonsten auch gecrashed war.
Deshalb sah ich erst nochmal nach, welcher Treiber eigentlich der passende sein würde und dann, was ich den Ports und was als Paket finden konnte.
Das verwirrt mich alles ein wenig.

Der Grund für den Crash fand ich dann allerdings an anderer Stelle:
Ich kenne ja das Problem, dass manche Karten `nvidia' wollen und andere `nvidia-modeset'. Nachdem ich mit `nvidia' immer nur einen Monitor hinbekommen hatte, las ich eine Anleitung, in welcher erklärt wurde, beide gleichzeitig zu aktivieren. Das tat ich auch mittels kldload und siehe da: war erfolgreich. Also setzte ich beide in der rc.conf und vergaß das Ding. Irgendwann musste ich neu starten und dann kam es eben zum Crash.
In den Installationsmeldungen heißt es recht eindeutig, entweder `nvidia' oder `nvidia-modeset'.
Wieso beide gleichzeitig liefen, nachdem ich `nvidia-modeset' manuell nachgeladen hatte und das auch funktionierte, beim Neustart damit dann das System crashte, ist ein anderer Punkt, der mir etwas unklar ist.

Ich habe den größten Teil meiner HW erneuert und teste gerade und versuche damit klar zu kommen.
Meine alte HW war immer wieder mal sporadisch neu gestartet. Meine neue derzeit leider auch schon zwei Mal. Ich habe bisher Motherboard und CPU, RAM, GraKA und Netzteil erneuert. Mein Ziel war nicht nur, mit neuer HW ein verlässlicheres System zu bekommen, sondern auch eine ganze Weile keine neue HW mehr anschaffen zu müssen. Scheinbar muss ich daran noch arbeiten und die Stelle mit dem Treiber für die GraKa einfach verlässlich ausschließen können.
 

mr44er

Well-Known Member
#5
Der 390er ist der richtige.

/boot/loader.conf
nvidia-modeset_load="YES"


Dann save to x configuration file. Hier wichtig: überschreiben statts mergen. Dann rebooten und freuen.
 

Anhänge

pit234a

Well-Known Member
Themenstarter #6
x11/nvidia-driver
ist nicht nur ein "Meta-Port", sondern, wie ich Gestern sehen konnte, auch ein "Meta-Paket"
Anstatt also mittels pkg install die (vermeintlich) korrekte Treiberversion zu installieren, kann man also die Wahl dem System überlassen. In meinem Fall wurde bei zwei unterschiedlichen Karten jeweils der 390er genommen und funktioniert auch. Bei einer hatte ich zuvor den 340er manuell gewählt.
 

mr44er

Well-Known Member
#7
Öhm...ich glaube, du irrst. Ich hab den x11/nvidia-driver immer als neuesten wahrgenommen, zur Zeit eben der 390er. 96, 304 und 340 sind gedacht, um Karten zu betreiben, die nvidia nach den jeweiligen Versionen aus dem Treibersupport rausge'EOL'd hat. Wobei ich grade nichtmal weiß, ob der 96er überhaupt noch verfügbar ist.

Wenn man wirklich eine uralte Karte hat (7-8 Jahre), kann man bei nvidia unter 'Produkttyp: legacy -> Unterstützte' nachschauen und weiß dann, welchen man nutzen kann, eben die jüngste noch mögliche Treibergeneration. :)
 

pit234a

Well-Known Member
Themenstarter #8
das kann natürlich auch sein. Ich hatte das mit dem Meta-Paket daraus geschlossen, dass ich irgendwo gelesen hatte, der Port sei ein Meta-Port und da steht auch:
Code:
cat /usr/ports/x11/nvidia-driver/pkg-descr 
These are the official NVidia binary drivers for hardware OpenGL rendering
in X11, using the GLX extensions.
Also, Mehrzahl.
Es wurde jedenfalls der neuere 390er Treiber installiert und funktioniert.