• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

openbsd und locale

cdp_xe

Well-Known Member
Themenstarter #1
hallo.

ich habe openbsd-current (stand mitte dezember) laufen, allerdings probleme mit der c-library.
unterstützt openbsd wirklich keine locale?

ich habe alte threats im forum gefunden. darauf hin habe ich eine 'german' login-class für de_DE@ISO8859-15 angelegt. die LC_*-variablen hatte ich bereits vorher auf de_DE@ISO8859-15 gesetzt..

habe auch de_DE@euro, de_DE@ISO8859-1 und de_DE probiert, läuft aber alles nicht.

perl meldet nach wie vor

Code:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LC_ALL = "de_DE.ISO8859-1",
        LANG = "de_DE.ISO8859-1"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
centericq und sylpheed kommen daher nicht mit umlauten klar, was mich ziehmlich stört. hat jemand eine idee?
 

Arjan

Well-Known Member
#2
Nee, locale wird nicht unterstützt in OBSD.

Als User benutze ich die Bash, in der .bashrc steht bei mir:

export LANG=de_DE.ISO8855-15
export LC_ALL=de_DE.ISO8859-15

export MM_CHARSET=ISO8859-15

das hilft zumindest bei den Umlauten, auch auf Konsole und xterm.

Beim Sylpheed kannst Du den Charset extra einstellen, eigentlich auch bei vielen anderen Programmen.


HTH

Gruss

:cool:
 

romp

New Member
#3
hallo erst mal und habt dank für eure beiträge, die mich schon während meiner ersten openBSD-gehversuche :) schon unterstützt haben ( KDE läuft :D ).

ein problem läßt mich jetzt aber nicht mehr zur ruhe kommen:

nach dem login in der konsole: (ksh)

* keine umlaute (öäüß) nur "piepser"
* der mc reagiert nicht auf die tasten F1-F5 (ausgabe ist "11~" - "15~") aber F10 geht wieder (bei F6-F9 reagiert er auch )


aber.....:eek:....starte ich X (startx / startkde) sind die umlaute da (xterm) und mc
reagiert auf F1-F10 richtig.....:confused:

folgendes hab ich schon konfiguriert/getestet:

1. /etc/kbdtype == de

2. in .profile & .cshrc

Arjan hat gesagt.:
........

export LANG=de_DE.ISO8855-15
export LC_ALL=de_DE.ISO8859-15

export MM_CHARSET=ISO8859-15

..........
3. /etc/X11/xkb/X0-config.keyboard == Rules="xorg"
== MouseKeysCurve=0

4. /etc/X11/xorg.conf

...Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection....
.
.
.
.....Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
EndSection....




hoffe, ich hab' nichts vergessen.


weiß jemand, an welcher "schraube" ich noch drehen kann/muß, um der maschine ihre zicken abzugewöhnen???

gruß und dank im vorraus
romp

PS.: komme aus der debian "ecke" und kenne "locale" von dort....

Arjan hat gesagt.:
Nee, locale wird nicht unterstützt in OBSD.
..........
;'(
 
#4
ich weiß jetzt nicht mehr genau welche schraube für welches
problem hilft, aber wenn's dich interessiert lies nach.

aus ~/.inputrc
set metaflag on
set convert-meta off
set output-meta on

aus ~/.profile
set +o emacs-usemeta
bind '^XH'=beginning-of-line # POS1/HOME
bind '^XF'=end-of-line # END
bind '^[[3'=prefix-2 # DEL
bind '^[[3~'=delete-char-forward # DEL
 

romp

New Member
#5
....LOL.....


habs fast hinbekommen.....öäüß gehen ....


die lösung war....



.....eine andere tastatur :D :D :D ... hab die FUS gegen eine SieNix ersetzt ;)



hab auch oben vergessen zu erwähnen, dass das switchen zw den konsolen möglich war (strg+alt+F2, etc) nur unter mc verweigerten die F1-F5 tasten ihre funktion.
scheint wohl am mc zu liegen...


@guebbbi : thx für deinen tipp.... hab da auch noch dies gefunden:

http://www.datacomm.ch/prutishauser/mytxt/dot.inputrc

edit:/ http://www.buha.info/board/showthread.php?t=49737&highlight=openbsd
 
Zuletzt bearbeitet:

SteWo

OpenBSD User
#6
Hallo cdp_xe

Ich weiß nicht, ob Dein Problem hinsichtlich Sylpheed bereits gelöst ist - hier meine Lösung (auch OpenBSD 4.0-GENERIC):

Bei mir kommt Fluxbox zum Einsatz. Sylpheed rufe ich in der ~/.fluxbox/menu wie folgt auf:
Code:
[exec] (Sylpheed) {LANG=de_DE.ISO8859-15 /usr/local/bin/sylpheed-claws}
Ohne das 'LANG=' sind die Umlaute problematisch:cool:

Hast Du ausserhalb dieses Threads etwas zu dem locale-Problem von Perl etwas in Erfahrung bringen können? DAS Problem habe ich nämlich ebenfalls...
:confused:

Darüber hinaus habe ich das gleiche Problem wie romp, nur das ich die Laptop-Tastatur nicht austauschen kann... Dazu starte ich aber noch einen separaten Thread.

Hoffe, ich konnte Dir ein wenig weiterhelfen.

Gruß,
SteWo