• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

openbsd und Remote printing über cups

H

holgerw

Guest
Themenstarter #1
Hallo,

nun habe ich aus Neugier mal ein openBSD 6.1 auf meine zweite SSD installiert (Uefi), über die Intel Haswell-Grafik läuft der Xserver ordentlich mit xfce4, Anwendungen wie claws-mail und firefox gehen auch gut und erfreulich finde ich, dass unter audacity ohne Basteleien Musik über den Intel-On-Board-Soundchip zu hören ist.

Der Bootloader von FreeBSD auf der ersten ssd wurde übrigens nicht überschrieben :)

ssh-Zugriff auf andere Maschinen im Netzwerk läuft auch.

Nun möchte ich auch gerne auf die Drucker meines Print-Servers (Debian 9 mit cups und turboprint) zugreifen.

Nur wie? Leider finde ich auf der openBSD Seite keine Hinweise zum korrekten Einrichten von cups, cups-browsed. Wo kann ich mich dazu einlesen?
cups läuft übrigens, ich kann über localhost:631 das Webinterface aufrufen, als root drucken auf entfernten Systemen erlauben u.s.f. und die Änderungen werden auch ohne Fehlerausgabe übernommen. cups läuft also schonmal korrekt.
Brauche ich hier auch avahi oder geht das ohne? Ich stochere da gerade ein bischen herum, weil ich da keine Doku zu finde.

Viele Grüße
Holger
 

crotchmaster

happy BSD user
#2
Moin,

Avahi brauchst Du nicht unbedingt. Nur für den Fall, dass Dein OpenBSD Rechner als Printserver im lokalen Netz via bonjour gefunden werden soll. Für AirPrint wird es benötigt, müsste aber noch etwas nachgearbeitet werden.

Hast Du denn schon einen Drucker über das lokale cups Webinterface eingerichtet? Der 'Assistent' unter Administration zum Einrichten eines Druckers erklärt sich mehr oder weniger von selbst.
Er fragt nach dem verwendeten Protokoll (IPP, LPD, ..), IP-Adresse/Hostnamen, Druckprotokoll (PCL, PostScript, ..) usw.
 
H

holgerw

Guest
Themenstarter #4
Hallo,

Hast Du denn schon einen Drucker über das lokale cups Webinterface eingerichtet? Der 'Assistent' unter Administration zum Einrichten eines Druckers erklärt sich mehr oder weniger von selbst.
Danke, wegen avahi unter FreeeBSD brauche ich das bei FreeBSD gar nicht zu machen, aber wenn ich unter OpenBSD kein avahi verwende, versuche ich das mal manuell über das Webinterface.

Danke auch Dir, ich versuche es erstmal manuell per cups- Webinterface, das mit lpr ist dann ein weiterer Ansatz, gut zu wissen.
 
#5
Hast Du mal in ``/usr/local/share/doc/pkg-readme`` geschaut? Manchmal sind noch einige händische Anpassung möglich.

https://cvsweb.openbsd.org/cgi-bin/...in?rev=1.18&content-type=text/x-cvsweb-markup
https://cvsweb.openbsd.org/cgi-bin/...ain?rev=1.9&content-type=text/x-cvsweb-markup

Ansonsten würde ich auch noch einige Anpassungen bezüglich der allgemeinen perfomance einstellen. Ich habe diesen link hier schon ein paar mal geposted, aber evtl. hilft er Dir ja weiter. Wichtig hierbei, dass Dein user in der Gruppe ``staff'' ist und die ``/etc/login.conf'' und ``/etc/sysctl.conf'' angepasst wurde, siehe:

https://home.nuug.no/~peter/transition/eurobsdcon2014/desktop.html
https://home.nuug.no/~peter/transition/eurobsdcon2014/desktop2.html
 
H

holgerw

Guest
Themenstarter #6
Hallo @midnight

danke, da habe ich ja einiges zum Lesen und Durchprobieren.

Wenn denn mein poudriere Repo fertig geworden ist, werde ich mal nach OpenBSD wechseln und einiges ausprobieren, vor allem erst einmal die Remote Drucker für das System verfügbar machen.
 
H

holgerw

Guest
Themenstarter #7
Hallo,

dank einiger Links mit weiteren Hinweisen hier habe ich gestern das OpenBSD nochmals komplett neu aufgesetzt, dauert ja nur wenige Minuten, und diesmal gleich den grafischen Login gewählt.
Nach Anpassungen der ~/.xsession, der /etc/rc.conf.local und dem Wechsel auf die bash (die .bashrc habe ich dann von einem Debian System übernommen) habe ich ein komplett deutsch lokalisiertes Xfce4 mit claws-mail, firefox, audacity u.s.f.

ssh und nfs geht wie beim FreeBSD-Client auch, gerade bezogen auf ssh ist das ja auch klar, da openssh auf allen drei Systemen standardmäßig genutzt wird.

Um die Drucker werde ich mich nun noch kümmern, dann noch ein paar Anpassungen vornehmen wie Zugriff auf USB-Sticks, Audio-CDs auslesen, brennen und weiteres.

Bisher habe ich den Eindruck, dass ich unter OpenBSD auch das machen kann, was ich unter FreeBSD und Linux auf dem Desktop mache.

Ich werde zwar bei FreeBSD als Hauptsystem bleiben, finde es aber spannend, auch mal ein anderss BSD kennen zu lernen, daher werde ich OpenBSD parallel zum FreeBSD installiert lassen, und vergleichen.

Was mir nun noch nicht klar ist: Wie füge ich permanent cups hinzu, dass es auch beim Hochfahren sauber startet und ich als Nutzer auch vollen Zugriff habe? Das geht aus der README - soweit ich das überschaue - nicht hervor.

Unter FreeBSD muss ich ja bloß in der /etc/rc.conf cups aktivieren, die Nutzer (in den Gruppen wheel und operator) haben dann auch Zugriff.

Was mir schon mit der vorigen Installation gelungen ist: Auf dem Debian habe ich openbsd-inetd installiert und aktiviert, ich konnte dann vom OpenBSD-Client einen lpd Raw Drucker konfigurieren und als Root eine Testseite korrekt über das Webinterface ausdrucken. Als User tauchte der Drucker allerdings in den Anwendungen nicht auf, bei Firefox führt die Auswahl "Druckvorschau" sogar reproduzierbar zum Einfrieren von Firefox.

Mir fehlt da ein wenig ein kompaktes Howto zu cups unter OpenBSD, was ja nicht weiter tragisch ist, wenn einige Einzelhinweise ebenfalls zum Erfolg führen :)
 
H

holgerw

Guest
Themenstarter #8
Hallo,

erst einmal sollte man um das Tool rcctl wissen.

Ich habe folgendes gemacht:
- pkg_add cups
- rcctl enable cupsd && rcctl start cupsd
- rcctl enable cups_browsed && rcctl start cups_browsed

Edit: avahi und /etc/cups/client.conf werden nicht benötigt.

Dann über das Webinterface localhost:631 cups aufgerufen und als Root den Drucker
lpd://farbmaus/tp0
als Raw-Device hinzu gefügt

Ich kann als Root eine Testseite drucken und ich kann als User holger mit dem Befehl
Code:
lp -d tp0
drucken.

Das ist doch schon mal ein Fortschritt. :)
 
H

holgerw

Guest
Themenstarter #9
Hallo,

und hier die elegante Lösung:
1. in /etc/cups/client.conf die IP des Printservers samt Cups-Port eintragen:
Code:
ServerName 192.168.1.30:631
2. Avahi verfügbar machen
Code:
rcctl enable avahi_daemon && rcctl start avahi_daemon
3. Cups-Browsed verfügbar machen
Code:
rcctl enable cups_browsed && rcctl start cups_browsed
4. Für Druck aus gtk-Anwendungen:
Code:
pkg_add gtk+2-cups gtk+3-cups
Hinweis: cupsd muss dafür nicht aktiviert und gestartet werden.

Den Nutzern stehen nun alle Drucker, die auf dem Debian-Printserver eingerichtet sind, unter dem openBSD-Client zur Verfügung.
 
R

ralli

Guest
Themenstarter #11
Hier mal meine kleine Installationsanleitung, hoffentlich hilfreich und nicht OT, wer es mal ausprobieren möchte:

OpenBSD Version 6.1 installieren

Nach der Grundinstallation neu booten:

Pfad für Package Server einstellen:

im Homeverzeichnis in die .profile eintragen:

export PKG_PATH=https://ftp.spline.de/pub/OpenBSD/6.1/packages/amd64/

Editor installieren:

pkg_add ee

Neuen User ralph anlegen:

useradd -g wheel -m -k /etc/skel/ -d /home/ralph ralph

Für User ralph neues Passwort einrichten:

passwd ralph

xxxxxxxxxx

Als root:

ee /etc/group

In der ersten Zeile root löschen und ralph eintragen

von

wheel:*:0:root auf wheel:*:0:ralph ändern

XFCE4 Desktop installieren

pkg_add -v consolekit2 xfce xfce-extras evince firefox firefox-i18n-de thunderbird thunderbird-i18n-de xscreensaver

In die .xinitrc eintragen:

export LANG=de_DE.UTF-8

setxkbmap de

exec startxfce4

CD oder DVD mounten:

mount -t cd9660 /dev/cd0a /mnt

Stand: 21. August 2017

Bei mir läuft alles out of the box ohne Anpassung und Änderung.
 

Rakor

Administrator
Mitarbeiter
#15
Passend wäre ralph zusätzlich in die Gruppe aufzunehemen. Gruppen können ja mehrere Benutzer enthalten (das ist ja eben auch der Nutzen dahinter).
Wobei das nun alles wenig mit Cups zu tun hat. Ich würde empfehlen zur Vertiefung der Fragen rund um die Grundinstallation von OpenBSD einen neuen Thread zu eröffnen, dann findet es später ein Suchender auch.
 
R

ralli

Guest
Themenstarter #17
Passend wäre ralph zusätzlich in die Gruppe aufzunehemen. Gruppen können ja mehrere Benutzer enthalten (das ist ja eben auch der Nutzen dahinter).
Wobei das nun alles wenig mit Cups zu tun hat. Ich würde empfehlen zur Vertiefung der Fragen rund um die Grundinstallation von OpenBSD einen neuen Thread zu eröffnen, dann findet es später ein Suchender auch.
Hallo @Rakor,

Du hast natürlich Recht, entschuldige bitte, mein Thread war hier deplaziert. Ich habe einen neuen aufgemacht und den Fehler korrigiert. Könntest Du bitte den deplazierten löschen?
 
#18
Weil ich sonst als normaler User nicht mit su zum Installieren weiterer Pakete arbeiten konnte. Wenn das verkehrt ist, bitte um Info, damit ich das richtig korrigieren kann. Ist es richtig root zu lassen und zusätzlich ralph einzutragen?
Auch wenn "su" vorhanden ist, sollte man sich lieber die 2 Minuten Zeit nehmen "doas" in der /etc/doas.conf richtig zu konfigurieren (doas = sudo replacement).

https://man.openbsd.org/doas.conf
 
H

holgerw

Guest
Themenstarter #20
Wenn du eine Client.conf hast, braucht du eigentlich kein Avahi oder den Cups-browsed.
Edit: Oliver, Du hast Recht. Ich habe es gerade mal beim FreeBSD-System getestet:

Es reicht tatsächlich nur die Installation von cups und dann der Eintrag in der client.conf.
Es muss weder cupsd aktiviert werden, noch avahi-daemon, noch cups_browsed.

Bei OpenBSD werde ich es auch mal umstellen.
 
Zuletzt bearbeitet von einem Moderator:
H

holgerw

Guest
Themenstarter #21
Hier noch mal zusammengefasst das korrekte Vorgehen für openBSD-Clients, die auf Cups-Remote-Printer zugreifen sollen, danke an @derOliver

1. cupsd installieren aber nicht aktivieren
2. In die /etc/cups/client.conf: ServerName xxx.xxx.xxx.xxx:631
3. gtk+2-cups und gtk+3-cups installieren
 
H

holgerw

Guest
Themenstarter #23
Och, avahi ist doch ganz harmlos.

Wobei ich gestern leichtfertig ein
Code:
pgk_add okular
abgesetzt habe, um Drucken aus QT-Anwendungen zu testen, da kam dann pulseaudio gleich mit auf die Platte.

Aber nun bitte nicht auch noch das gewisse "S"-Wort aussprechen, sonst macht @Yamagi hier vielleicht dicht :D