• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

OpenBSD3.3 - X11 - SS5

andras98

Well-Known Member
Themenstarter #1
Hi,

Nachdem ich jetzt endlich einen 13W3 Adapter habe moechte ich nachtraeglich X11 auf meine SparcStation5 installieren. Ich hab alle x*.tgz entpackt.
Leider habe ich ueberhaupt keine Ahnung wie die eingebauten Komponenten heissen (Grafikkarte etc.).
In der sysctl.conf habe ich nicht "machdep.allowaperture=2 " eingetragen da es laut "man xf86" nicht fuer meine Architektur gebraucht wird.
Leider bekomme ich kein X11 zum laufen (siehe unten XF86 log).
Auch die Meldung:
(EE) No OS PCI support available
irritiert mich. Gibts ueberhaupt eine Sparc mit PCI Slots?

Also Maus verwende ich eine optische vom Typ5. Hab aber auch eine mit Kugel.

Viel Fragen

Danke fuer eure Hilfe,

Andreas

Meine dmesg:

OpenBSD 3.3 (GENERIC) #14: Sat Mar 29 15:13:34 MST 2003
deraadt@sparc.openbsd.org:/usr/src/sys/arch/sparc/compile/GENERIC
real mem = 66789376
avail mem = 58793984
using 200 buffers containing 3338240 bytes of memory
bootpath: /iommu@0,10000000/sbus@0,10001000/espdma@5,8400000/esp@5,8800000/sd@3,0
mainb us0 (root): SUNW,SPARCstation-5
cpu0 at mainbus0: MB86904 @ 70 MHz, on-chip FPU
cpu0: 16K instruction (32 b/l), 8K data (16 b/l) cache enabled
obio0 at mainbus0
clock0 at obio0 addr 0x71200000: mk48t08 (eeprom)
timer0 at obio0 addr 0x71d00000 delay constant 33
zs0 at obio0 addr 0x71100000 pri 12, softpri 6
zstty0 at zs0 channel 0
zstty1 at zs0 channel 1
zs1 at obio0 addr 0x71000000 pri 12, softpri 6
zskbd0 at zs1 channel 0: keyboard, type 5, layout 0x25
wskbd0 at zskbd0: console keyboard
zstty2 at zs1 channel 1: mouse
slavioconfig at obio0 addr 0x71800000 not configured
auxreg0 at obio0 addr 0x71900000
power0 at obio0 addr 0x71910000
fdc0 at obio0 addr 0x71400000 pri 11, softpri 4: chip 82077
iommu0 at mainbus0 addr 0x10000000: version 0x4/0x0, page-size 4096, range 64MB
sbus0 at iommu0: clock = 23.333 MHz
dma0 at sbus0 slot 5 offset 0x8400000: rev 2
esp0 at dma0 offset 0x8800000 pri 4: ESP200, 40MHz, SCSI ID 7
scsibus0 at esp0: 8 targets
sd0 at scsibus0 targ 3 lun 0: <SEAGATE, ST11200N ST31230, 0378> SCSI2 0/direct fixed
sd0: 1010MB, 3992 cyl, 5 head, 103 sec, 512 bytes/sec, 2069860 sec total
bpp0 at sbus0 slot 5 offset 0xc800000: DMA2
ledma0 at sbus0 slot 5 offset 0x8400010: rev 2
le0 at ledma0 offset 0x8c00000 pri 6: address 08:00:20:20:c9:67
le0: 16 receive buffers, 4 transmit buffers
audiocs0 at sbus0 slot 4 offset 0xc000000 pri 9, softpri 4
audio0 at audiocs0
power-management at sbus0 slot 4 offset 0xa000000 not configured
cgsix0 at sbus0 slot 3 offset 0x0: SUNW,501-2325, 1024x768, rev 11
wsdisplay0 at cgsix0: console (std, sun emulation), using wskbd0
root on sd0a
rootdev=0x700 rrootdev=0x1100 rawdev=0x1102
mars# OpenBSD 3.3 (GENERIC) #14: Sat Mar 29 15:13:34 MST 2003
deraadt@sparc.openbsd.org:/usr/src/sys/arch/sparc/compile/GENERIC
real mem = 66789376
avail mem = 58793984
using 200 buffers containing 3338240 bytes of memory
bootpath: /iommu@0,10000000/sbus@0,10001000/espdma@5,8400000/esp@5,8800000/sd@3,0
mainb us0 (root): SUNW,SPARCstation-5
cpu0 at mainbus0: MB86904 @ 70 MHz, on-chip FPU
cpu0: 16K instruction (32 b/l), 8K data (16 b/l) cache enabled
obio0 at mainbus0
clock0 at obio0 addr 0x71200000: mk48t08 (eeprom)
timer0 at obio0 addr 0x71d00000 delay consBadly placed ()'s.

mein xfree86 log:

(EE) No OS PCI support available
(--) Using wscons driver

XFree86 Version 4.2.1 (for OpenBSD) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 3 September 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: OpenBSD 3.3 sparc [ELF]
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Nov 13 13:46:39 2003
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "wsfb"
[...]
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "wsfb"
(II) Loading /usr/X11R6/lib/modules/drivers/wsfb_drv.o
(II) Module wsfb: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.3
(II) wsfb: driver for wsdisplay framebuffer: wsfb
(II) wsfb(0): using /dev/ttyC0
(II) Running in FRAMEBUFFER Mode
(**) wsfb(0): Depth 16, (--) framebuffer bpp 16
(==) wsfb(0): RGB weight 565
(==) wsfb(0): Default visual is TrueColor
(==) wsfb(0): Using gamma correction (1.0, 1.0, 1.0)
(II) wsfb(0): Vidmem: 6144k
(==) wsfb(0): DPI set to (75, 75)
(**) wsfb(0): Using "Shadow Framebuffer"
(II) Loading sub module "shadow"
(II) LoadModule: "shadow"
(II) Loading /usr/X11R6/lib/modules/libshadow.a
(II) Module shadow: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.1
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.2.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.1
(==) wsfb(0): Backing store disabled
Symbol xf4bppScreenInit from module /usr/X11R6/lib/modules/drivers/wsfb_drv.o is unresolved!
Symbol xf1bppScreenInit from module /usr/X11R6/lib/modules/drivers/wsfb_drv.o is unresolved!
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(**) Option "Protocol" "Microsoft"
(**) zsmouse0: Protocol: "Microsoft"
(**) Option "CorePointer"
(**) zsmouse0: Core Pointer
(**) Option "Device" "/dev/ttyc"
(**) Option "BaudRate" "1200"
(**) Option "StopBits" "1"
(**) Option "DataBits" "7"
(**) Option "Parity" "None"
(**) Option "Vmin" "1"
(**) Option "Vtime" "0"
(**) Option "FlowControl" "None"
(==) zsmouse0: Buttons: 3
(**) zsmouse0: BaudRate: 1200
(II) Keyboard "Keyboard0" handled by legacy driver
(II) XINPUT: Adding extended input device "zsmouse0" (type: MOUSE)
(**) Option "BaudRate" "1200"
(WW) fcntl(9, F_SETOWN): Inappropriate ioctl for device

Fatal server error:
Caught signal 11. Server aborting
 
#2
Hi,

sparc mit PCI waer mir neu (sparc64 gibt's mit PCI).

Deine Grafikkarte ist cgsix0, aber das Problem liegt wohl
eher in den mouse settings.

X11 unter sparc ist mir selber allerdings ueberhaupt nicht
gelaeufig.
Schick doch mal mit dmesg und aktueller XF86Config das ganze
an sparc@openbsd.org (auf englisch ;>) da sitzen Leute,
die zu dem Thema was sagen koennen.

HTH,