• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Openvpn Client einrichten

Themenstarter #1
Hallo BSD-Gemeinde. Ich bin seit 20 Jahren unter der Non-Redmond-Welt unterwegs. Allerdings geht Ubuntu ganz eigene Wege, Debian zieht nach, was bleibt ist Devuan, dessen Installation irgendwie nicht so gut funzt, wie diese von Openbsd, welches ich gerade benutze. Also möchte ich komplett umsteigen. Allerdings sind da doch einige Unterschiede, mit denen ich nicht klarkomme.

Mein Wissen: Openvpn wird installiert, der Server steht und funktioniert auch, der statische Schlüssel wird da abgelegt, wo die client.conf hinzeigt, welche im /etc/openvpn/ -Verzeichnis liegt. So funzt das schon mal nicht. Ich habe schon einiges probiert, aber alles endete in einer Sachgasse, Google und co sind da im Moment auch keine Hilfe...

Weiss einer von Euch, wie das geht?

Der olle Schwedeii
 

foxit

Well-Known Member
#2
Hallo,

Zeig doch einfach mal alle deine Configs, die Logfiles, die Kommandos (auch die Reihenfolge), welche du verwendest. Dann kann dir vielleicht auch jemand mit einem Tipp helfen. So ist das nur Kaffeesatz lesen.
 
Themenstarter #3
Meine /etc/openvpn/client.conf:

#IP-Adressen _IM_ VPN
ifconfig 192.168.2.10 192.168.2.9
secret /pfad_zum_Schlüssel/key.key
#diesen Port fuer UDP in der Firewall oeffnen
port 0815
proto udp
#um NAT-Tabelleneintraege nicht verfallen zu lassen(ping)
keepalive 18 86
#server adresse
remote 192.168.1.1
#device tun nutzen
dev tun0
route-gateway 192.168.2.9
redirect-gateway
#komprimierung
comp-lzo
#mtu kleiner als DSL-mtu
tun-mtu 1400
#tunnel immer offen halten
persist-tun
#key halten bei restart der verbind
persist-key
#Verschluesselungsmodus
cipher AES-256-CBC
#nach dem lesen der konfig und dem Start wird openvpn auf diese Userid gesetzt
user nobody
group nogroup
#openvpn soll sich von der konsole abkoppeln
#daemon
#verb 5

Wo ich die logs für Openvpn finde, weiss ich nicht...
 
Zuletzt bearbeitet:
Themenstarter #5
Okay, bis dahin schon nicht schlecht, ich habe eine Anleitung gefunden, unter welcher der Dienst gestartet werden kann. Nun habe ich den die Config in client.ovpn umbenannt, und eine:
hostname.tun0 mit dem Inhalt:
!usr/local/sbin/openvpn --daemon --config /etc/openvpn/client.ovpn

angelegt. der Rechner routet aber noch nicht um, sprich, die alte default-route 192.168.1.1 bleibt bestehen. Nachdem ich die default-route geändert hatte, kam ich erst mal raus, aber der Rechner verschluckt sich, irgend etwas muss ich noch tun, damit es sauber läuft...
 

Columbo0815

Kaffeemann
Mitarbeiter
#6
Moin,

besteht die Möglichkeit, dass du die server.conf zeigst? Was möchtest du mit dem VPN eigentlich erreichen? Wenn ich die Config richtig deute, dann hast du in deinem lokalen Netzwerk einen Rechner 192.168.1.1 stehen. Zu dem willst du eine VPN aufbauen und über die VPN dein Defaultgateway haben.

Am Rande: Die Anleitung, die du gefunden hast, ist scheinbar für Windows. Dort enden die Config-Dateien mit ovpn. Wie die Config unter OpenBSD heißt, ist völlig egal. Tu dir den Gefallen und benenne sie so, wie es war. ;) Die Logs sollten nach /var/log/messages geschrieben werden.

HTH
 
Themenstarter #7
#listen to (ip des wlanports)
local 192.168.1.1
tun-mtu 1400
port 0815
proto udp
dev tun2

ifconfig 192.168.2.9 192.168.2.10
persist-tun
comp-lzo
ping 213
secret /pfad_zm_Key/key.key
cipher AES-256-CBC

So sieht's mit dem Server aus. Mit Linux hat das auch Jahre gefunzt. Dazu kommt, dass ich ja schon Verbindungen nach draussen hatte, aber nur äusserst instabil.

Die Anleitung habe ich von hier , ist für Openvpn. Da die Config unkommentiert ist, komme ich nicht richtig klar. Und ja, der Server ist die 192.168.1.1 und soll dann den Defaultgateway auf das VPN legen. Der Server (Devuan) arbeitet als Router, NFS-Server, Print-Server und soll später noch eine Cloud abbekommen. Im Moment gehe ich aber über meinen Anbieter-Router ins internet, da bleiben alle anderen Dienste aussen vor, da die Firewall des Devuan-Servers alles zunagelt.
 

Columbo0815

Kaffeemann
Mitarbeiter
#8
Auch wenn dir das hier nicht weiterhilft: Das ist das Problem, wenn man per copy&paste Beispiele aus dem Internet übernimmt, ohne zu verstehen, was eigentlich passiert.

Auf der von dir verlinkten Seite ist allerdings schön beschrieben, wie du auf Fehlersuche gehen kannst. Nimm aber zusätzlich mal auf beiden Seiten "verb 5" rein und zeige uns die Logfiles. Daneben helfen auch die Ausgabe von "ifconfig" und "netstat -nr" von beiden Seiten.
 
Themenstarter #9
Nun, nicht ganz, ich hab nix per copy&paste übernommen, dies ist die konfig von den Linux-Rechnern, die Jahrelang gefunzt hat (erst Debian, dann Ubuntu und auch Arch, wobei ich mit letzterem gar nicht klarkam). Habe gehofft, dass dies auch unter BSD gleich geht, habe mich aber geirrt. Was was unter Linux bedeutet, weiss ich. Aber wo finde ich die Einstellungen für den zu nutzenden Port in der Anleitung? Und wie wird der Gateway umgestellt? UDP-Protokoll ist okay, ist ja alles dokumentiert.

Nachtrag: Nachdem ich einige händische Einträge ( für Daemons)aus der rc.conf (steht oben drin, Finger wech, ich weiss) wieder entfernt habe, läuft es erst mal. Der Eintrag in der /etc/mygate für die Route hat aber nichts gebracht, da ist keine beim Aufruf # route show aktiv. nachdem ich es aber händisch aufgerufen hatte, läuft die Route erst mal. Habe nun in der rc.conf.local den Befehl: # exec /sbin/route add default 192.168.2.9 eingetragen und hoffe, es läuft damit. Melde mich gleich wieder.

Okay, so ging es auch nicht. es bleibt dabei, die route wird nicht automatisch eingestellt. Das muss noch werden.
 
Zuletzt bearbeitet:

Columbo0815

Kaffeemann
Mitarbeiter
#10
Die Angaben in der Config haben nichts mit dem Betriebssystem zu tun. Sie bewirken unter Windows das selbe wie unter Linux oder (Open)BSD.

Bislang wissen wir ja nicht einmal, ob die Voraussetzungen identisch sind. Was ich nicht ganz verstehe: "Aber wo finde ich die Einstellungen für den zu nutzenden Port in der Anleitung?" Was meinst du damit?

Läuft eine Firewall (pf)?
 
Themenstarter #11
Okay, openvpn ohne Firewall macht nicht viel Sinn, also ja, es läuft eine, und sogar so, dass ich von aussen reinkomme. Aber eben nur über VPN. Und das sollte doch über den gleichen Port laufen. Und das läuft auch alles mittlerweile, aber eben ohne die Route umzustellen. Und ja, die konfig lief auch schon (vor Jahren) auf einem Redmond, nachdem ich die Zeilenumbrüche modifiziert hatte.
 
Themenstarter #12
Nachtrag: nach dieser Anleitung wird die defaultroute erst gesetzt, wenn alle Interfaces konfiguriert wurden, also auch tun0. Aber das scheint nicht der Fall zu sein. wenn ich den Tunnel als default eintrage, besteht keine default-Route. Wenn ich das Netzwerk-interface, über das der Tunnel gehen soll, eintrage und mit den beiden Einträgen:

route-gateway 192.168.2.9
redirect-gateway

umrouten möchte, verschluckt sich der gute ganz mächtig, irgendwas hakt an der Stelle...
 
Themenstarter #13
Okay.die letzte Rettung hat es hinbekommen. Obwohl das script nicht da war:

nano /etc/rc.local

/sbin/route add default 192.168.2.9

eintragen, dann noch:

route-gateway 192.168.2.9
redirect-gateway

mit einer Raute auskommenieren, und es läuft. Nun sind die Grundvoraussetzungen für das BSD geschaffen.