• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Ordner nicht löschbar (Name mit ..)

Themenstarter #1
Hi,

ich hab auf einem Rechner unter WinXP einen Ordner Umbenannt und in der Hektik
irgend eine Tastenkombination gedrückt, so dass der Ordner nun auf ".." endet.
Der Name lautet nun: "[2004-05-01] .." und ich kann ihn nicht mehr unter WinXP löschen
oder umbenennen.

Mein Versuch ihn unter FreeBSD zu löschen scheiterten auch da er auch hier nicht erkannt
wird :(
Eion ls -l bringt folgendes:

tigion@RedThree[DigiCamP..]%>ls -l
ls: [2004-05-01] ..: No such file or directory
total 136
drwxrwxr-x 1 root wheel 8192 Sep 8 18:41 Fotos 2000
drwxrwxr-x 1 root wheel 8192 Sep 8 18:42 Fotos 2001
drwxrwxr-x 1 root wheel 8192 Sep 8 18:42 Fotos 2002
drwxrwxr-x 1 root wheel 8192 Sep 8 18:42 Fotos 2003
drwxrwxr-x 1 root wheel 8192 Sep 8 18:42 Fotos 2004
drwxrwxr-x 1 root wheel 16384 Feb 9 2004 _Diverses
drwxrwxr-x 1 root wheel 32768 Mar 22 18:07 _Katrin
drwxrwxr-x 1 root wheel 49152 Feb 9 2004 _www_temp
tigion@RedThree[DigiCamP..]%>

Ich hoffe hier hat jemand einen Tip für mich, wie ich diesen
Ordner wieder hinbekomme oder entfernen kann.

Danke Tigion
 

Marco

Well-Known Member
#2
Hmm tolle Wurst :D Vielleicht Windows neu installieren? ;)
Ne, mal im Ernst.
1. Was gibt eigentlich ls -al aus?
2. Wenn alles nichts hilft, verschiebe doch alle Daten aus dem Ordner mal wo anders hin und lösche dann rekursiv komplett den Ordner wo sich die merkwürde Datei befindet.
# rm -R derOrdner
Vielleicht haut es ja dann die Datei einfach sammt dem Ordner raus?!
 
Themenstarter #3
ls -la bringt auch kein Ergebnis, weil auch hier eine Fehlermeldung bei dem Ordner
erschient:

ls: [2004-05-01] ..: No such file or directory

das mit dem Rekursive Löschen glaube ich nicht das es geht, da ich denke das Problem
eher darin liegt, dass es nicht als Directory oder File erkannt wird durch die komische
Namensgebung :(

Da aber der Name bei einem einfachen "ls" angezeigt wird muss er ja irgendwie gelistet
sein nur fehlen mir da die Kenntnisse um tiefer ind Filesystem einzusteigen ...
 

Tron

Well-Known Member
#4
Wo liegt die Datei? FAT oder NTFS? wie hast du das Dateisystem gemountet - über Netzerk (mount_smbfs) oder lokal (mount_msdosfs)?
Unter *nix is jeder Dateiname der kein / und kein \0 enthält ein gültiger Dateiname. Windows ist da meines Wissens einiges restriktiver - kein /, \, *, ? - aber wie es mit Punkten steht weiß ich nicht, kann ich mir aber nicht vorstellen.
 
Themenstarter #5
Hi Tron,

es ist keine Datei sondern ein Ordner und er liegt auf einer Fat32 Partition, welche ich unter FreeBSD
gemountet habe (lokal), da ich dachte ihn unter FreeBSD löschen zu können.
 

Marco

Well-Known Member
#6
Hmm das ist merkwürdig, weil eigentlich werden die Infos (ob es sich um eine Datei oder einen Ordner handelt) in der Filesystem FAT hinterlegt. Demnach muss Windows da voll Müll gebaut haben. An dem Name kann es eigentlich nicht liegen meiner Meinung nach.
 

Tron

Well-Known Member
#7
nochmal zum Mitschreiben:
- du hast das ganze per mount_msdosfs gemountet
- ls ohne Parameter zeigt die Datei an
- ls -l macht Zicken

lass mal ein fsck_msdosfs drüber laufen
 
Themenstarter #8
Hi Tron,

ja, per mount msdosfs gemountet
ja, ls ohne Parameter zeigt die Datei an
ja, ls -l macht Zicken oder sobald Details zum Verzeichnis angezeigt werden sollen

root@RedThree[tigion]#>fsck_msdosfs /dev/ad0s7
** /dev/ad0s7 (NO WRITE)
** Phase 1 - Read and Compare FATs
** Phase 2 - Check Cluster Chains
** Phase 3 - Checking Directories
** Phase 4 - Checking for Lost Files
Next free cluster in FSInfo block (1361) not free
fix? no
47706 files, 2808776 free (1399673 clusters)
root@RedThree[tigion]#>

Das kommt bei fsck_msdosfs, wobei er automatisch no gemacht hat
 

Tron

Well-Known Member
#9
** /dev/ad0s7 (NO WRITE) <-- deswegen wurde "no" gewählt
entweder das Dateisystem ist akutell gemountet oder der Benutzer mit dem du das fsck ausgeführt hast hat kein Schreibrecht auf ad0s7

Also ist was faul am Dateisystem...
 
Themenstarter #10
Hi, also Schreibrechte sind vorhanden, weil ich kann Ordner udn Dateien anlegen und hinkopieren.
Das da ein NO WRITE beim Prüfen kommt hat mich auch schon gewundert.

Ich sehe es schon kommen, dass ich den kompletten Festplatteninhalt auslagern muss, um die Partition frei
zu bekommen um sie Formatieren zu können ... :(
 
Themenstarter #11
root@RedThree[DigiCamP..]#>fsck_msdosfs /dev/ad0s7 [21:45]
** /dev/ad0s7 (NO WRITE)
** Phase 1 - Read and Compare FATs
** Phase 2 - Check Cluster Chains
** Phase 3 - Checking Directories
** Phase 4 - Checking for Lost Files
47707 files, 2808768 free (1399672 clusters)
root@RedThree[DigiCamP..]#>

geht jetzt plötzlich ohne Fehlermeldungen ..
 

Tron

Well-Known Member
#12
Hi, also Schreibrechte sind vorhanden, weil ich kann Ordner udn Dateien anlegen und hinkopieren.
o_O
Ich rede vom Schreibrecht auf die Gerätedatei (/dev/ad0s7) nicht auf das gemountete Dateisystem, das sind 2 verschiedene Paar Schuhe.