Package info corrupt

Styx

Universaldilettant
Hallo Leute,
schon seit einer ganzen Weile erhalte ich bei der Benutzung von pkg_info oder pkg_delete folgende Fehlermeldungen:

pkg_info: the package info for package 'acroread7-7.0.1_2,1' is corrupt
pkg_info: the package info for package 'de-acroread7-7.0.1_2,1' is corrupt
pkg_delete: the package info for package 'linux-glib2-2.6.6' is corrupt
pkg_delete: the package info for package 'linux-gtk2-2.4.14_4' is corrupt
pkg_delete: the package info for package 'linuxpluginwrapper-20051113_4' is corrupt

Das kuriose daran ist, dass keines der Programme mehr auf meinem Rechner installiert ist. Alle oben angegebenen Programme sind durch aktuelle Versionen ersetzt worden und das schon vor längerer Zeit. Das System läuft auch stabil und es gibt keine Probleme. Ich will nur wissen, wie ich diese Fehlermeldung beheben kann. Kann ich diese alten Package-Einträge irgendwo löschen oder so?
 

Kamikaze

Warrior of Sunlight
Bist du dir sicher, dass auch die Dateien die zu den Paketen gehörten gelöscht sind?

Wenn ja, kannst du einfach unter /var/db/pkg die entsprechenden Verzeichnisse löschen.
 

Styx

Universaldilettant
Gegenfrage: Was würde passieren, wenn die Dateien nicht gelöscht sind und ich die Verzeichnisse in /var/db/pkg lösche?
 

Kamikaze

Warrior of Sunlight
Dann hättest du tote, ungenutzte Dateien auf dem Rechner, die im besten Fall gar nichts tun im schlimmsten Fall irgendetwas durcheinander bringen.

Meine Empfehlung ist es die Pakete möglichst genau in der Version wieder zu installieren (z.B. über einen entsprechenden CVS Snapshot). Mit FORCE_PKG_REGISTER können bei der Installation dann die alten Einträge überschrieben werden. Danach ist dann eine saubere Deinstallation möglich.
 

Styx

Universaldilettant
So, ich habe es mal gewagt die Verzeichnisse zu löschen, da ich mal beim spontanen durchschauen diverser lib-, bin-, etc. Verzeichnisse auf keine entsprechenden Dateien gestoßen bin. Falls nun Probleme auftauchen sollten, was ich nicht glaube, kann ich die Pakete immer noch mal installieren.

Danke auf jeden Fall!
 
Oben