perl 5.8.2 und p5-Tk beißen sich

i18n

Well-Known Member
Seit neuestem portupgrade beißen sich bei mir perl und p5-Tk. Es sind zwei perl-Versionen installiert, am Ende der Installation von 5.8.2 meint man, ich sollte
Code:
use.perl port
angeben, um alles auf den neuren perl-Standard einzustellen.
Seitem läuft z.B. BBBike nicht mehr, ick bin aus Berlin und mag das Programm recht gern. p5-Tk meint, ich sollte perl auf 5.8x bringen, ist aber schon. Hab auch versucht, perl 5.6.1_14 zu entfernen und dann mittels pkgdb -F alles auf 5.8.2 gelinkt, geht aber auch nicht, und ich fürchte, dann funktionieren andere Anwendungen nicht.
Any ideas?
 

i18n

Well-Known Member
Nun gings doch, aber BBBike bricht ab:
Code:
bbbike
Can't locate loadable object for module Tk::Photo in @INC (@INC contains: /usr/local/BBBike /usr/local/BBBike/images /usr/local/BBBike/lib/5.6.1 /usr/local/BBBike/lib /usr/local/lib/perl5/site_perl/5.8.2/mach /usr/local/lib/perl5/site_perl/5.8.2 /usr/local/lib/perl5/site_perl/5.6.1 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.8.2/BSDPAN /usr/local/lib/perl5/5.8.2/mach /usr/local/lib/perl5/5.8.2 .) at /usr/local/BBBike/lib/Tk/FastSplash.pm line 25
Usage $widget->frame(...)
Tk::FastSplash=HASH(0x8137bc8) is not a Tk object at /usr/local/BBBike/lib/Tk/ProgressSplash.pm line 50.
/home/e/eserte/src/perl/Tk-MyBrowseEntry is not a directory
BEGIN failed--compilation aborted at (eval 27) line 1.
Es wurde keine Quelle für den Empfang der Wetterdaten angegeben.

Not a CODE reference at /usr/local/bin/bbbike line 3861.
 
Oben