phpvirtualbox: Wie installieren OHNE aktuelle PHP-Install zu zerschießen?

testit

Well-Known Member
Hallo,

wenn ich mit pkg_add -r phpvirtualbox installieren, wird automatisch PHP 5.3.5 installiert.

Hat jemand eine Idee, wie man das verhindern kann und die bereits installierte PHP-Version unberührt bleibt?

Über HOLD_PKGS in pkgtools.con funktioniert es schon mal nicht!


Gruß
testit
 

SolarCatcher

Well-Known Member
Hab's nie probiert, aber "pkg_add -rif " müsste gehen

Code:
-i, --no-deps
             Install the package without fetching and installing dependencies.

-f, --force
             Force installation to proceed even if prerequisite packages are
             not installed or the requirements script fails.  Although pkg_add
             will still try to find and auto-install missing prerequisite
             packages, a failure to find one will not be fatal.
 

testit

Well-Known Member
Hallo,

stimmt, das könnte gehen! Vielen Dank!

Ich habe inzw. einfach phpvirtualbox aus dem Port gebaut, wobei mein PHP 5.2.17 in Ruhe gelassen wurde.

Gruß
testit
 
Oben