• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

pkg upgrade macht System unbrauchbar

Krull

Well-Known Member
Themenstarter #1
Hallo,

ich versuche nun schon seit Monaten immer wieder mal meine Pakete mit "pkg upgrade" auf einen aktuellen Stand hochzuziehen (12.1-RELEASE-p10). Es scheitert aber leider, vermutlich an Xorg. Die Aktualisierung an sich läuft ohne Fehlermeldungen durch. Nach dem Neustart allerdings geht dann gar nichts mehr. Ich komme bis zur xdm-Anmeldung. Da aber jetzt die Tastatur kaputt ist, kann ich keine sinnvolle Eingaben mehr machen. Es gibt nur noch Zeichensalat. Drücke ich dieselbe Taste mehrmals hintereinander, werden verschiedene Zeichen ausgegeben, oder auch gar keine. Als wäre es ein Zufallsgenerator. Deshalb kann ich hier auch nicht mehr mit Alt oder Strg ins Terminal wechseln.

Das ist die Stelle an er ich in den Single User Modus boote und versuche zu alten Snapshots zurück zu rollen. Geht hier aber auch nicht, weil beim Rollback des ROOT-Datasets reproduzierbar das System einfriert. Bei kleineren Änderungen an diesem Dateisystem ist das normalerweise kein Problem. Im schlimmsten Fall muss ich mich neu anmelden. Nach einem größeren "pkg upgrade" geht hier aber gar nichts mehr. Die einzige Lösung bisher ist ein Rollback von einem gebooteten Rettungssystem aus.

Da xorg und xdm selbst nicht aktualisiert werden, habe ich xorg-server oder dessen Abhängigkeiten im Verdacht:

Code:
New packages to be INSTALLED:
        libXfont2: 2.0.4

Installed packages to be UPGRADED:
        libdrm: 2.4.99,1 -> 2.4.102,1
        libepoxy: 1.5.2 -> 1.5.4
        libudev-devd: 0.4 -> 0.4.2
        mesa-dri: 18.3.2_9 -> 19.0.8_8
        pixman: 0.38.4 -> 0.40.0
        xkbcomp: 1.4.2 -> 1.4.3
        xkeyboard-config: 2.27 -> 2.30
        xorg-server: 1.18.4_13,1 -> 1.20.8_4,1
Könnte es denn an etwas anderem liegen, als an einem Bug in den Paketen? Ich finde es etwas verstörend, dass so ein schwerer Fehler auch nach Monaten immer noch unverändert auftritt. Bei den eher kleinen Versionssprüngen würde Änderungen in einem Konfigurationsschema eigentlich ausschließen.

Ich habe etwas weiter unten im Brett noch das Thema "Nach Xorg upgrade: Tastaturlayout kaputt" gefunden. Da gab es wohl Probleme mit xorg.conf im Zusammenhang mit Nvidia-Karten. Ich habe jedoch nur eine Intel-Karte bzw. -Chip im Laptop.

In xorg.conf.d/keyboard.conf steht noch das:
Code:
Section "InputClass"
        Identifier          "KeyboardDefaults"
        Driver              "keyboard"
        MatchIsKeyboard "yes"
        Option              "XkbLayout" "de"
        Option              "XkbModel" "pc105"
        Option              "XkbVariant" "nodeadkeys"
EndSection
Was kann man hier noch tun? Funktioniert denn bei euch alles rund?
 

Columbo0815

Kaffeemann
Mitarbeiter
#2
Wie lange ist das letzte Update tatsächlich her? Es gab "vor ein paar Monaten" ein Update, bei dem du ein paar Kleinigkeiten beachten musstest. Ist bei dir xf86-input-libinput installiert? Wenn nicht: Installiere das und werfe alle anderen xf86-input Pakete runter.

Über die Suche solltest du anhand der vorgeschlagenen Pakete auch weitere Threads dazu finden.

HTH
 

Krull

Well-Known Member
Themenstarter #4
Ok, jetzt klappt das Upgrade. Ich habe einfach beide Empfehlungen umgesetzt, sodass ich nicht genau weiß was davon das Wunder bewirkt hat. Deshalb euch beiden einen schönen Dank! ;)
 

Columbo0815

Kaffeemann
Mitarbeiter
#5
Blind Änderungen übernehmen ist nicht ganz optimal. Deshalb versuche ich zu erklären, was du gemacht hast:

Mit dem Update von xorg-server auf 1.20.7 ist xorg-server von devd auf udev umgestiegen. Aus diesem Grund soll man bei Problemen mit den Eingabegeräten x11/libinput und x11-drivers/xf86-input-libinput installieren. Das war meine der beiden "Empfehlungen". Yamagi hat das ganze komplettiert indem er deine xorg.conf so angepasst hat, dass du in Bezug au die Tastatur keine "custom" Konfiguration mehr hast.

HTH