pkg upgrade quarterly -> qt Anwendungen werfen Fehler qt5 14.2 vs 15

serie300

Well-Known Member
Hallo
Ich habe gerade ein pkg upgrade auf meiner FreeBSD 11-2 Maschine gemacht. Danach gehen qt5 Anwendungen nicht mehr.
Cannot mix incompatible Qt library (5.14.2) with this library (5.15.0).

Ursache ist wohl, daß jetzt die qt5-core in Version 15 ist und auch einige Zusatzmodule, diverse Zusatzmodule aber 14.2.

Code:
$ pkg info | grep ^qt5
...
qt5-charts-5.14.2              Qt 5 charts module
qt5-concurrent-5.15.0          Qt multi-threading module
qt5-core-5.15.0_2              Qt core non-graphical module
qt5-datavis3d-5.14.2           Qt 5 3D data visualization module
qt5-dbus-5.15.0                Qt D-Bus inter-process communication module
qt5-declarative-5.14.2         Qt declarative framework for dynamic user interfaces
qt5-designer-5.14.2   
...

Kann man mit überschaubaren Aufwand was selber machen oder sollte man warten, bis ein "pkg upgrade" das repariert?

Serie300
 

serie300

Well-Known Member
Kann sei, daß es einige Module nicht mehr gibt , die Maschine wirdseit Jahren geupdate; aber qt5ct, freecad und stellarium werfen den Fehler. Auffällig ist qt5ct, da das ja zu qt5 gehören sollte.
 

bsd4me

Well-Known Member
Wenn ich das recht interpretiere, dann läuft Dein Server auf Release 11.2. Wäre es möglich da ein Upgrade auf 11.4 zu machen. Das wäre dann der aktuelle/final 11 Release Stand. Vielleicht sind dann ja die Pakete alle wieder da - oder Du muss dann die Pakete auch einfach upgraden...
Hoffe es hilft Dir, Norbert
 

serie300

Well-Known Member
Hallo

FreeBSD V11.2 war Schreibfehler, die Maschine ist eine aktuelle 11.4 Maschine mit allen Patches. Ich versuche mal qt5 zu reinstallieren .OR.. eine von den nicht funktionierenden Anwendungen

Nachtrag: Habe jetzt pkg install der auffälligen Anwendungen versucht -> No packages available to install matching '...' have been found. Ich hoffe mal, daß Anwendungen wie FreeCAD, qt5ct und stellarium nicht auf ewig verschwunden sind.
 
Oben