• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

pkg: Viele "duplicate dependency listing"s

SolarCatcher

Well-Known Member
Themenstarter #1
Seit einigen Monaten meldet sich "pkg upgrade" bei mir immer mit div. "duplicate dependency listing"-Einträgen. Ansich sind die offenbar unproblematisch. Ich verstehe allerdings nicht, was sie mir sagen wollen. Und außerdem machen sie den Output von "pkg upgrade" nicht gerade übersichtlich. Gibt es einen Schalter um das auszublenden? Oder sonst einen Trick?

Falls Ihr es nicht kennt - bei mir (auf einem 11.0-RELEASE Laptop) gibt es eine lange Liste, die so beginnt:
Code:
Checking for upgrades (33 candidates):  9%
pkg: samba44-4.4.3_1: duplicate dependency listing: python27, ignoring
pkg: samba44-4.4.3_1: duplicate dependency listing: libarchive, ignoring
pkg: samba44-4.4.3_1: duplicate dependency listing: python27, ignoring
pkg: samba44-4.4.3_1: duplicate dependency listing: libarchive, ignoring
Checking for upgrades (33 candidates):  15%
pkg: python27-2.7.11_2: duplicate dependency listing: gettext-runtime, ignoring
pkg: python27-2.7.11_2: duplicate dependency listing: gettext-runtime, ignoring
pkg: python27-2.7.12: duplicate dependency listing: gettext-runtime, ignoring
pkg: python27-2.7.12: duplicate dependency listing: gettext-runtime, ignoring
Checking for upgrades (33 candidates):  18%
pkg: py27-setuptools27-20.0: duplicate dependency listing: python27, ignoring
pkg: py27-setuptools27-20.0: duplicate dependency listing: python27, ignoring
pkg: py27-setuptools27-23.1.0: duplicate dependency listing: python27, ignoring
pkg: py27-setuptools27-23.1.0: duplicate dependency listing: python27, ignoring
Checking for upgrades (33 candidates):  21%
pkg: py27-dnspython-1.12.0: duplicate dependency listing: python27, ignoring
pkg: py27-dnspython-1.12.0: duplicate dependency listing: py27-setuptools27, ignoring
pkg: py27-dnspython-1.12.0: duplicate dependency listing: python27, ignoring
pkg: py27-dnspython-1.12.0: duplicate dependency listing: py27-setuptools27, ignoring
...
 

SolarCatcher

Well-Known Member
Themenstarter #3
Danke - das half nicht.

Aber ich habe jetzt die wahre Ursache gefunden: Die Duplicate-Einträge kamen von einem nicht mehr ganz frischen Synth-Repository (ports-mgmt/synth). Habe das Respsitory aus /usr/local/etc/pkg/repos rausgenommen, ein "pkg update -f" durchgeführt und jetzt ist alles wieder fein. Dieser Zusammenhang war mir nicht klar gewesen. Auf diese Idee gebracht hatte mich dieses GH-Issue bezüglich pkg. Da war ein Poudriere-Repo für das Problem verantwortlich.

EDIT: Tippfehler beseitigt