pkg_add Frage

southy

New Member
Hallo erstmal.

Ich versuche grade, mich mal ein bisschen in FreeBSD einzuarbeiten.
Um mit Ports & Pkgs vertraut zu werden, wollte ich einfach mal was installieren. irgendwas kleines, unwichtiges, wo ich nix kaputtmache ;-) - z.b. BitchX oder so, nur zum Spaß.

Aber:
pkg_add -r bitchx_1.0c19-3

kommt immer:
Error: FTP Unable to get ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-4-stable/Latest/bitchx_1.0c19-3.tgz: File unavailable (e.g., file not found, no access)

Lade ich es mir selbst runter (bitchx.tar.gz), kommt:
pkg_add: unable to extract table of contents file from '/tmp/bitchx.tar.gz' - not a package? Selbst ausgepackt geht erst recht nix.

und wenn ich es mit sysinstall versuche, geht auch nix.

dann habe ich gedacht, macht nix, bau ich halt selber.
geht aber auch nicht:

make
gpg --keyserver pgp.mit.edu --recv-key 42D1F77C
gpg: can't get key from keyserver: Connection refused
und in der Folge dann natürlich: Can´t check signature.

Sieht eigentlich nach einer grundsätzlichen Konfigurationsfrage aus: gpg nicht gescheit konfiguriert?!
Das ist jetzt etwas seltsam, denn das System wird eigentlich von einem fähigen BSDler gut gewartet, erst vor ein paar Tagen hat er was kompiliert, make sollte also an sich schon gehen.
- man make bietet leider keine Option, eine checksum-prüfung auszuschalten.

Also irgendwie komme ich nicht weiter. Vielleicht kann mir irgendwer einen Tipp geben, oder was ich irgendwie falschmache.
Danke, Southy
 

CW

Netswimmer
Original geschrieben von southy
Hallo erstmal.

Ich versuche grade, mich mal ein bisschen in FreeBSD einzuarbeiten.
Um mit Ports & Pkgs vertraut zu werden, wollte ich einfach mal was installieren. irgendwas kleines, unwichtiges, wo ich nix kaputtmache ;-) - z.b. BitchX oder so, nur zum Spaß.

Aber:
pkg_add -r bitchx_1.0c19-3

kommt immer:
Error: FTP Unable to get ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-4-stable/Latest/bitchx_1.0c19-3.tgz: File unavailable (e.g., file not found, no access)


Meiner Überprüfung zufolge (als OpenBSD-User) heißt das Paket so: BitchX-1.0c19_1.tgz

Da du nicht angegeben hast, welche FreeBSD-Version fährst, ging ich davon aus, dass du die 4.8 hast.

Zumindest hattest du einen 4-er Pfad in deinen Angaben drinne.

Deswegen kann es sein, dass die Version eine andere ist, aber die Großschreibung von BitchX ist dieselbe geblieben.

Lade ich es mir selbst runter (bitchx.tar.gz), kommt:
pkg_add: unable to extract table of contents file from '/tmp/bitchx.tar.gz' - not a package? Selbst ausgepackt geht erst recht nix.

Ich gehe davon aus, dass du nicht das Package sondern den Source-Tarball heruntergeladen hast.

Informiere dich im handbook über die Ports/Packages usw.

Hier der Link für dich: http://www.freebsd.org/doc/de_DE.ISO8859-1/

und wenn ich es mit sysinstall versuche, geht auch nix.

Hmmm ... dazu kann ich dir nicht viel sagen, da du keine Angaben gegeben hast.

Aber ich gehe davon aus, dass du wohl sysinstall "genötigt" hast, diesen Tarball zu installieren, was nicht klappen konnte.

Halte dich IMMER an die Package-Tarballs von den FreeBSD-Servern.

dann habe ich gedacht, macht nix, bau ich halt selber.
geht aber auch nicht:

make
gpg --keyserver pgp.mit.edu --recv-key 42D1F77C
gpg: can't get key from keyserver: Connection refused
und in der Folge dann natürlich: Can´t check signature.

Hast du make mit root-Rechten ausgeführt?

Sieht eigentlich nach einer grundsätzlichen Konfigurationsfrage aus: gpg nicht gescheit konfiguriert?!
Das ist jetzt etwas seltsam, denn das System wird eigentlich von einem fähigen BSDler gut gewartet, erst vor ein paar Tagen hat er was kompiliert, make sollte also an sich schon gehen.
- man make bietet leider keine Option, eine checksum-prüfung auszuschalten.

Das ist wiederum eine andere Frage und hätte eigentlich einen eigenen Thread verdient.

Versuche es erst mal mit Packages-Installation.

Da oben habe ich dir ja den richtigen Namen des Packages gegeben.

Übrigens: eine Checksum-Überprüfung abzuschalten ist keine sinnvolle Sache.

Also irgendwie komme ich nicht weiter. Vielleicht kann mir irgendwer einen Tipp geben, oder was ich irgendwie falschmache.
Danke, Southy

Erster Tipp: LESEN

Zweiter Tipp: GOOGELN

Dritter Tipp: hier vorbeischauen


Gruß

CW
 
Zuletzt bearbeitet:

asg

push it, don´t hype
Dat Ding heisst "BitchX". Siehe auch in den Ports wie der Port heisst.
Daher --> "pkg_add -r BitchX" macht das was Du willst
 

southy

New Member
Re: Re: pkg_add Frage

Ok, habe mitttlerweile alle Fehler gefunden.
Original geschrieben von CW
Meiner Überprüfung zufolge (als OpenBSD-User) heißt das Paket so: BitchX-1.0c19_1.tgz
Ich gehe davon aus, dass du nicht das Package sondern den Source-Tarball heruntergeladen hast.

In der Tat ;-(
Informiere dich im handbook über die Ports/Packages usw.
Das hatte ich natürlich - aber daß es nur dann ein Paket ist, wenn .tgz/.tbz - habe ich übersehen

Als Dateinamen hatte ich einfach das genommen, was bei Freshports als Überschrift steht - war wohl auch etwas blauäugig, denn scheinbar sind die Namen der Ports dort nicht case-sensitiv
(z.b. auf http://www.freshports.org/irc/bitchx/)
Jetzt habe ich im Porttree auf dem Rechner gesucht und prompt den richtigen Namen gefunden.


Also: meine Fehler waren:
- Unterschied .tar.gz <-> .tgz
- genauen Dateiname nicht im Porttree sondern bei freshports gesucht, wo halt aber kein genauer Dateiname beigegeben ist
- der Rest geht wohl als Folgefehler durch ;-)

Jetzt hats geklappt und ich muss gleich mal kucken, was ich noch installieren könnte, so um nicht aus der Übung zu kommen ;-)

Danke Euch und viele Grüße,
southy
 
Oben