• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

poudriere FreeBSD Current Arm Jail unter FreeBSD 11.1-RELEASE?

minimike

Berufsrevolutionär
Themenstarter #1
Hi

Ich würde ganz gerne auf einem Raspberry Pi 3 FreeBSD installieren

Soweit ich verstanden habe muss es dann zwingend FreeBSD 12-Current sein. Ich habe eine VM mit FreeBSD 11.1-RELEASE und Poudriere das mir schon seit einer Weile treu meine Pakete baut. Bisher nur für 11.1-RELEASE als AMD64 und i386. Wenn ich aber auf diesem System Pakete für 12-Current bauen will muss ich da generrel noch was besonderes Beachten? Oder wird wegen Qemu auch direkt ein Kernel für ARM geladen?
 

sterum

Well-Known Member
#2
Genau das gleiche hab ich lustigerweise vor zwei Wochen auch gemacht.
So wie ich das verstanden habe musst du Pakete für CURRENT auch auF CURRENT bauen.
Übrigens, das Bauen von llvm hat dank Qemu etwa drei Tage gedauert.
 

minimike

Berufsrevolutionär
Themenstarter #3
Ja ich überlege aus dem Grund FreeBSD 12-Current auf dem Pi zu installieren und ein Jail mit FreeBSD 11.1-RELEASE dann auf dem Pi zu Betreiben. So kann ich weiter meine Pakete auf FreeBSD 11.1-RELEASE bauen. Und wenn ich das Pi update werde ich so verfahren. Ich packe vorher das Jail in einen Tar-Ball sichere diesen mit ein paar Configs vom System. Dann flashe ich das Pi mit einem neuen Image und schiebe Jail und Configs wieder drauf. Ich glaube das ist schneller als auf dem Pi mal eben ein BSD neu zu Bauen :)
 

sterum

Well-Known Member
#4
Das mit der 11.1-RELEASE jail ist eine interessante Idee.
Übrigens, die Pakete für den PI hab ich auf meinem i7 gebaut. Aber Qemu verlangsamte den Bau um den Faktor 20 oder so.
 

minimike

Berufsrevolutionär
Themenstarter #5
Ja da bin ich auch gespannt. Ich habe der VM 12 Pferdchen von meinem Xeon D-1541 und 72 GB Ram gegeben
 

minimike

Berufsrevolutionär
Themenstarter #6
Ich stelle es vorerst ein. Weil lang/go geht nicht unter ARM

Code:
is marked as broken on armv6: fails to build: go build runtime: go/pkg/tool/freebsd_arm/5g: wait: interrupted system call