Poudriere: Was schlägt hier fehl?

Status
Für weitere Antworten geschlossen.

cabriofahrer

Well-Known Member
Ich versuche xorg-minimal mit dem Stand von branches/2020Q1 zu bauen. Zweck der Sache ist einen xorg-server zu bekommen, der noch nvidia-driver-304 mit einem alten Nvidia-Chip (Geforce 6100) unterstützt.

Vorausgegangen waren die Befehle

#poudriere jail -c -j 122amd64 -v 12.2-RELEASE
#podriere ports -c -B branches/2020Q1

Der Inhalt von xorgmin-pkglist ist lediglich "x11/xorg-minimal"

Hier die Ausgabe:

Code:
# pwd
/usr/local/etc/poudriere.d
# ls
athlon64-make.conf.bak    hooks            jails            kodi-pkglist        ports            xorgmin-pkglist
# poudriere bulk -f xorgmin-pkglist -j 122amd64 -p 2020Q1
[00:00:01] Creating the reference jail... done
[00:00:32] Mounting system devices for 122amd64-2020Q1
[00:00:32] Mounting ports/packages/distfiles
[00:00:32] Using packages from previously failed build: /usr/local/poudriere/data/packages/122amd64-2020Q1/.building
[00:00:32] Mounting packages from: /usr/local/poudriere/data/packages/122amd64-2020Q1
/etc/resolv.conf -> /usr/local/poudriere/data/.m/122amd64-2020Q1/ref/etc/resolv.conf
[00:00:32] Starting jail 122amd64-2020Q1
[00:00:33] Logs: /usr/local/poudriere/data/logs/bulk/122amd64-2020Q1/2021-04-19_19h37m02s
[00:00:33] Loading MOVED for /usr/local/poudriere/data/.m/122amd64-2020Q1/ref/usr/ports
[00:00:34] Ports supports: FLAVORS SELECTED_OPTIONS
[00:00:34] Gathering ports metadata
[00:00:36] Calculating ports order and dependencies
[00:00:36] pkg package missing, skipping sanity
[00:00:36] Skipping incremental rebuild and repository sanity checks
[00:00:37] Cleaning the build queue
[00:00:37] Sanity checking build queue
[00:00:37] Processing PRIORITY_BOOST
[00:00:37] Balancing pool
[00:00:37] Recording filesystem state for prepkg... done
[00:00:37] Building 145 packages using 4 builders
[00:00:37] Starting/Cloning builders
[00:02:42] Hit CTRL+t at any time to see build progress and stats
[00:02:42] [01] [00:00:00] Building ports-mgmt/pkg | pkg-1.12.0_1
[00:04:06] [01] [00:01:24] Finished ports-mgmt/pkg | pkg-1.12.0_1: Failed: build
[00:04:06] [01] [00:01:24] Skipping devel/autoconf | autoconf-2.69_3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/autoconf-wrapper | autoconf-wrapper-20131203: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/automake | automake-1.16.1_2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/binutils | binutils-2.33.1,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/bison | bison-3.4.2,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping security/ca_root_nss | ca_root_nss-3.51: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/check | check-0.13.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/cmake | cmake-3.15.5: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping ftp/curl | curl-7.67.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/docbook | docbook-1.5: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/docbook-sgml | docbook-sgml-4.5_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/docbook-xml | docbook-xml-5.0_3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/docbook-xsl | docbook-xsl-1.79.1_1,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/expat2 | expat-2.2.8: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11-fonts/font-util | font-util-1.3.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping print/freetype2 | freetype2-2.10.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/gettext-runtime | gettext-runtime-0.20.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/gettext-tools | gettext-tools-0.20.1_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/gmake | gmake-4.2.1_3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping math/gmp | gmp-6.1.2_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping misc/help2man | help2man-1.47.11: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping print/indexinfo | indexinfo-0.3.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/iso8879 | iso8879-1986_3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/jsoncpp | jsoncpp-1.8.1_7: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libICE | libICE-1.0.10,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libSM | libSM-1.2.3,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libX11 | libX11-1.6.9,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libXau | libXau-1.0.9: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libXdamage | libXdamage-1.1.5: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libXdmcp | libXdmcp-1.1.3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libXext | libXext-1.3.4,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libXfixes | libXfixes-5.0.3_2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11-fonts/libXfont | libXfont-1.5.4_2,2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libXi | libXi-1.7.10,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11-toolkits/libXmu | libXmu-1.1.3,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libXrandr | libXrandr-1.5.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libXrender | libXrender-0.9.10_2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11-toolkits/libXt | libXt-1.2.0,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libXv | libXv-1.0.11_2,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libXvMC | libXvMC-1.0.12: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libXxf86vm | libXxf86vm-1.1.4_3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping archivers/libarchive | libarchive-3.4.0,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping graphics/libdrm | libdrm-2.4.99,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/libedit | libedit-3.1.20191211,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/libepoll-shim | libepoll-shim-0.0.20190311: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping graphics/libepoxy | libepoxy-1.5.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/libffi | libffi-3.2.1_3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11-fonts/libfontenc | libfontenc-1.1.4: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping security/libgcrypt | libgcrypt-1.8.5: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping security/libgpg-error | libgpg-error-1.36: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping converters/libiconv | libiconv-1.14_11: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping archivers/liblz4 | liblz4-1.9.2,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping www/libnghttp2 | libnghttp2-1.40.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/libpciaccess | libpciaccess-0.16: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/libpthread-stubs | libpthread-stubs-0.4: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/libtextstyle | libtextstyle-0.20.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/libtool | libtool-2.4.6_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/libunwind | libunwind-20170615: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/libuv | libuv-1.34.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libxcb | libxcb-1.13.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libxkbfile | libxkbfile-1.1.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/libxml2 | libxml2-2.9.10: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/libxshmfence | libxshmfence-1.3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/libxslt | libxslt-1.1.34: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/llvm80 | llvm80-8.0.1_3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping lang/lua52 | lua52-5.2.4: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping archivers/lzo2 | lzo2-2.10_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/m4 | m4-1.4.18_1,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping graphics/mesa-dri | mesa-dri-18.3.2_9: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping graphics/mesa-libs | mesa-libs-18.3.2_3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/meson | meson-0.52.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping math/mpfr | mpfr-4.0.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/ninja | ninja-1.9.0,2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/p5-Locale-gettext | p5-Locale-gettext-1.07: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/p5-Locale-libintl | p5-Locale-libintl-1.31: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping converters/p5-Text-Unidecode | p5-Text-Unidecode-1.30: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/p5-Unicode-EastAsianWidth | p5-Unicode-EastAsianWidth-12.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping misc/pciids | pciids-20191223: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/pcre | pcre-8.43_2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping lang/perl5.30 | perl5-5.30.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/pixman | pixman-0.38.4: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/pkgconf | pkgconf-1.6.3,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-babel@py27 | py27-Babel-2.7.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-MarkupSafe@py27 | py27-MarkupSafe-1.1.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping www/py-beaker@py27 | py27-beaker-1.11.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-funcsigs@py27 | py27-funcsigs-1.0.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-mako@py27 | py27-mako-1.0.14: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-pytz@py27 | py27-pytz-2019.3,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-setuptools@py27 | py27-setuptools-41.4.0_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-babel | py37-Babel-2.7.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-CommonMark | py37-CommonMark-0.9.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-Jinja2 | py37-Jinja2-2.10.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-MarkupSafe | py37-MarkupSafe-1.1.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-alabaster | py37-alabaster-0.7.6: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-asn1crypto | py37-asn1crypto-0.24.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping security/py-certifi | py37-certifi-2019.11.28: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-cffi | py37-cffi-1.13.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-chardet | py37-chardet-3.0.4_3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping security/py-cryptography | py37-cryptography-2.6.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping lang/cython | py37-cython-0.29.13_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-docutils | py37-docutils-0.15.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-future | py37-future-0.18.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping dns/py-idna | py37-idna-2.8: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping graphics/py-imagesize | py37-imagesize-1.1.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping security/py-openssl | py37-openssl-19.0.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-pycparser | py37-pycparser-2.19: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-pygments | py37-pygments-2.4.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping net/py-pysocks | py37-pysocks-1.7.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-pystemmer | py37-pystemmer-1.3.0_2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-pytz | py37-pytz-2019.3,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-recommonmark | py37-recommonmark-0.5.0_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping www/py-requests | py37-requests-2.22.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-setuptools | py37-setuptools-41.4.0_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/py-six | py37-six-1.12.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-snowballstemmer | py37-snowballstemmer-1.2.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-sphinx | py37-sphinx-1.6.5_2,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-sphinx_rtd_theme | py37-sphinx_rtd_theme-0.4.3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/py-sphinxcontrib-websupport | py37-sphinxcontrib-websupport-1.1.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping net/py-urllib3 | py37-urllib3-1.25.6,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping lang/python27 | python27-2.7.17_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping lang/python37 | python37-3.7.6: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/readline | readline-8.0.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping security/rhash | rhash-1.3.5: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/scons | scons-3.1.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/sdocbook-xml | sdocbook-xml-1.1_2,2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/swig30 | swig30-3.0.12: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping print/texinfo | texinfo-6.7_1,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping graphics/wayland | wayland-1.16.0_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping graphics/wayland-protocols | wayland-protocols-1.17: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/xauth | xauth-1.1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/xcb-proto | xcb-proto-1.13_1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11-drivers/xf86-input-keyboard | xf86-input-keyboard-1.9.0_3: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11-drivers/xf86-input-mouse | xf86-input-mouse-1.9.3_2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11-drivers/xf86-video-vesa | xf86-video-vesa-2.4.0_2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/xinit | xinit-1.4.1,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/xkbcomp | xkbcomp-1.4.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/xkeyboard-config | xkeyboard-config-2.27: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/xmlcatmgr | xmlcatmgr-2.2_2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping textproc/xmlcharent | xmlcharent-0.3_2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping devel/xorg-macros | xorg-macros-1.19.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/xorg-minimal | xorg-minimal-7.5.2_2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11-servers/xorg-server | xorg-server-1.18.4_13,1: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/xorgproto | xorgproto-2019.2: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] [01] [00:01:24] Skipping x11/xtrans | xtrans-1.4.0: Dependent port ports-mgmt/pkg | pkg-1.12.0_1 failed
[00:04:06] Stopping 4 builders
[00:04:10] No package built, but repository needs to be created
[00:04:10] Creating pkg repository
[00:04:10] Error: Unable to extract pkg.
[00:04:10] Cleaning up
[00:04:10] Unmounting file systems
 

cabriofahrer

Well-Known Member
Dass der build von pkg fehl schlägt, steht ja da, ich dachte nur, ich hätte etwas falsch gemacht. Wo finde ich denn die logs?
 

Esjott

Kellerkind
unter /usr/local/poudriere/logs/data/bulk/ gibt auch einen Ordner lastest-per-pkg, dort pkg/$versionsnummer/$jailname-$portstree.log ;)
 

cabriofahrer

Well-Known Member
versuch mal 2021Q1.
pkg ist aktuell bei Version 1.16, in deinem Fall wird versucht Version 1.12 zu bauen.
2020Q1 ist der letzte, der noch nicht xorg-server-1.20 hat, deswegen muss das so sein. Ich glaube aber nicht, dass das das Problem ist. Hier die Logdatei, ganz unten stehen die Fehlermeldungen, mit denen ich leider nicht viel anfangen kann:
 

Anhänge

  • pkg-1.12.0_1.txt
    298,5 KB · Aufrufe: 37

foxit

Well-Known Member
@cabriofahrer
Du bist doch jetzt schon wirklich länger dabei. Um hier nützliche Hilfe zu bieten, (mit einer Ports Version die löchriger ist als schweizer Käse!) braucht es schon noch etwas mehr (auch wenn es nur dazu dient meinen Verdacht zu bestätigen). Deine `poudriere.conf`und dein kompletter Befehl zum starten wären doch mal noch sinnvoll.
 

cabriofahrer

Well-Known Member
Ich hatte doch oben die vorausgegangenen Befehle genannt, und der Befehl zum Starten steht im Code-Fenster, aber ich trage es nochmal zusammen:


#poudriere jail -c -j 122amd64 -v 12.2-RELEASE

#podriere ports -c -B branches/2020Q1 -m svn+https -p 2020Q1 (Sorry, war oben nicht komplett und hatte ich früher schon mal ausgeführt)

#poudriere bulk -f xorgmin-pkglist -j 122amd64 -p 2020Q1


Der Inhalt von xorgmin-pkglist ist lediglich "x11/xorg-minimal"

Die poudriere.conf hatte ich nicht gepostet, da es damals damit geklappt hatte, aber hier:

Code:
$ more /usr/local/etc/poudriere.conf

# Poudriere can optionally use ZFS for its ports/jail storage. For
# ZFS define ZPOOL, otherwise set NO_ZFS=yes
#
#### ZFS
# The pool where poudriere will create all the filesystems it needs
# poudriere will use ${ZPOOL}/${ZROOTFS} as its root
#
# You need at least 7GB of free space in this pool to have a working
# poudriere.
#
#ZPOOL=zroot

### NO ZFS
# To not use ZFS, define NO_ZFS=yes
NO_ZFS=yes

# root of the poudriere zfs filesystem, by default /poudriere
# ZROOTFS=/poudriere

# the host where to download sets for the jails setup
# You can specify here a host or an IP
# replace _PROTO_ by http or ftp
# replace _CHANGE_THIS_ by the hostname of the mirrors where you want to fetch
# by default: ftp://ftp.freebsd.org
#
# Also note that every protocols supported by fetch(1) are supported here, even
# file:///
# Suggested: https://download.FreeBSD.org
FREEBSD_HOST=_PROTO_://_CHANGE_THIS_

# By default the jails have no /etc/resolv.conf, you will need to set
# RESOLV_CONF to a file on your hosts system that will be copied has
# /etc/resolv.conf for the jail, except if you don't need it (using an http
# proxy for example)
RESOLV_CONF=/etc/resolv.conf

# The directory where poudriere will store jails and ports
BASEFS=/usr/local/poudriere

# The directory where the jail will store the packages and logs
# by default a zfs filesystem will be created and set to
# ${BASEFS}/data
#
#POUDRIERE_DATA=${BASEFS}/data

# Use portlint to check ports sanity
USE_PORTLINT=no

# When building packages, a memory device can be used to speedup the build.
# Only one of MFSSIZE or USE_TMPFS is supported. TMPFS is generally faster
# and will expand to the needed amount of RAM. MFS is a slower since it
# uses UFS and several abstraction layers.

# If set WRKDIRPREFIX will be mdmfs of the given size (mM or gG)
#MFSSIZE=4G

# Use tmpfs(5)
# This can be a space-separated list of options:
# wrkdir    - Use tmpfs(5) for port building WRKDIRPREFIX
# data      - Use tmpfs(5) for poudriere cache/temp build data
# localbase - Use tmpfs(5) for LOCALBASE (installing ports for packaging/testing)
# all       - Run the entire build in memory, including builder jails.
# yes       - Enables tmpfs(5) for wrkdir and data
# no        - Disable use of tmpfs(5)
# EXAMPLE: USE_TMPFS="wrkdir data"
USE_TMPFS=yes

# How much memory to limit tmpfs size to for *each builder* in GiB
# (default: none)
#TMPFS_LIMIT=8

# How much memory to limit jail processes to for *each builder*
# in GiB (default: none)
#MAX_MEMORY=4

# How many file descriptors to limit each jail process to (default: 1024)
# This can also be set per PKGBASE, such as MAX_FILES_RStudio=2048.
# Package names with hyphens (-) should be replaced with underscores (_).
#MAX_FILES=1024

# If set the given directory will be used for the distfiles
# This allows to share the distfiles between jails and ports tree
# If this is "no", poudriere must be supplied a ports tree that already has
# the required distfiles.
DISTFILES_CACHE=/usr/ports/distfiles

# If set the ports tree or source tree marked to use svn will use the defined
# mirror (default: svn.FreeBSD.org)
# The SSL fingerprints are published here:
# https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/svn.html#svn-mirrors
#SVN_HOST=svn.FreeBSD.org

# Automatic OPTION change detection
# When bulk building packages, compare the options from kept packages to
# the current options to be built. If they differ, the existing package
# will be deleted and the port will be rebuilt.
# Valid options: yes, no, verbose
# verbose will display the old and new options
#CHECK_CHANGED_OPTIONS=verbose

# Automatic Dependency change detection
# When bulk building packages, compare the dependencies from kept packages to
# the current dependencies for every port. If they differ, the existing package
# will be deleted and the port will be rebuilt. This helps catch changes such
# as DEFAULT_RUBY_VERSION, PERL_VERSION, WITHOUT_X11 that change dependencies
# for many ports.
# Valid options: yes, no
# Default: yes
#CHECK_CHANGED_DEPS=yes

# Consider bad dependency lines on the wrong PKGNAME as fatal.
# For example:
#    BUILD_DEPENDS=  p5-List-MoreUtils>=0:lang/p5-List-MoreUtils
# If this port's PKGNAME were really "List-MoreUtils" then it would
# not be recorded into the resulting package.  The next build with
# CHECK_CHANGED_DEPS enabled would consider it a "new dependency"
# since it is in the port but not in the package.  This is usually
# a warning but can be made fatal instead by enabling this option.
# Default: no
#BAD_PKGNAME_DEPS_ARE_FATAL=yes


# Path to the RSA key to sign the PKG repo with. See pkg-repo(8)
#PKG_REPO_SIGNING_KEY=/etc/ssl/keys/repo.key


# ccache support. Supply the path to your ccache cache directory.
# It will be mounted into the jail and be shared among all jails.
# It is recommended that extra ccache configuration be done with
# ccache -o rather than from the environment.
#CCACHE_DIR=/var/cache/ccache

# Static ccache support from host.  This uses the existing
# ccache from the host in the build jail.  This is useful for
# using ccache+memcached which cannot easily be bootstrapped
# otherwise.  The path to the PREFIX where ccache was installed
# must be used here, and ccache must have been built statically.
# Note also that ccache+memcached will require network access
# which is normally disabled.  Separately setting RESTRICT_NETWORKING=no
# may be required for non-localhost memcached servers.
#CCACHE_STATIC_PREFIX=/usr/local

# The jails normally only allow network access during the 'make fetch'
# phase.  This is a security restriction to prevent random things
# ran during a build from accessing the network.  Disabling this
# is not advised.  ALLOW_NETWORKING_PACKAGES may be used to allow networking
# for a subset of packages only.
#RESTRICT_NETWORKING=yes
#ALLOW_NETWORKING_PACKAGES="npm-foo"

# parallel build support.
#
# By default poudriere uses hw.ncpu to determine the number of builders.
# You can override this default by changing PARALLEL_JOBS here, or
# by specifying the -J flag to bulk/testport.
#
# Example to define PARALLEL_JOBS to one single job
# PARALLEL_JOBS=1

# How many jobs should be used for preparing the build? These tend to
# be more IO bound and may be worth tweaking. Default: PARALLEL_JOBS * 1.25
# PREPARE_PARALLEL_JOBS=1


# If set, failed builds will save the WRKDIR to ${POUDRIERE_DATA}/wrkdirs
# SAVE_WRKDIR=yes

# Choose the default format for the workdir packing: could be tar,tgz,tbz,txz
# default is tbz
# WRKDIR_ARCHIVE_FORMAT=tbz

# Disable Linux support
# NOLINUX=yes

# By default poudriere sets FORCE_PACKAGE
# To disable it (useful when building public packages):
# NO_FORCE_PACKAGE=yes

# By default poudriere sets PACKAGE_BUILDING
# To disable it:
# NO_PACKAGE_BUILDING=yes

# If you are using a proxy define it here:
# export HTTP_PROXY=bla
# export FTP_PROXY=bla
#
# Cleanout the restricted packages
# NO_RESTRICTED=yes

# By default MAKE_JOBS is disabled to allow only one process per cpu
# Use the following to allow it anyway
# ALLOW_MAKE_JOBS=yes

# List of packages that will always be allowed to use MAKE_JOBS
# regardless of ALLOW_MAKE_JOBS. This is useful for allowing ports
# which holdup the rest of the queue to build more quickly.
#ALLOW_MAKE_JOBS_PACKAGES="pkg ccache py*"

# Timestamp every line of build logs
# Default: no
#TIMESTAMP_LOGS=no

# URL where your POUDRIERE_DATA/logs are hosted
# This will be used for giving URL hints to the HTML output when
# scheduling and starting builds
#URL_BASE=http://yourdomain.com/poudriere/


# This defines the max time (in seconds) that a command may run for a build
# before it is killed for taking too long. Default: 86400
#MAX_EXECUTION_TIME=86400

# This defines the time (in seconds) before a command is considered to
# be in a runaway state for having no output on stdout. Default: 7200
#NOHANG_TIME=7200


# The repository is updated atomically if set yes. This leaves the
# repository untouched until the build completes. This involves using
# hardlinks and symlinks. The operations are fast, but can be intrusive
# for remote syncing or backups.
# Recommended to always keep on.
# Default: yes
#ATOMIC_PACKAGE_REPOSITORY=yes

# When using ATOMIC_PACKAGE_REPOSITORY, commit the packages if some
# packages fail to build. Ignored ports are considered successful.
# This can be set to 'no' to only commit the packages once no failures
# are encountered.
# Default: yes
#COMMIT_PACKAGES_ON_FAILURE=yes

# Keep older package repositories. This can be used to rollback a system
# or to bisect issues by changing the repository to one of the older
# versions and reinstalling everything with `pkg upgrade -f`
# ATOMIC_PACKAGE_REPOSITORY is required for this.
# Default: no
#KEEP_OLD_PACKAGES=no

# How many old package repositories to keep with KEEP_OLD_PACKAGES
# Default: 5
#KEEP_OLD_PACKAGES_COUNT=5

# Make testing errors fatal.
# If set to 'no', ports with test failure will be marked as failed but still
# packaged to permit testing dependent ports (useful for bulk -t -a)
# Default: yes
#PORTTESTING_FATAL=yes

# Define the building jail hostname to be used when building the packages
# Some port/packages hardcode the hostname of the host during build time
# This is a necessary setup for reproducible builds.
#BUILDER_HOSTNAME=pkg.FreeBSD.org

# Define to get a predictable timestamp on the ports tree
# This is a necessary setup for reproducible builds.
#PRESERVE_TIMESTAMP=yes

# Define to yes to build and stage as a regular user
# Default: yes, unless CCACHE_DIR is set and CCACHE_DIR_NON_ROOT_SAFE is not
# set.  Note that to use ccache with BUILD_AS_NON_ROOT you will need to
# use a non-shared CCACHE_DIR that is only built by PORTBUILD_USER and chowned
# to that user.  Then set CCACHE_DIR_NON_ROOT_SAFE to yes.
#BUILD_AS_NON_ROOT=no

# Define to the username to build as when BUILD_AS_NON_ROOT is yes.
# Default: nobody (uid PORTBUILD_UID)
#PORTBUILD_USER=nobody

# Define to the uid to use for PORTBUILD_USER if the user does not
# already exist in the jail.
# Default: 65532
#PORTBUILD_UID=65534

# Define pkgname globs to boost priority for
# Default: none
#PRIORITY_BOOST="pypy openoffice*"

# Define format for buildnames
# Default: %Y-%m-%d_%Hh%Mm%Ss
# ISO8601:
#BUILDNAME_FORMAT="%FT%TZ"

# Define format for build duration times
# Default: %H:%M:%S
#DURATION_FORMAT="%H:%M:%S"

# Use colors when in a TTY
# Default: yes
#USE_COLORS=yes

# Only build what is requested. Do not rebuild build deps if nothing requested
# depends on them. This can create an inconsistent repository if you often
# build one-off packages but expect the repository to stay consistent.
# Defaut: yes
#TRIM_ORPHANED_BUILD_DEPS=yes

# A list of directories to exclude from leftover and filesystem violation
# mtree checks.  Ccache is used here as an example but is already
# excluded by default.  There is no need to add it here unless a
# special configuration is used where it is a problem.
# Default: none
#LOCAL_MTREE_EXCLUDES="/usr/obj /var/tmp/ccache"

# Set to hosted to use the /data directory instead of inline style HTML
# Default: inline
#HTML_TYPE="hosted"

# Set to track remaining ports in the HTML interface.  This can slow down
# processing of the queue slightly, especially for bulk -a builds.
# Default: no
#HTML_TRACK_REMAINING=yes
 

Azazyel

Well-Known Member
Ich versuche xorg-minimal mit dem Stand von branches/2020Q1 zu bauen. Zweck der Sache ist einen xorg-server zu bekommen, der noch nvidia-driver-304 mit einem alten Nvidia-Chip (Geforce 6100) unterstützt.

Lohnt sich der Zeitaufwand für eine 16 Jahre alte Grafikkarte? :confused:

Für eine mit dem aktuellen Stand lauffähige GPU zahlt man auf eBay inklusive Versand weniger als 5€.
 

KobRheTilla

used register
Ich glaube aber nicht, dass das das Problem ist.
da hilft kein glauben, sondern prüfen.
Ich habe eben auf einem FreeBSD-12.2 die Ports von 2020Q1 ausgecheckt und versucht pkg zu bauen, ging nicht:

Code:
ld: error: undefined symbol: _libmd_SHA256_Final
>>> referenced by check.c
>>>               check.o:(lzma_check_finish) in archive /usr/lib/liblzma.a
cc: error: linker command failed with exit code 1 (use -v to see invocation)
*** [pkg-static] Error code 1
also der selbe Fehler wie bei dir im Logfile.
Du solltest eher einen aktuellen Portstree auschecken und dann prüfen, ob du einfach nur xorg-xserver aus dem 2020Q1-branch dort hinein auscheckst.

Rob
 

cabriofahrer

Well-Known Member
Wenn nur pkg das Problem ist, gibt es dann nicht einen Weg, poudriere mitzuteilen, dass pkg (also als Ausnahmeregelung) NICHT gebaut werden soll? Also ggf. durch einen Eintrag in die Liste "xorgmin-pkglist" oder eine weitere Liste?
Pkg brauche ich sowieso nicht in einer alten Version, die würde sowieso als erstes aktualisiert werden.

Was ich mir eigentlich vorstelle: Auf einer FreeBSD-Installation ohne Packages erstmal "pkg add" der von Poudriere erstellten alten xorg-minimal Packages.
Da pkg auf einem solchen System noch gar nicht existiert, würde das System erst mal fragen, ob es pkg installieren soll. Soll es natürlich und hätte dann gleich die aktuelle Version von pkg. Erst danach könnte man "pkg add" überhaupt ausfüren. Danach ein "pkg lock -a" und ein "pkg unlock pkg", damit man ausser dem xorg Stack aktuelle Packages installieren und aktualisieren kann, da der xorg Stack ziemlich unabhängig vom Rest sein soll. Wie gesagt, es geht letztendlich darum, den Betrieb eines alten Nvidia-Grafikchips zu ermöglichen, da es "nouveau" für FreeBSD lider nicht gibt.
 

Andy_m4

Well-Known Member
Wie gesagt, es geht letztendlich darum, den Betrieb eines alten Nvidia-Grafikchips zu ermöglichen, da es "nouveau" für FreeBSD lider nicht gibt.
Die Frage (die ja auch schon aufgeworfen wurde) ist ja, ob man sich das alles antun sollte wenn man für ein paar Euro fünfzig eine supportete Grafikkarte bekommt. Es tun sich ja hier nur Probleme auf. Jetzt ist es nur das pkg was "fehlt". Als nächstes kommen irgendwelche Abhängigkeiten die ein aktuelleres Xorg voraussetzen. Das wird ein Rattenschwanz ohne Ende.

Vor allem wirds ja künftig nicht besser. Die Probleme werden eher zunehmen. Bei jeden Update musst Du befürchten, das es Schwierigkeiten gibt.
 

cabriofahrer

Well-Known Member
Wo ist eigentlich das Problem, nvidia-driver-304 ist doch noch in den (aktuellen) Ports?
Das ist zwar richtig, aber das Problem ist, dass der xorg-server-1.20 nicht mehr unterstüzt. Nvidia hat offensichtlich den Support diesbezüglich schon vor einer Weile eingestellt.

Und @Andy_m4 , Du hast ja vollkommen Recht. Aus dem Grund habe ich eher Interesse daran, die Kontakte meiner Radeon-Karte zu reinigen, jetzt muss ich erst mal sehen, wo ich so einen "Glasfaserstift" herbekomme...

Alternativ könnte ich auch ein Linux installieren wegen nouveau und als letzte Option wirklich eine andere Graka. Trotzdem würde ich es zunächst mal mit dem alten xorg probieren wollen.
 

Yamagi

Possessed With Psi Powers
Teammitglied
Wo ist eigentlich das Problem, nvidia-driver-304 ist doch noch in den (aktuellen) Ports?
Ich glaube, dass der xorg-server aus den aktuellen Ports Modul-API 24 hat. Der alte nvidia-driver-304 unterstützt aber nur Modul-API 23. Damit lässt der Treiber sich nicht in den Server laden. Aber wenn ich mir https://cgit.freedesktop.org/xorg/xserver/log/hw/xfree86/common/xf86Module.h so anschaue, sind die Änderungen zwischen API 23 und 24 minimal. Ich würde einfach mal probieren im Nvidia-Treiber die die Modul-API hochzudrücken und zu gucken, ob es geht. Ich meine viel mehr als einen Crash beim xorg-server Start kann da nicht passieren.
 

cabriofahrer

Well-Known Member
Ich würde einfach mal probieren im Nvidia-Treiber die die Modul-API hochzudrücken und zu gucken, ob es geht.
Ich verstehe nicht ganz. Was genau muss ich mit dem Nvidia-Treiber machen? Geht "Modul-API hockdrücken" mit dem Package oder muss ich den Nvidia-Treiber aus den Ports installieren und vorher etwas in der Makefile editieren?
 

Yamagi

Possessed With Psi Powers
Teammitglied
Du lädst dir den Code des Nvidia-Treibers herunter, suchst die Stelle der API-Defintion und editierst sie. Vorausgesetzt, dass es im offenen, also im Quellcode vorliegenden Teil ist. Ist es im Blob, hast du verloren. Aber ich meine, dass man xorg-server auch einen Schalter mitgeben kann, der ihn die API-Versionen ignorieren lässt...
 

cabriofahrer

Well-Known Member
Aber ich meine, dass man xorg-server auch einen Schalter mitgeben kann, der ihn die API-Versionen ignorieren lässt...
Das ist die interessantere Variante. Es handelt sich um die "IgnoreABI" Option, wie hier erwähnt: https://www.computerhope.com/unix/xorg.htm

Ich habe demnach die xorg.conf um folgenden Eintrag ergänzt:

Code:
Section "ServerFlags"
    Option "IgnoreABI" "true"
EndSection


Die xorg.conf sieht komplett so aus:

Code:
# nvidia-xconfig:  version 440.64


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "ServerFlags"
    Option "IgnoreABI" "true"
EndSection


Dann habe ich ein "kldload nvidia" gemacht.

Doch leider gibt es bei "startx" nur einen schwarzen Bildschirm mit zwei weißen Balken links oben von oben nach unten, ein Wechsel in eine andere Konsole geht nicht, der Rechner fährt aber runter, wenn ich auf den Einschaltknopf drücke.
Die Xorg.0.log sieht folgendermaßen aus. Der Eintrag "ignoreABI" in der xorg.conf scheint zu wirken, wie sich aus dem entsprechenden Text folgern lässt. Ganz unten erscheint eine Meldung, die ich nicht ganz verstehe, es scheint aber etwas mit der Auflösung zu tun zu haben:

Code:
303.651] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[   303.651] (WW) NVIDIA(0): Unable to support custom viewPortOut 1920 x 1080 +0 +0

Gibt es hier vielleicht doch noch Hoffnung, wenn man einen festen Wert für den Bildschirm / die Auflösung eingibt?
Wie müsste der Eintrag lauten?
 

Crest

rm -rf /*
Teammitglied
Wenn der Rest deines Rechner halbwegs aktuell ist so sollte die iGPU ähnlich schnell sein wie deine >15 Jahre alte Nvidiakarte.
 

cabriofahrer

Well-Known Member
Wenn der Rest deines Rechner halbwegs aktuell ist so sollte die iGPU ähnlich schnell sein wie deine >15 Jahre alte Nvidiakarte.
Die "Nvidiakarte" IST der integrierte Chip auf dem Mainboard (Sockel AM2).
Wenn meine letzte Frage bezüglich der Ausgabe der Xorg.0.log nicht beantwortet werden kann, komme ich nicht weiter. Auf der anderen Seite will ich natürlich noch versuchen, die Kontakte der Radeon-Karte abzuschleifen, habe das Werkzeug dafür aber noch nicht. Die letzte Möglichkeit wäre natürlich eine neue Graka.
Allerdings wäre die Angelegenheit mit der xorg.conf mittlerweile rein aus Wissenserweiterungsgründen interessant.
 

midnight

OpenBSD & FreeBSD
Zum Reinigen von Kontakten nehme ich erst WD-40 und danach Isopropanol. WD-40 hat aehnliche Eigenschaften wie Kontaktspray und entfernt Rost, Oxydationen und sonstigen Schmutz. Isopropanol entfernt dann die Rueckstaende vom WD-40. Diese Kombi ist ein Tipp aus der Retroszene und hat mir bis jetzt immer gute Dienste geleistet. Glasfaserstifte sind aufgrund ihrer metallabtragenden Eigenschaften nicht gut fuer Kontakte geeignet.
 

midnight

OpenBSD & FreeBSD
Muss es WD-40 sein, oder geht auch anderes Öl?
Es gehen auch andere duennfluessige Kriechoele, wie z.B. Caramba oder Ballistol. Es sollte aber kein Speiseoel sein. ;-) Einfach mit einem Oellappen die Kontakte vorsichtig und nicht zu grossem Druck reinigen und hinterher mit mindestens 70% Isopropanol (gibt es z.B. in der Apotheke) das Oel und die Schmutzreste entfernen. Mit Isopropanol kann man ausserdem die ganze Elektronik vorsichtig reinigen, da dieses restlos verfliegt.

Falls es etwas hartnaeckiger ist: Reinigungsstaebchen sind meiner Meinung nach schonender als Glasfaserstifte. Die Kontakte auf deinem Bild im anderen Thread sehen jedoch nur leicht oxydiert aus und sollten sich mit Oel und Isopropanol gut reinigen lassen. Bevor Du mit der Reinigung anfaengst, solltest Du dich aber z.B. an der Heizung kurz erden, um Beschaedigungen durch statische Aufladung / Funkenflug zu vermeiden.
 
Zuletzt bearbeitet:
Status
Für weitere Antworten geschlossen.
Oben