PPPoE bricht minuetlich zusammen

radiohead

Well-Known Member
Moin,

installiere mir gerade ein frisches 4.1 und wollte nach der Anleitung http://wiki.bsdforen.de/howto/dsl-router mir eine Firewall zusammenbauen. Wenn ich das mit dem PPPoE so einrichte wie dort beschrieben, bricht die Verbindung in weniger als einer Minute ab, baut sich dann wieder auf usw...

Hier mal ein log Auszug:

Code:
Jul 14 18:23:52 voldemort ppp[14908]: tun0: IPCP: deflink: LayerUp. 
Jul 14 18:23:52 voldemort ppp[14908]: tun0: IPCP: myaddr 217.70.192.104 hisaddr = 213.178.64.69 
Jul 14 18:23:52 voldemort ppp[14908]: tun0: Command: MYADDR: ! sh -c /sbin/ifconfig pflog0 up 
Jul 14 18:23:52 voldemort ppp[14908]: tun0: Command: MYADDR: ! sh -c /sbin/pflogd 
Jul 14 18:23:52 voldemort ppp[14908]: tun0: Command: MYADDR: ! sh -c /sbin/pfctl -e -F all -f /etc/pf.conf 
Jul 14 18:23:52 voldemort ppp[14908]: tun0: Warning: 0.0.0.0: Change route failed: errno: No such process 
Jul 14 18:23:52 voldemort ppp[14908]: tun0: Warning: ff01:7::: Change route failed: errno: Network is unreachable 
Jul 14 18:23:52 voldemort ppp[14908]: tun0: Warning: ff02:7::: Change route failed: errno: Network is unreachable 
Jul 14 18:23:52 voldemort ppp[14908]: tun0: Phase: deflink: IPV6CP protocol reject closes IPV6CP ! 
Jul 14 18:24:04 voldemort last message repeated 5 times
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: deflink: ** Too many LQR packets lost ** 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: CCP: deflink: State change Stopped --> Closed 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: CCP: deflink: State change Closed --> Initial 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: deflink: open -> lcp 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Warning: 0.0.0.0: Change route failed: errno: No such process 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Warning: ff01:7::: Change route failed: errno: Network is unreachable 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Warning: ff02:7::: Change route failed: errno: Network is unreachable 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: IPCP: deflink: LayerDown: 217.70.192.104 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Command: MYADDR: ! sh -c /sbin/pfctl -d -F all 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Command: MYADDR: ! sh -c kill `cat /var/run/pflogd.pid` 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Command: MYADDR: ! sh -c /sbin/ifconfig pflog0 down 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Command: MYADDR: ! sh -c /sbin/route delete default 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: IPCP: deflink: State change Opened --> Starting 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: IPCP: deflink: LayerFinish. 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: IPCP: Connect time: 61 secs: 2647 octets in, 2665 octets out 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: IPCP: 30 packets in, 37 packets out 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: IPCP:  total 87 bytes/sec, peak 238 bytes/sec on Sat Jul 14 18:24:00 2007 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: IPCP: deflink: State change Starting --> Initial 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: bundle: Terminate 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: deflink: Disconnected! 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: deflink: lcp -> logout 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: deflink: Disconnected! 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: deflink: logout -> hangup 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: deflink: Connect time: 61 secs: 3347 octets in, 3748 octets out 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: deflink: 110 packets in, 138 packets out 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase:  total 116 bytes/sec, peak 272 bytes/sec on Sat Jul 14 18:24:00 2007 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: deflink: HUPing 13294 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: deflink: hangup -> opening 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: bundle: Establish 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Phase: deflink: Enter pause (15) for redialing. 
Jul 14 18:24:53 voldemort ppp[14908]: tun0: Chat: deflink: Reconnect try 4 of 10000 
Jul 14 18:24:54 voldemort pflogd[10868]: Exiting
Jul 14 18:24:54 voldemort pflogd[10868]: 0 packets received, 0/0 dropped (kernel/pflogd)

Kann mir jemand helfen? Ist das ein bekanntes Problem?
 

radiohead

Well-Known Member
Habe schon ein wenig mehr herausgefunden. Und zwar geht es um die Zeile "set lqrperiod 5" in der ppp.conf. Diesen Wert habe ich mal auf 600 gesetzt, das wurde so in einem englischen Forum empfohlen. Weiss jemand genau, was dieser Wert zu sagen hat?
 

Bummibaer

Registered Schwarzbär
Hoi,

LQR steht für Link Quality Request. Die Gegenstelle (Provider) schickt Dir alle paar Sekunden einen LQR. Erfolgt darauf keine Antwort, wird die Verbindung abgebaut. Damit das nicht passiert, mußt Du dem Rechner erlauben, auf diese Requests zu antworten. Eigentlich ist das aber der Default. D.h. accept lqr sollte gesetzt sein und lqrperiod entsprechend eben, je nach Provider.

Gruß Bummibaer
 

radiohead

Well-Known Member
Hey,

danke fuer die Antwort. Durch das hochsetzen des lqrperiod Statements, geht die Verbindung nun halt spaeter erst aus. Einwahl funktioniert dann aber nicht wieder automatisch. Muss immer den ppp killen und neustarten. Liegt das dann am falschen lqr Wert?
 

radiohead

Well-Known Member
Ja natuerlich, sorry.

Code:
# cat /etc/ppp/ppp.conf                                                                                                       
default:
 set log Phase Chat IPCP CCP tun command
 set redial 15 0
 set reconnect 15 10000
     
pppoe:
 set device "!/usr/sbin/pppoe -i xl0"
 disable acfcomp protocomp
 deny acfcomp
 set mtu max 1454
 set crtscts off
 set speed sync
 enable lqr
 set lqrperiod 600
 set dial
 set login
 set timeout 0
 set authname "XXXX"
 set authkey "XXXX"
 add! default HISADDR
 enable dns
 enable mssfixup
 disable ipv6cp
 
Zuletzt bearbeitet:

s-tlk

Lion King Fan
Ich würde mal deinen usernamen und dein passwd da raus nehmen. Das geht glaub ich niemanden was an. :ugly:
Mh aber sonst finde ich jetzt nichts auffälliges daran. Hast du mal versucht pf aus der ppp.linkup rauszunehmen? Mein Tipp bleibt trotzdem mal kernel pppoe versuchen.
 

radiohead

Well-Known Member
So, ich habe nun mal die folgenden Zeilen aus der ppp.conf entfernt und dann laeuft es nun seit Stunden ohne Probleme. Ich werde das mal weiter beobachten.

enable lqr
set lqrperiod 600

Wird das dann ausgehandelt, wenn ich diese Eintraege weglasse, so dass man immer vom Provider den richtigen Wert bekommt?
 

d4mi4n

volksoperator on duty
radiohead: bisher alles i.O.?

alle: weiss jemand wo das Problem liegt? Könnte man dann im Wiki anpassen.
Ich selbst nutze Kernel pppoe, Userland pppoe funktionierte bei mir nie. Von daher kann ich da leider keine tipps geben.
 

radiohead

Well-Known Member
Ja, keinerlei Probleme! Wie gesagt nur die beiden Optionen auskommentiert. Scheint dann also ausgehandelt zu werden...
 

s-tlk

Lion King Fan
Darf man vllt fragen, welchen Provider du hast. Das wäre doch mal ganz interessant zu wissen. Evtl. kann man das dann mal zusammentragen welche conf, bei welchem besser ist.

Bei mir war immer das Problem, dass das userland pppoe sich nicht immer wieder neu verbinden wollte und seit dem ich kernel pppoe benutze hat sich das dann erledigt.
 

mapet

Active OpenBSD User
bei mir war das gleich wie bei s-tlk, bin deswegen auch auf kernel pppoe umgestiegen. auch hatte ich festgestellt, dass der kernel-kram schneller ist und weniger last erzeugt (hab da mittlerweile ne soekris dranhängen, daher ist das auch ganz interessant für mich gewesen).
 
Oben