• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Prescott+ACPI+SMP+Shutdown-Probleme

Ice

Well-Known Member
Themenstarter #1
Hallo Leute,

habe seit gestern hier ein nettes Prescott-System stehen:

P4 Prescott 3Ghz HT
Intel 875PBZLK Mainboard
1GB Corsair Dual Channel RAM

Habe jetzt auf das System mal 5.2.1 Release installiert. Läuft soweit auch alles erstmal einwandfrei.

Aus Interesse und Spaß daran, habe ich dann mal versucht, das System ohne ACPI zu starten, was bereits während des Boot-Vorgangs kläglich scheitert:
Code:
Fatal Trap 9: general protection fault while in kernel mode
cpuid = 0; apic id = 00
instruction pointer = 0x58:0x1823
stack pointer = 0x10:0xf80
frame pointer = 0x10:0x0
code segment = base 0xc00f0000, limit 0xffff, type 0x1b
                       = DPL 0, pres 1, def32 0, gran 0
processor eflags = interrupt enabled, resume, IOPL = 0
current process = 0 (swapper)
trap number = 9
panic: general protection fault
cpuid = 0;
Uptime = 1s;
Das Ganze hab ich wiederholt versucht und zwar mit folgenden Einstellungen:

- HT im BIOS disabled /SMP Kernel
- HT im BIOS an / MPTABLE_FORCE_HTT im Kernel

Das System will ohne ACPI einfach nicht starten!
OK, soweit kein Problem, denn eigentlich ist man ja froh, wenn ACPi funktioniert. Nur leider hab ich jetzt das Problem, dass ich das System weder rebooten noch herunterfahren kann.
Ich erhalte fogende Fehlermeldungen:

Reboot:
Code:
boot() called on cpu#1
Waiting (max 60 seconds) for system process `vlnru` to stop....stopped
kr(ab hier kommen dann noch ein par Hyoglyphen und das System bleibt hängen)
Die einzige Alternative, die zu funktionieren scheint, ist, SMP im Kernel zu deaktivieren. Dann kann ich das System ordnungsgemäß herunterfahren und auch rebooten.
Was mich allerdings auch hier etwas stutzig macht, ist die Ausgabe von dmesg:
Code:
CPU: Intel(R) Pentium(R) 4 CPU 3.00GHz (3000.12-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf33  Stepping = 3
  Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,C
MOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
[b]Hyperthreading: 2 logical CPUs[/b]
Bedeutet das, dass HT immernoch aktiv ist?
Oder liege ich richtig in der Annahme, dass das System zwar die HT-CPU erkennt, diese aber im System dann nicht als 2 CPUs benutzt wird?

Ich werde mich mal am Debugging des ACPI versuchen. Würde mich aber trotzdem freuen, wenn jemand Erfahrungen oder ähnliche Probleme hat und mir heöfen könnte, das System mit HT/SMP sauber ans Laufen zu kriegen.

Gruß,

Ice
 

FierceOne

Kampfmaschine
#2
ich denke mal es gibt 2 Möglichkeiten um festzustellen ob er im SMP Modus läuft. Schau doch einfach mal in dmesg ob direkt nach GEOM
Code:
SMP: AP CPU #1 Launched!
steht.

Soweit ich weis heißt es nix, wenn er "Hyperthreading: 2 logical CPUs" schreibt. Ich glaube das heißt wie Du schon sagtest einfach das er es erkennt.

EDIT:

Wie blöd!

Code:
sysctl  hw.ncpu
tut's auch
 
Zuletzt bearbeitet:
D

destiny

Guest
#3
ich hatte auch mal smp im kernel deaktiviert, weil die soundtreiber von OSS mir das an herz gelegt hatten, da kam die gleiche meldung wie bei dir

===... MOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,S
S,HTT,TM,PBE>
Hyperthreading: 2 logical CPUs .. ===

mittlerweile hab ich aber wieder alles im kern drin und der sound tut es auch.

hardware: 3.0 CPU/HT = Abit IC7, die probleme bei starten gabs aber nicht, am anfang (das war aber 5.2, jetzt läuft 5.2.1) wollte er nicht immer abschlaten und erzählte immer was von zeitlimit erreicht ....
 

Ice

Well-Known Member
Themenstarter #4
Also ich habe mit dem System nochmal ein bischen weitergebastelt und bin bisher zu dem Ergebnis gekommen, dass ein Betrieb ohne ACPI offensichtlich nicht möglich ist.
Allerdings war es mir möglich die Fehler beim Reboot oder Shutdown zu beheben, indem ich den Kernel mit der Option NO_MIXED_MODE gebaut hab.
Damit läuft das System eigentlich einwandfrei, sowohl mit und ohne SMP/HT und ist auch wirklich sehr flink (subjektiv). Wen es interessiert hier mal die ubench-Werte mit HT:
CPU: 123487
MEM: 114294
AVG: 118890
Leider hab ich trotz Gehäuselüfter immernoch ein heftiges Hitzeproblem auf dem System, wenn ich es über längere Zeit mit Last versorge.
Bevor ich jetzt mit weiterem Lüftergebastel anfange, habe ich mich entschieden, das System wieder abzustoßen und mal den Athlon64 zu testen.
Aktuell kann ich leider jedem, der keinen großen Wert auf Kühlungsgebastel oder Lärmbelästigung hat, nur von diesem System abraten.

Gruß,

Ice
 

nintendo

Please don't sue us!!
#5
Jo Ice, da stimme ich dir zu, die neuen Prozessoren sind wirklich problematisch geworden. Ob jetzt CPU oder GPU, inzwischen fressen die Dinger so viel Strom und entwickeln dermaßen viel Abwärme, dass es nur Probleme geben kann!

Für FreeBSD reicht auch ältere Hardware (habe mir einen älteren dual P2 400 zusammengebaut, einfach traumhaft) - die neuere hardware ist eher was für die Fanatiker oder Overclocker ;)
Ich frage mich, wann der Aldi/Lidl PC kommt, in dem eine Wasserkühlung standardmässig integriert ist :D

Btw es spricht imho vieles für ältere Hardware: es ist robuster, wird von der Software/OS unterstützt und es ist preisgünstiger... Und ne 64bit CPU ist auch nix wert, wenn es von der Software nicht unterstützt wird :(
 

Ice

Well-Known Member
Themenstarter #6
@nintendo

Geb Dir recht. Ich setze hier auch einiges an etwas betagter Hardware ein und bin damit sehr zufrieden. Ich kann allerdings einem Kunden nur schwer vermitteln, dass er sich gebrauchte Hardware kaufen soll..... ;)
Ich werde die 64-Bit CPU dann schon mit der amd64-Variante testen. Bin mal sehr gespannt. Laut Erfahrungsberichten soll diese CPU von der Abwärme her sogar besser sein als die XP-Schiene.
Gruß,

Ice
 

UnUser

Well-Known Member
#7
Also ich hab leider nur Erfahrungen mit I865 Chipsatz hatte aber auch dort hin und wieder Probleme gerade mit ACPI. Die Rechner sind einfach festgefroren. Kernel Panic & reboot

Also ich konnte die Probleme beseitigen indem ich

1. kernel mit

options SMP # Symmetric MultiProcessor Kernel
device apic # I/O APIC
options MPTABLE_FORCE_HTT # Enable HTT CPUs with the MP Table

bauen und installieren.

2. zur /boot/loader.conf

exec="unset acpi_load"

hinzufügen. Damit verhinderst du, daß das ACPI Modul in den Kernel geladen wird.

3. reboot en und dann im Bios alles was dir an ACPI über den weg läuft abschalten .. falls APM da ist auch gleich mit ...

(4.) zum Teil gibt es noch Optionen für die ATA Controller, irgendwelche "Burst" Kram (sorry kann ich jetzt nicht rauskriegen). Falls du noch Probleme hast ruhig mal rausnehmen und probieren. Ich hatte schon ein System bei dem gerade das alle Probleme mit z.T. nicht nachzuvollziehenden Abstürzen beseitigt hat.
 

Ice

Well-Known Member
Themenstarter #8
@UnUser

Das Problem hier war, dass das System ohne ACPI überhaupt nicht läuft! ;)

Gruß,

Ice