• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Problem 12.1 Vbox Desktop Xorg + DM + WM => lightdm + XFCE4 => Kein Screen gefunden => xrandr => cant open display. Hilfe was mache ich falsch?

Sadakazu

Well-Known Member
Themenstarter #1
Sehr geehrte BSDForum Community,
ich habe ein Problem bei der Installation einer Desktop Umgebung auf FreeBSD 12.1

Zu meiner großen Überraschung hat sich scheinbar mit der neuen Version einiges geändert und die Installation einer Desktop Umgebung erschließt sich als schwieriger als es noch zu 11.2 gewesen war.

Deswegen würde ich gern euch um Unterstützung bitten, das neue System zu verstehen und vorallem warum es jetzt so funktioniert, wie es eben funktioniert.

Ich möchte euch kurz erzählen was ich genau gemacht habe und was meine Ziele sind:

Zunächst möchte ich FreeBSD 12.1 erst einmal wieder in einer Virtuellen Maschine installiere.
Dazu benutze ich als Host System ein:
AMD Ryzen 2800X
64GB DDR4 RAM
Samsung Evo NVME SSD
Die VM's liegen aber auf einem ZFS auf einer HDD
Das Host Operating System dient ein Arch Linux mit ZFS Support und einem 5.3.8-1 Linux Kernel
Als Virtualisierungssoftware wird Virtual Box benutzt.

Ich habe eine Virtuelle Maschine erstellt mit 8 Kernen, 8GB RAM 50GB Festplatten und UEFI support.

Habe dann das FreeBSD-12.1-RELEASE boot-only Image heruntergeladen und eine ganz normale Grundinstallation mit ZFS und UEFI durchgeführt.

Als erstes habe ich ein freebsd-update fetch install durchgeführt um FreeBSD auf den aktuellen stand zu bringen.
Allerdings scheint das image noch das aktuellste System zu sein, da keine Updates installiert wurden.

Als nächste habe ich via pkg install nano mir einen Texteditor installiert, da ich mit nano besser zurecht komme als mit vi vim oder ed.

Danach bin ich bei gegangen und habe mit pkg install xorg xfce xfce4-goodies lightdm lightdm-gtk-greeter virtualbox-ose-additions versucht einen xorg server, ein Displaymanager und ein Windowmanager zu installieren.
Nachdem alle Pakete heruntergeladen und installiert waren habe ich angefangen nach dem FreeBSD Handbuch die Konfigurationen anzupassen:

/etc/rc.conf:
Code:
dbus_enable="YES"
hald_enable="YES"

vboxguest_enable="YES"
vboxservice_enable="YES"

lightdm_enable="YES"

/boot/loader.conf

Code:
kern.vty=vt
========
/etc/fstab
Code:
proc    /proc    procfs    rw    0    0

Danach habe ich ein neues Dataset für meinen zukünftigen Benutzer erstellt:
zfs create zroot/usr/home/sada
Danach den Benutzer mit adduser angelegt und zusätzlich direkt in die gruppen:
wheel operator und video hinzugefügt.
Anschließend - sicherheitshalber - den eigentümer von /usr/home/sada auch auf den benutzer sada gelegt:
chmod -R sada:sada /usr/home/sada

Damit mein Benutzer auch restart und shutdown nutzen kann im XFCE hab ich noch polkit roules angelegt:
/usr/local/etc/polkit-1/rules.d/10-restart.stop.rule
Code:
polkit.addRule(function (action, subject) {
    if ((action.id == "org.freedesktop.consolekit.system.restart" ||
        action.id == "org.freedesktop.consolekit.system.stop")
        && subject.isInGroup("operator")) {
        return polkit.Result.YES;
    }
});
Als root ausgeloggt und mit sada eingeloggt.
Als user dann auch eine .xinitrc und .xsession angelegt:
.xinitrc
Code:
export LANG=de_DE.UTF-8
export LC_CTYPE=de_DE.UTF-8
export LC_COLLATE=de_DE.UTF-8
export MM_CHARSET=UTF-8
export LC_TYPE=de_DE.UTF-8
export LC_MESSAGES=de_DE.UTF-8
export LC_MONETARY=de_DE.UTF-8
export LC_NUMERIC=de_DE.UTF-8
export LC_TIME=de_DE.UTF-8
export CHARSET=UTF-8
export LC_ALL=de_DE.UTF-8

exec /usr/local/bin/startxfce4 --with-ck-launch
Die xsession sieht ähnlich aus nur das in der ersten zeile gewohnt das #!/bin/sh steht....

Weil ich in Xorg auch eine Deutsche Tastatur haben möchte habe ich dann auch direkt in /usr/local/etc/X11/xorg.conf.d/ das Keyboard Layout definiert.
/usr/local/etc/X11/xorg.conf.d/20-keyboard.conf
Code:
Section "InputClass"
    Identifier "keyboard"
    MatchIsKeyboard "yes"
    Option "XkbLayout" "de"
    Option "xkbVariant" "nodeadkeys"
EndSection
Kurzer blick ins FreeBSD Handbuch Kapitel 5.4 Xorg konfigurieren:
Zitat:
Grafikkarten, Monitore und Eingabegeräte werden automatisch erkannt und müssen nicht manuell konfiguriert werden. Erstellen Sie keine xorg.conf und führen Sie nicht -configure aus, es sei denn, die automatische Konfiguration schlägt fehl.
also wäre ich an dieser stelle fertig.
Deswegen System reboot....

Was ich ab hier erwarten würde - so wie es in FreeBSD 7 8 9 10 und 11 gewesen ist, das mich mein Displaymanager begrüßt den ich installiert habe, in diesem Fall der lightdm.
Tut er aber nicht, sondern das system bleibt im Textmode.
Also als normaler benutzer eingeloggt und startx eingegeben...
Fehlermeldung:
Cannot run in Framebuffermode.
Also nochmal genau in die Xorg.0.log geschaut und gesehen, das er versucht vmware videotreiber zu laden.
ALSOOO doch noch einmal hand angelegt und eine neue config angelegt:
/usr/local/etc/X11/xorg.conf.d/30-virtualbox-driver.conf
Code:
Section "Device"
        Identifier  "VirtualBox Video Card"
        Driver      "vboxvideo"
EndSection

Section "InputDevice"
        Identifier  "VBoxMouse"
        Driver      "vboxmouse"
        Option      "CorePointer"
EndSection
gespeichert und nochmal startx als normaler benutzer eingegeben.
Fehlermeldung:
no screens found(EE)

Also auch hier noch maml in die Xorg.0.log geschaut...
Code:
(II) VBoxVideo: guest driver for VirtualBox: vbox
(--) Using syscons driver with X support (version 2.0)
(--) using VT number 9
(EE) no devices detected.
(EE) Fatal server error:
(EE) no screens found(EE)
nochmal weiter oben geschaut
Code:
(==) No Layout section. Using the first Screen section.
(==) No screen section available. Using default.
(**) |-->Screen "Default Screen Section" (0)
(**) |   |-->Monitor "<default monitor"
(==) No devices specified for screen "Default Screen Section".
     Using the first device section listed.
(**)|    |-->Device "VirtualBox Video Card"
(==) no monitor specified for screen "Default screen".
    using a default monitor configuration
(==) Automatically adding devices
(==) Automatically enabling devices
(==) Not automatically adding GPU device
hm okay also gucken wir einfach mal ins Handbuch Kapitel 5.4.6 Monitore....
Man soll xrandr ohne parameter aufrufen um eine Liste mit Video-ausgängen und der erkannten Monitor-Modies sehen zu können... also gut..
xrandr
-> Can't open display

Hä?

Und ab hier steige ich komplett aus und hab keine Ahnung was FreeBSD jetzt von mir will.
Treiber sind ja installiert, gestartet und werden von Xorg auch geladen, aber jetzt hängt es an der Videoausgabe?
Schön, und wo?

Nochmal was ich vor habe:
FreeBSD mit xorg und einem DM + WM auf einer VIRTUAL BOX ans laufen bekommen.

Wie gesagt, bis einschließlich 11.2 (letzte version die ich als Desktop Version als Vanilla FreeBSD benutzt habe sowohl in VM als auch auf Hardware) hat es immer über diesen wege Funktioniert, und plötzlich gehts nicht mehr?
Was mache ich Falsch?

Gruß Sada

PS: ich hoffe es ist jetzt sachlich und ausführlich genug....
 
#2
Mein Beitrag wird bescheiden ausfallen.
Ich hatte solche Probleme auf meinem Laptop, weil das nvidia Modul nicht geladen war.
Über die Einstellungen von Virtualbox sollte es möglich sein die Video Beschleunigung einzustellen.
Vielleicht lohnt es sich da noch nachzuschauen.

Liebe Grüße,
Goldfluss
 

Sadakazu

Well-Known Member
Themenstarter #3
Danke für die Antwort :)
Auf die Idee bin ich auch schon gekommen mit den VBox Settings herum zu spielen....
Aufgefallen ist mir was vor etlichen Wochen als ich das Ubuntu 19.10 in ner VBox installiert hatte..
Hatte massive grafikfehler und etliche Probleme
Da ist mir dann die Option Grafik-Controller im VBox 6.0 aufgefallen.

Standardmäßig stand das auf VMSVGA und scheinbar kommt Ubuntu damit nicht klar...
Nachdem ich das auf VBoxSVGA gestellt hatte lief ubuntu....

Bei FreeBSD hatte ich den gleichen verdacht zu anfang gehabt und hab mitlerweile jede option durch und bekomme auf allen den gleichen fehler....
Auch 3D-Beschleunigung aktiviert und deaktiviert.... Grafikspeicher von mini auf maximal von maximal auf mittel von mittel auf minimal und immer hin und her probiert... Daran liegt es auch nicht... (scheinbar)

Ich werd mir die Tage sobald ich wieder bisschen Luft hab nochmal eine 11.x schnappen und da nochmal versuchen XFCE4 zu installieren...

Wenn das funktioniert... liegts vermutlich nicht an den Vbox Settings....
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#4
FreeBSD in VirtualBox ist echt böse lange her. Aber es könnte sein, dass die das Kernelmodul fehlt, taucht vboxguest.ko in kldstat auf?
 

serie300

Well-Known Member
#5
Erstmal ohne DE installieren . Dann ohne xdm o.ä. booten. In der Shell kldinfo eingeben. Dann weißt du , ob der Grafik Treiber geladen ist; wird er in der regel für die neue Konsole . Dann startx und der twm sollte erscheinen. Xorg.log sollte in jedem fall Erhellendrs enthalten.


BTW: Die harsche Kritik an den FreeBSD Entwicklern in deinem anderen Thread finde ich nicht angebracht. Wenn du DE wie KDE willst willst du nicht VGA Framebuffer als Grafik device.
 

pit234a

Well-Known Member
#6
Du hast eine sehr gute Beschreibung deines Problems geliefert. Da entsteht in mir direkt so ein Gefühl, dass man einen derart leidenden Menschen doch mal zart drücken muss und sein Mitgefühl äußert.
Das nutzt dir natürlich gar nichts und ich ich habe auch gar keine Lösung für deine Probleme.

Wann immer ich selbst FreeBSD (oder ein anderes BSD) in VirtualBox probierte, hatte ich Probleme und es funktionierte weitaus schlechter, als viele andere Systeme. Vielleicht stolperst du da nun auch drüber. Wobei: die schlechte Funktion betrifft eigentlich gar nicht FreeBSD!
Enttäuschung ja, aber trotzdem: FreeBSD ist FreeBSD. Es ist nicht FreeBSD + beliebige Pakete und X und Sound etc.
FreeBSD nutzt Freie SW aus ihren Quellen, die allerdings aller allermeist nicht mit Fokus auf FreeBSD entwickelt wird und wir müssen froh sein, dass Port-Maintainer sich die Mühe machen und sehr viele SW sehr gut an FreeBSD anpassen. Nur deshalb können wir überhaupt vielleicht auch einen Desktop auf einem FreeBSD betreiben.
Vielleicht auch nicht!
Und das hat nichts mit FreeBSD zu tun und mit deren Entwicklungszielen, denn die können sich natürlich nur auf das beschränken, was FreeBSD ist. Alle zusätzliche SW liegt nicht im Zugriff der FreeBSD-Entwickler!
Ganz grob gesagt hat beinahe kein einziger Eintrag in deinem Eingangsthread irgendwas mit FreeBSD zu tun. Und ich nehme hier nun ausdrücklich auch den inzwischen geschlossenen Thread mit rein, in dem du mal Dampf abgelassen hast, was mir ja immer gut gefällt.
Wo fange ich an?
ist natürlich FreeBSD, aber was darin gestartet wird nicht unbedingt: kein einziger Eintrag bei dir hat was mit FreeBSD zu tun, alles third-Party-SW!
ist natürlich erst recht FreeBSD und kern.vty=vt schon ein sehr typischer Eintrag, der aber auch nur mit bestimmten Grafikkarten ein bestimmtes Verhalten ermöglicht und bei anderen eben nicht. Es geht hier hauptsächlich darum, wie sich die Konsole nach Ausloggen aus X verhält, X ist nicht FreeBSD.
fstab ist natürlich FreeBSD und ein proc schadet nicht. Hilft aber auch kaum was.

Und alles alles andere hat schon gar nicht mehr mit FreeBSD zu tun.

Nochmal: ich verstehe die Enttäuschung und wundere mich, dass ältere FreeBSD-Versionen bei dir besser funktionierten.
Hat sich vielleicht außer der FreeBSD-Version noch etwas geändert?
Ganz sicher die Versionen von X und etlicher anderer SW (die aber nicht FreeBSD ist!), aber vielleicht auch VirtualBox oder deine PC-HW?
 

waldbaer59

Well-Known Member
#7
Hmmmm, ich habe gerade meine (zugegeben ziemliche 'Vanilla'-Installation auf der Virtualbox von 12.0 auf 12.1 gehoben. Neben einigen üblichen Haklern, die mich immer bei so etwas begleiten (und denen ich endlich mal beigehen muss und das dann auch für mich dokumentieren) lief es ganz gut. Insbesondere habe ich eine grafische Anzeige und kann mich mit Slim anmelden (xfce). Soweit scheint also alles ganz gut zu sein.
Nun frage ich mich, wie wir deinem Problem am besten auf die Schliche kommen. Ich halte FreeBSD 'locker die Treue' ;), d.h. eigentlich™ bin ich nur ab und zu mal dran, aktualisiere alles und arbeite dann weiterhin unter Linux => besonders viel 'Dunst' habe ich nicht. Das mag sich bessern, wenn ich gelegentlich mein Thinkpad von SuSE Tumbleweed befreie und FreeBSD dort installiere (so richtig zum arbeiten ;) ) ... aber ich schweife ab. :)
Vielleicht können wir uns per Mail etc. kurzschließen, die Infos abgleichen und das Ergebnis dann hier mitteilen, bevor wir den Thread mit ziemlich vielen Posts überladen?

VLG
Stephan
 

Columbo0815

Kaffeemann
Mitarbeiter
#8
Moin,

ich habe das versucht - soweit mir möglich - nachzustellen. Dabei habe ich VirtualBox auf einem Windows-Host in der aktuellen Version 6.0.14 installiert. FreeBSD 12.1 habe ich danach ebenfalls mit dem bootonly-iso installiert (allerdings ohne zfs, was egal sein sollte). Danach habe ich nur virtualbox-ose-additions installiert und in der rc.conf aktiviert. dbus und hald habe ich derzeit nicht aktiv. Ebenfalls installiert habe ich xorg.

Die VirtualBox-Additions sind aktiv, aufgerufen habe ich als root: startx

Ich erhalte eine grafische Oberfläche und kann arbeiten. Mir ist klar, dass die Gegebenheiten nicht identisch sind. Dennoch würde ich aktuell von einem Problem von deinem VirtualBox ausgehen. Welche Version nutzt du? Kannst du uns die komplette Xorg.0.log zeigen?

HTH
 

Columbo0815

Kaffeemann
Mitarbeiter
#9
Als Nachtrag: Auf dem Host habe ich unter VirtualBox als Grafik-Controller die Default-Einstellungen gelassen: "VBoxVGA", ohne 3D-Beschleunigung, ohne 2D-Video-Beschleunigung.