• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Problem bei cups installation

E

ex-user_4198

Guest
Themenstarter #1
Hallo leute

Ich bekomme folgende Meldung wenn ich cups installieren möchte.

/usr/ports/print/cups]# make install
===> cups-1.4.8 depends on executable: espgs - found
===> cups-1.4.8 depends on executable: cupsd - not found
===> Verifying install for cupsd in /usr/ports/print/cups-base
===> cups-base-1.4.8 is marked as broken: gnutls does not support threads yet; disable the GNUTLS.
*** Error code 1

Stop in /usr/ports/print/cups-base.
*** Error code 1

Stop in /usr/ports/print/cups.

Wie soll ich vorgehen?
 

pit234a

Well-Known Member
#4
vielleicht ohne gnutls bauen?

das ist für mich leicht verwirrend, doch es zeigt sich so:
Code:
pit@syo ~:-> whereis cupsd
cupsd: /usr/local/sbin/cupsd /usr/local/man/man8/cupsd.8.gz
pit@syo ~:-> pkg_info -W /usr/local/sbin/cupsd
/usr/local/sbin/cupsd was installed by package cups-base-1.4.6_5
pit@syo ~:-> pkg_info -o cups-base-1.4.6_5
Information for cups-base-1.4.6_5:

Origin:
print/cups-base
und da gibt es dann eben in cups-base die Option, mit gnutls zu bauen und das scheint im Moment nicht zu wollen.
Also würde ich erst nach cups-base, dort mit make config die Optionen (neu) setzen und den Port (versuchen zu ) bauen, dann mit print/cups weiter machen.
 

Gulp

Well-Known Member
#5
Auszug aus /usr/ports/UPDATING :
20110828:
AFFECTS: users of print/cups-{base,client,image}
AUTHOR: sahil@FreeBSD.org

During the update to 1.4.8, the GNUTLS option was changed from ON to
OFF by default. Because old configuration options are saved, users
should re-run 'make config' and explicitly deselect the GNUTLS option
before upgrading.
Gruß
 

Bummibaer

Registered Schwarzbär
#6
Hoi,
oifach in de jeweilige betroffene Ports gnutls Bindung entfernen und neu bauen - danach rennt des.

Gruß Bummibär