• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

problem mit kdm und kde als user

s-tlk

Lion King Fan
Themenstarter #1
hi,
ich hab folgendes problem und zwar habe ich kdm und kde 3.2.3 aus den ports gebaut. funktioniert auch alles wunderbar, bis auf eine "kleinigkeit". wenn kdm startet und ich mich als user darauf einlogge um kde zu starten, startet es komplett (ich sehe das panel und der splash screen verschwindet) aber es fährt sofort wieder runter und ich lande wieder auf kdm.
wenn ich mich als root anmelde funzt es.

hab auch ein paar ähnliche sachen im netz bzw. hier im forum gefunden nur das funzt nicht.

mfg, s-tlk

running fbsd 5.2-Release
kde 3.2.3

ps was braucht ihr für config files?

kdmrc
Code:
[General]
ConfigVersion=2.1
PidFile=/var/run/kdm.pid
Xservers=/usr/local/share/config/kdm/Xservers

[X-*-Core]
AllowNullPasswd=false
AllowRootLogin=false
AllowShutdown=Root
AutoReLogin=false
Reset=/usr/local/share/config/kdm/Xreset
Session=/usr/local/share/config/kdm/Xsession
Setup=/usr/local/share/config/kdm/Xsetup
Startup=/usr/local/share/config/kdm/Xstartup

[X-*-Greeter]
AntiAliasing=false
ColorScheme=
DefaultUser=michi
EchoMode=OneStar
FaceSource=AdminOnly
FailFont=helvetica,12,-1,5,75,0,0,0,0,0
FocusPasswd=false
ForgingSeed=1093119180
GUIStyle=
GreetFont=charter,24,-1,5,50,0,0,0,0,0
GreetString=Welcome
GreeterPosFixed=false
GreeterPosX=100
GreeterPosY=100
HiddenUsers=toor
Language=en_US
LogoArea=Clock
LogoPixmap=
MaxShowUID=65000
MinShowUID=1000
PreselectUser=None
SelectedUsers=
ShowUsers=NotHidden
SortUsers=true
StdFont=helvetica,12,-1,5,50,0,0,0,0,0
UseBackground=true

[X-:*-Core]
AllowNullPasswd=true
AllowRootLogin=true
AllowShutdown=All
NoPassEnable=false
NoPassUsers=

[X-:*-Greeter]
AllowClose=false
LoginMode=DefaultLocal

[X-:0-Core]
AutoLoginEnable=false
AutoLoginUser=michi

[Xdmcp]
Enable=false
Willing=/usr/local/share/config/kdm/Xwilling
 

s-tlk

Lion King Fan
Themenstarter #2
hier ist noch .xsession-errors:
Code:
startkde: Starting up...
ksplash: WARNING: KGenericFactory: instance requested but no instance name passed to the constructor!
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
kbuildsycoca running...
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
Launched ok, pid = 989
QFont::setPointSize: Point size <= 0 (-3)
Can't get own host name. Your system is severely misconfigured

ICE default IO error handler doing an exit(), pid = 971, errno = 35
ICE default IO error handler doing an exit(), pid = 974, errno = 0
ICE default IO error handler doing an exit(), pid = 986, errno = 0
ICE default IO error handler doing an exit(), pid = 994, errno = 0
ICE default IO error handler doing an exit(), pid = 962, errno = 0
ICE default IO error handler doing an exit(), pid = 995, errno = 0
ICE default IO error handler doing an exit(), pid = 998, errno = 0
ICE default IO error handler doing an exit(), pid = 999, errno = 0
ICE default IO error handler doing an exit(), pid = 1004, errno = 35
ICE default IO error handler doing an exit(), pid = 1007, errno = 35
ICE default IO error handler doing an exit(), pid = 1009, errno = 0
WARNING: DCOP communication problem!
X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  20
  Minor opcode:  0
  Resource id:  0x1c00009
kdeinit: Communication error with launcher. Exiting!
startkde: Shutting down...
Warning: connect() failed: : Connection refused
Error: Can't contact kdeinit!
ICE default IO error handler doing an exit(), pid = 1005, errno = 32
ICE default IO error handler doing an exit(), pid = 1001, errno = 0
ICE default IO error handler doing an exit(), pid = 1001, errno = 32
pure virtual method called
sound server terminated
kicker: crashHandler called
warning: leaving MCOP Dispatcher and still 9 object references alive.
  - Arts::SampleStorage
  - Arts::Synth_MULTI_ADD
  - Arts::Synth_MULTI_ADD
  - Arts::Synth_PLAY
  - Arts::StereoVolumeControl
  - Arts::StereoEffectStack
  - Arts::Synth_BUS_DOWNLINK
  - Arts::SoundServerV2
  - Arts::MidiManager
warning: leaving MCOP Dispatcher and still 75 types alive.
startkde: Running shutdown scripts...
Session management error: Could not open network socket
KCrash: Application 'kicker' crashing...
startkde: Done.
ktip: Fatal IO error: client killed
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
Mutex destroy failure: Device busy
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

drkonqi: cannot connect to X server :0.0
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kicker: cannot connect to X server :0
DCOP aborting call from 'anonymous-1035' to 'kicker'
ERROR: Communication problem with kicker, it probably crashed.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

korgac: cannot connect to X server :0
DCOP aborting call from 'anonymous-1006' to 'korgac'
ERROR: Communication problem with korgac, it probably crashed.
ein paar sachen versteh ich einfach nicht ich hab den host namen richtig gesetzt.
auch fällt mir auf das der kdm ziemlich lange braucht zum starten, wenn ich fluxbox(was komischerweise als user geht) oder kde beende.
 

s-tlk

Lion King Fan
Themenstarter #4
danke das mit fc-cache -vf hat funktioniert. hatte immer gedacht das bringt nichts.

hab jetzt folgendes gemacht: meinen user namen gelöscht und neu erstellt und nun läufts.
war wohl irgendwas mit meinen einstellungen im home verzeichnis. vermutlich war das kde daran schuld und nicht wie ich dachte kdm.

nochmals danke.
 
P

p.h.

Guest
#5
Du hättest nicht gleich deinen ganzen Benutzeraccount entsorgen müssen. Ein
Code:
cd && rm -r .kde .kderc
hätte es auch getan.