• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Problem mit nvidia-driver nach pkg upgrade

Themenstarter #1
Habe soeben mein Sytem mittles "pkg upgrade" auf den neuesten Stand gebracht, allerdings gibt es bei sddm einen schwarzen Bildschirm. Beim esrten mal stellte ich fest, dass nvidia-driver gar nicht installiert worden war, was schonmal komisch erschien. Mit "pkg install nvidia-driver" und "reboot" war das schnell nachgeholt, doch trotzdem das gleiche Problem. Mit Konsolenwechsel und "service sddm stop" und "xinit fluxbox" bekomme ich zum Glück ein normales Bild, doch das Problem ist schnell klar durch ein "glxinfo", es gibt keine 3D-Beschleunigung:

Code:
$ glinfo
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  155 (NV-GLX)
  Minor opcode of failed request:  4 ()
  Resource id in failed request:  0xc00002
  Serial number of failed request:  58
  Current serial number in output stream:  58
$ uname -a
FreeBSD amd64.local 12.0-RELEASE-p10 FreeBSD 12.0-RELEASE-p10 GENERIC  amd64
$ kldstat
Id Refs Address                Size Name
 1   65 0xffffffff80200000  243d228 kernel
 2    3 0xffffffff8263e000    a6b78 linux.ko
 3    5 0xffffffff826e5000     8df8 linux_common.ko
 4    3 0xffffffff826ee000    8a438 vboxdrv.ko
 5    1 0xffffffff8277a000   1721e8 nvidia-modeset.ko
 6    2 0xffffffff828ed000  134d1e0 nvidia.ko
 7    1 0xffffffff83c3b000    20af0 firewire.ko
 8    1 0xffffffff83e19000     490c linprocfs.ko
 9    1 0xffffffff83e1e000     cc50 snd_uaudio.ko
10    1 0xffffffff83e2b000     1800 uhid.ko
11    1 0xffffffff83e2d000     23a8 ums.ko
12    2 0xffffffff83e30000     2ce0 vboxnetflt.ko
13    2 0xffffffff83e33000     a020 netgraph.ko
14    1 0xffffffff83e3e000     1710 ng_ether.ko
15    1 0xffffffff83e40000     3f30 vboxnetadp.ko
16    1 0xffffffff83e44000      acf mac_ntpd.ko
17    1 0xffffffff83e45000   247e20 zfs.ko
18    1 0xffffffff8408d000     7628 opensolaris.ko
19    1 0xffffffff84095000    16a78 ext2fs.ko
20    1 0xffffffff840ac000     9c08 fuse.ko
21    1 0xffffffff840b6000     3d44 geom_linux_lvm.ko
22    1 0xffffffff840ba000     81f0 tmpfs.ko
Die /var/log/Xorg.0.log scheint das zu betätigen und empfiehlt eine Neuinstallation von nvidia-driver. Ist das jemandem von Euch auch passiert, sollte man vielleicht nvidia-driver aus den ports installieren?

Code:
$ more /var/log/Xorg.0.log
[   350.250]
X.Org X Server 1.18.4
Release Date: 2016-07-19
[   350.250] X Protocol Version 11, Revision 0
[   350.250] Build Operating System: FreeBSD 12.0-RELEASE-p10 amd64
[   350.250] Current Operating System: FreeBSD amd64.local 12.0-RELEASE-p10 FreeBSD 12.0-RELEASE-p10 GENERIC amd64
[   350.251] Build Date: 07 September 2019  08:40:39AM
[   350.251] 
[   350.251] Current version of pixman: 0.38.4
[   350.251]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   350.251] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   350.251] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Sep 10 12:00:31 2019
[   350.251] (==) Using config file: "/etc/X11/xorg.conf"
[   350.251] (==) ServerLayout "Layout0"
[   350.251] (**) |-->Screen "Screen0" (0)
[   350.251] (**) |   |-->Monitor "Monitor0"
[   350.251] (**) |   |-->Device "Device0"
[   350.251] (**) |-->Input Device "Keyboard0"
[   350.251] (**) |-->Input Device "Mouse0"
[   350.251] (==) Automatically adding devices
[   350.251] (==) Automatically enabling devices
[   350.251] (==) Not automatically adding GPU devices
[   350.251] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   350.251] (**) FontPath set to:
        /usr/local/lib/X11/fonts/misc/:unscaled,
        /usr/local/lib/X11/fonts/100dpi/:unscaled,
        /usr/local/lib/X11/fonts/75dpi/:unscaled,
        /usr/local/lib/X11/fonts/misc/,
        /usr/local/lib/X11/fonts/Type1/,
        /usr/local/lib/X11/fonts/100dpi/,
        /usr/local/lib/X11/fonts/75dpi/,
        /usr/local/lib/X11/fonts/cyrillic/,
        /usr/local/lib/X11/fonts/TTF/,
        /usr/local/share/fonts/misc/,
        /usr/local/share/fonts/TTF/,
        /usr/local/share/fonts/OTF/,
        /usr/local/share/fonts/Type1/,
        /usr/local/share/fonts/100dpi/,
        /usr/local/share/fonts/75dpi/
[   350.251] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[   350.251] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   350.251] (WW) Disabling Keyboard0
[   350.251] (WW) Disabling Mouse0
[   350.251] (II) Loader magic: 0x421020
[   350.251] (II) Module ABI versions:
[   350.251]    X.Org ANSI C Emulation: 0.4
[   350.251]    X.Org Video Driver: 20.0
[   350.251]    X.Org XInput driver : 22.1
[   350.251]    X.Org Server Extension : 9.0
[   350.252] (--) PCI:*(0:2:0:0) 10de:1381:1458:362e rev 162, Mem @ 0xfb000000/16777216, 0xd0000000/268435456, 0xee000000/33554432, I/O @ 0x0000bc00/128, BIOS @ 0x????????/65536
[   350.252] (II) LoadModule: "glx"
[   350.252] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[   350.277] (II) Module glx: vendor="X.Org Foundation"
[   350.278]    compiled for 1.18.4, module version = 1.0.0
[   350.278]    ABI class: X.Org Server Extension, version 9.0
[   350.278] (==) AIGLX enabled
[   350.278] (II) LoadModule: "nvidia"
[   350.278] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[   350.278] (II) Module nvidia: vendor="NVIDIA Corporation"
[   350.278]    compiled for 4.0.2, module version = 1.0.0
[   350.278]    Module class: X.Org Video Driver
[   350.278] (II) NVIDIA dlloader X Driver  390.87  Tue Aug 21 15:27:50 PDT 2018
[   350.278] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   350.278] (--) Using syscons driver with X support (version 2.0)
[   350.278] (--) using VT number 9

[   350.637] (II) Loading sub module "fb"
[   350.637] (II) LoadModule: "fb"
[   350.637] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[   350.638] (II) Module fb: vendor="X.Org Foundation"
[   350.638]    compiled for 1.18.4, module version = 1.0.0
[   350.638]    ABI class: X.Org ANSI C Emulation, version 0.4
[   350.638] (II) Loading sub module "wfb"
[   350.638] (II) LoadModule: "wfb"
[   350.638] (II) Loading /usr/local/lib/xorg/modules/libwfb.so
[   350.638] (II) Module wfb: vendor="X.Org Foundation"
[   350.638]    compiled for 1.18.4, module version = 1.0.0
[   350.638]    ABI class: X.Org ANSI C Emulation, version 0.4
[   350.638] (II) Loading sub module "ramdac"
[   350.638] (II) LoadModule: "ramdac"
[   350.638] (II) Module "ramdac" already built-in
[   350.638] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   350.638] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[   350.638] (==) NVIDIA(0): RGB weight 888
[   350.638] (==) NVIDIA(0): Default visual is TrueColor
[   350.638] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   350.639] (**) NVIDIA(0): Enabling 2D acceleration
[   350.639] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[   350.639] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[   350.639] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[   350.639] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[   350.639] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
--More--(47%)[   350.638] (II) Loading sub module "wfb"
[   350.638] (II) LoadModule: "wfb"
[   350.638] (II) Loading /usr/local/lib/xorg/modules/libwfb.so
[   350.638] (II) Module wfb: vendor="X.Org Foundation"
[   350.638]    compiled for 1.18.4, module version = 1.0.0
[   350.638]    ABI class: X.Org ANSI C Emulation, version 0.4
[   350.638] (II) Loading sub module "ramdac"
[   350.638] (II) LoadModule: "ramdac"
[   350.638] (II) Module "ramdac" already built-in
[   350.638] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   350.638] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[   350.638] (==) NVIDIA(0): RGB weight 888
[   350.638] (==) NVIDIA(0): Default visual is TrueColor
[   350.638] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   350.639] (**) NVIDIA(0): Enabling 2D acceleration
[   350.639] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[   350.639] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[   350.639] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[   350.639] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[   350.639] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
[   351.135] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:2:0:0
[   351.135] (--) NVIDIA(0):     CRT-0
[   351.135] (--) NVIDIA(0):     DFP-0 (boot)
[   351.135] (--) NVIDIA(0):     DFP-1
[   351.135] (--) NVIDIA(0):     DFP-2
[   351.135] (--) NVIDIA(0):     DFP-3
[   351.137] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 750 (GM107-A) at PCI:2:0:0 (GPU-0)
[   351.137] (--) NVIDIA(0): Memory: 1048576 kBytes
[   351.137] (--) NVIDIA(0): VideoBIOS: 82.07.32.00.0c
[   351.137] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   351.144] (--) NVIDIA(GPU-0): CRT-0: disconnected
[   351.144] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[   351.144] (--) NVIDIA(GPU-0):
[   351.159] (--) NVIDIA(GPU-0): Samsung SyncMaster (DFP-0): connected
[   351.159] (--) NVIDIA(GPU-0): Samsung SyncMaster (DFP-0): Internal TMDS
[   351.159] (--) NVIDIA(GPU-0): Samsung SyncMaster (DFP-0): 330.0 MHz maximum pixel clock
[   351.159] (--) NVIDIA(GPU-0):
[   351.160] (--) NVIDIA(GPU-0): DFP-1: disconnected
[   351.160] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[   351.160] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[   351.160] (--) NVIDIA(GPU-0):
[   351.161] (--) NVIDIA(GPU-0): DFP-2: disconnected
[   351.161] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[   351.161] (--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
[   351.161] (--) NVIDIA(GPU-0):
[   351.162] (--) NVIDIA(GPU-0): DFP-3: disconnected
[   351.162] (--) NVIDIA(GPU-0): DFP-3: Internal TMDS
[   351.162] (--) NVIDIA(GPU-0): DFP-3: 330.0 MHz maximum pixel clock
[   351.162] (--) NVIDIA(GPU-0):
[   351.165] (==) NVIDIA(0):
[   351.165] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[   351.165] (==) NVIDIA(0):     will be used as the requested mode.
[   351.165] (==) NVIDIA(0):
[   351.166] (II) NVIDIA(0): Validated MetaModes:
[   351.166] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[   351.166] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
[   351.170] (--) NVIDIA(0): DPI set to (90, 88); computed from "UseEdidDpi" X config
[   351.170] (--) NVIDIA(0):     option
[   351.171] (--) Depth 24 pixmap format is 32 bpp
[   351.171] (II) NVIDIA: Reserving 6144.00 MB of virtual memory for indirect memory
[   351.171] (II) NVIDIA:     access.
[   351.201] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[   351.257] (==) NVIDIA(0): Disabling shared memory pixmaps
[   351.257] (==) NVIDIA(0): Backing store enabled
[   351.257] (==) NVIDIA(0): Silken mouse enabled
[   351.257] (**) NVIDIA(0): DPMS enabled
[   351.257] (II) Loading sub module "dri2"
[   351.257] (II) LoadModule: "dri2"
[   351.257] (II) Module "dri2" already built-in
[   351.257] (II) NVIDIA(0): [DRI2] Setup complete
[   351.257] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   351.257] (--) RandR disabled
[   351.263] (II) AIGLX: Screen 0 is not DRI2 capable
[   351.263] (EE) AIGLX: reverting to software rendering
[   351.355] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[   351.356] (II) AIGLX: Loaded and initialized swrast
[   351.356] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[   351.564] (II) config/devd: probing input devices...
[   351.564] (II) config/devd: adding input device (null) (/dev/kbdmux)
[   351.564] (II) LoadModule: "kbd"
[   351.564] (II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
[   351.564] (II) Module kbd: vendor="X.Org Foundation"
[   351.564]    compiled for 1.18.4, module version = 1.9.0
[   351.565]    Module class: X.Org XInput Driver
[   351.565]    ABI class: X.Org XInput driver, version 22.1
[   351.565] (II) Using input driver 'kbd' for 'kbdmux'
[   351.565] (**) kbdmux: always reports core events
[   351.565] (**) kbdmux: always reports core events
[   351.565] (**) Option "Protocol" "standard"
[   351.565] (**) Option "XkbRules" "base"
[   351.565] (**) Option "XkbModel" "pc105"
[   351.565] (**) Option "XkbLayout" "us"
[   351.565] (**) Option "config_info" "devd:kbdmux"
[   351.565] (II) XINPUT: Adding extended input device "kbdmux" (type: KEYBOARD, id 6)
[   352.081] (II) config/devd: kbdmux is enabled, ignoring device ukbd0
[   352.081] (II) config/devd: kbdmux is enabled, ignoring device atkbd0
[   352.081] (II) config/devd: adding input device (null) (/dev/sysmouse)
[   352.081] (II) LoadModule: "mouse"
[   352.081] (II) Loading /usr/local/lib/xorg/modules/input/mouse_drv.so
[   352.081] (II) Module mouse: vendor="X.Org Foundation"
[   352.081]    compiled for 1.18.4, module version = 1.9.3
[   352.081]    Module class: X.Org XInput Driver
[   352.081]    ABI class: X.Org XInput driver, version 22.1
[   352.081] (II) Using input driver 'mouse' for 'sysmouse'
[   352.081] (**) sysmouse: always reports core events
[   352.081] (**) Option "Device" "/dev/sysmouse"
[   352.081] (==) sysmouse: Protocol: "Auto"
[   352.081] (**) sysmouse: always reports core events
[   352.081] (==) sysmouse: Emulate3Buttons, Emulate3Timeout: 50
[   352.081] (**) sysmouse: ZAxisMapping: buttons 4 and 5
[   352.081] (**) sysmouse: Buttons: 5
[   352.081] (**) Option "config_info" "devd:sysmouse"
[   352.081] (II) XINPUT: Adding extended input device "sysmouse" (type: MOUSE, id 7)
[   352.081] (**) sysmouse: (accel) keeping acceleration scheme 1
[   352.082] (**) sysmouse: (accel) acceleration profile 0
[   352.082] (**) sysmouse: (accel) acceleration factor: 2.000
[   352.082] (**) sysmouse: (accel) acceleration threshold: 4
[   352.082] (II) sysmouse: SetupAuto: hw.iftype is 4, hw.model is 0
[   352.082] (II) sysmouse: SetupAuto: protocol is SysMouse
[   352.082] (II) config/devd: device /dev/ums0 already opened
 
#2
Moin,

bei mir ist die Aktualisierung des Packages schon eine Weile her. Ich habe gerade nachgesehen: Der Port wurde Mitte August aktualisiert. Kurz danach war vermutlich das Package verfügbar. Deswegen Frage ich mich (bzw. dich):

1. Welche Karte hast du?
2. Welche Packages nutzt du (quarterly/latest)?
3. Was sagt "pkg info nvidia-driver"?
4. Wie lädst du das Modul nvidia-modeset.ko (über /etc/rc.conf oder /boot/loader.conf)?

HTH
 
Themenstarter #3
Geforce GTX 750
quarterly

Code:
# pkg info nvidia-driver
nvidia-driver-390.87_3
Name           : nvidia-driver
Version        : 390.87_3
Installed on   : Tue Sep 10 11:31:36 2019 CEST
Origin         : x11/nvidia-driver
Architecture   : FreeBSD:12:amd64
Prefix         : /usr/local
Categories     : x11 kld
Licenses       : NVIDIA
Maintainer     : danfe@FreeBSD.org
WWW            : https://www.nvidia.com/object/unix.html
Comment        : NVidia graphics card binary drivers for hardware OpenGL rendering
Options        :
    ACPI_PM        : off
    DOCS           : on
    LINUX          : on
    WBINVD         : off
Shared Libs required:
    libXext.so.6
    libX11.so.6
Shared Libs provided:
    libnvidia-ml.so.1
    libnvidia-eglcore.so.1
    libGL.so.1
    libvdpau_nvidia.so.1
    libnvidia-glsi.so.1
    libnvidia-cfg.so.1
    libGLESv1_CM.so.1
    libEGL.so.1
    libGLESv2.so.2
    libnvidia-glcore.so.1
    libnvidia-tls.so.1
Annotations    :
    FreeBSD_version: 1200086
    repo_type      : binary
    repository     : FreeBSD
Flat size      : 388MiB
Description    :
These are the official NVidia binary drivers for hardware OpenGL rendering
in X11, using the GLX extensions.

WWW: https://www.nvidia.com/object/unix.html
#
/boot/loader.conf
 
#6
Ok, ich würde dir trotzdem dazu raten, es in /etc/rc.conf zu belassen. Zurück zum Thema: Ich meine mich zu erinnern, dass es ein Problem gab, wenn ein bestimmtes Paket installiert wurde, bevor/nachdem der nvidia-Treiber installiert ist. Evtl. war es mesa-dri. Hast du das installiert?

Ansonsten verlassen mich die Ideen. Ausser dass es von dem von dir installierten Paket mehrere Versionen gab: https://www.freshports.org/x11/nvidia-driver/

Vielleicht ist in quarterly blöderweise eine kaputte Version gelandet? Ich habe bei mir jedenfalls latest-Pakete erfolgreich im Einsatz.
 
Themenstarter #7
Ich habe gerade das Paket nvidia-driver deinstalliert, den Portstree auf den neuesten Stand gebracht und nvidia-driver aus den Ports installiert. Neustart, leider kein Unterschied. Das Paket mesa-dri ist installiert, kann aber wohl schlecht deinstalliert werden:

Code:
# pkg delete mesa-dri
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 9 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
    mesa-dri-18.3.2_4
    xorg-server-1.18.4_11,1
    xorg-7.7_3
    nvidia-driver-390.87_3
    xf86-input-keyboard-1.9.0_3
    xf86-input-mouse-1.9.3_2
    xf86-video-scfb-0.0.4_7
    xf86-video-vesa-2.4.0_2
    xorg-drivers-7.7_5

Number of packages to be removed: 9

The operation will free 423 MiB.

Proceed with deinstalling packages? [y/N]:
 
#8
Ich habe jetzt mal dein Logfile mit meinen verglichen. Aufgefallen ist mir dabei:

Dein Logfile hat gesagt.:
[ 350.252] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[ 350.277] (II) Module glx: vendor="X.Org Foundation"
[ 350.278] compiled for 1.18.4, module version = 1.0.0
[ 350.278] ABI class: X.Org Server Extension, version 9.0
[ 350.278] (==) AIGLX enabled
[ 350.278] (II) LoadModule: "nvidia"
[ 350.278] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[ 350.278] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 350.278] compiled for 4.0.2, module version = 1.0.0
[ 350.278] Module class: X.Org Video Driver
Mein Logfile hat gesagt.:
[ 579.796] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[ 579.825] (II) Module glx: vendor="NVIDIA Corporation"
[ 579.825] compiled for 4.0.2, module version = 1.0.0
[ 579.825] Module class: X.Org Server Extension
[ 579.825] (II) NVIDIA GLX Module 390.87 Tue Aug 21 15:49:05 PDT 2018
[ 579.825] (II) LoadModule: "nvidia"
[ 579.826] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[ 579.829] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 579.829] compiled for 4.0.2, module version = 1.0.0
[ 579.829] Module class: X.Org Video Driver
Bei mir läd er glx vencor= NVIDIA. Bei dir ist es X.Org. Das dürfte das Problem sein. hast du zusätzliche glx-Pakete installiert?
 
Themenstarter #9
Code:
# pkg info | grep glx
libva-glx-2.5.0                VAAPI wrapper for GLX
# pkg delete libva-glx
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 4 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
    libva-glx-2.5.0
    libxine-1.2.9_9
    xine-0.99.9_7
    kdenlive-18.12.3_4

Number of packages to be removed: 4

The operation will free 68 MiB.

Proceed with deinstalling packages? [y/N]:
Ich habe nvidia-xconfig mal ausgeführt, das hat eine neue xorg.conf erstellt und ein Backup der alten gemacht, dann Neustart, aber keine Änderung. Meinst Du, libva-glx könnte das Problem sein? Ich brauche xine und kdenlive unbedingt...
 
#10
libva-glx ist bei mir ebenfalls installiert.

In /usr/local/lib/xorg/modules/extensions müsste ein Verzeichnis mit dem Namen .nvidia exisiteren. Dort liegt libglx.so drin (in dem Verzeichnis .xorg ebenfalls).

/usr/local/lib/xorg/modules/extensions # ls -l
total 7783
drwxr-xr-x 2 root wheel 4 13 Juli 09:58 .nvidia
drwxr-xr-x 2 root wheel 3 28 Aug. 17:14 .xorg
-r--r--r-- 3 root wheel 14005664 12 Juli 01:45 libglx.so
-r--r--r-- 3 root wheel 14005664 12 Juli 01:45 libglx.so.1
-rwxr-xr-x 1 root wheel 634304 2 Apr. 04:57 libvnc.so
Die Größe meiner libglx.so entspricht der im Verzeichnis .nvidia. ich tippe mal darauf, dass bei dir die Größe der Datei im Verzeichnis .xorg entspricht. Warum er die Datei nicht überschreibt, weiß ich nicht. Aber kopiere die doch mal manuell um.
 
Themenstarter #11
Also bei mir sieht es in den Verzeichnissen folgendermaßen aus:

Code:
# ls /usr/local/lib/xorg/modules/extensions/
.nvidia                        XXX-libglx.so.%%.orig-20180216
.xorg                          libglx.so
# ls /usr/local/lib/xorg/modules/extensions/.nvidia/
libglx.so   libglx.so.1
# ls /usr/local/lib/xorg/modules/extensions/.xorg/
XXX-libglx.so.%%.orig-20180216 libglx.so
#
Was soll ich jetzt also genau machen?
 
#12
Die Ausgabe von ls -l wäre besser gewesen, denn dann hätten wir die Größen der Dateien vergleichen können.

Sichere das Verzeichnis "extensions" inkl. Unterverzeichnissen weg. Danach kopierst du den Inhalt von .nvidia direkt ins Verzeichnis extensions. Danach versuchst du es noch einmal.
 

serie300

Well-Known Member
#13
Ich kenn mich ja praktisch nur mitAti ind intel aus.

Aber kannst du mal mit kldstat schauen , ob die erforderlichen Module tatsächlich im Kernel gelandet sind.

2. Ab 11.3 bzw. 12.0 solte xorg.conf der Vergangenheit angehören. Es sollte alles in /local ... über Einzeldateien konfiguriert werden . und dort möglichst die automagie machen lassen .
 
Themenstarter #14
Code:
$ kldstat
Id Refs Address                Size Name
 1   63 0xffffffff80200000  243d228 kernel
 2    3 0xffffffff8263f000    a6b78 linux.ko
 3    5 0xffffffff826e6000     8df8 linux_common.ko
 4    3 0xffffffff826ef000    8a438 vboxdrv.ko
 5    1 0xffffffff8277a000    20af0 firewire.ko
 6    1 0xffffffff82819000     490c linprocfs.ko
 7    1 0xffffffff8281e000    f4ef0 nvidia-modeset.ko
 8    1 0xffffffff82913000   c42ae8 nvidia.ko
 9    1 0xffffffff83556000     cc50 snd_uaudio.ko
10    1 0xffffffff83563000     1800 uhid.ko
11    1 0xffffffff83565000     23a8 ums.ko
12    2 0xffffffff83568000     2ce0 vboxnetflt.ko
13    2 0xffffffff8356b000     a020 netgraph.ko
14    1 0xffffffff83576000     1710 ng_ether.ko
15    1 0xffffffff83578000     3f30 vboxnetadp.ko
16    1 0xffffffff8357c000      acf mac_ntpd.ko
17    1 0xffffffff8357d000    16a78 ext2fs.ko
18    1 0xffffffff83594000     9c08 fuse.ko
19    1 0xffffffff8359e000     3d44 geom_linux_lvm.ko
20    1 0xffffffff835a2000   247e20 zfs.ko
21    1 0xffffffff837ea000     7628 opensolaris.ko
$
Das ist nicht das Problem. Und mit der xorg.conf hatte es bis heute funktioniert.
 
Themenstarter #16
Sichere das Verzeichnis "extensions" inkl. Unterverzeichnissen weg. Danach kopierst du den Inhalt von .nvidia direkt ins Verzeichnis extensions. Danach versuchst du es noch einmal.
Vielen Dank, das war's! Warum das jedoch passiert ist, bzw. das Upgrade nicht geklappt hat, bleibt jedoch ein Rätsel!

Habe ich beim nächsten pkg upgrade wieder das Gleiche zu erwarten?

Noch eine Frage: Was ist XXX-libglx.so.%%.orig-20180216 für eine Datei? Aufgrund des Datums, das diese im Namen enthält, vielleicht ein automatisch erstelltes Backup durch das Upgrade?
 
#17
Habe ich beim nächsten pkg upgrade wieder das Gleiche zu erwarten?
Ich kenne das Verhalten nicht und habe schon einige Male aktualisiert.

Noch eine Frage: Was ist XXX-libglx.so.%%.orig-20180216 für eine Datei? Aufgrund des Datums, das diese im Namen enthält, vielleicht ein automatisch erstelltes Backup durch das Upgrade?
Das erinnert mich ein wenig an Patches, die über die Ports "installiert" werden. Hattest du mal Ports genutzt? Ich gehe jedenfalls davon aus, dass das ein Überbleibsel einer alten Installation ist.