• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Problem mit wpa_supplicant (wlan0 no carrier)

Themenstarter #1
Hallo,

ich habe ein kleines Problem mit meiner W-LAN Konfiguration. Die W-LAN Karte von meinem Laptop wird von FreeBSD nicht unterstützt, deshalb habe ich einen USB-Adapter gekauft mit einem Realtek 8192CU chip. Anschließend die Zeilen
Code:
if_urtwn_load="YES"
legal.realtek.license_ack=1
in meine /boot/loader.conf eingetragen wie in urtwn(4) beschrieben.
Der Befehl ifconfig wlan0 list scan gibt eine Liste der in der Nähe liegenden W-LAN Netzwerke aus, was zeigt, dass der WLAN Stick funktioniert.

Das Problem ist, dass es mir nach eintragen der Netzwerk-Konfiguration in /etc/wpa_supplicant.conf
Code:
ctrl_interface=/var/run/wpa_supplicant
eapol_version=2
ap_scan=1
fast_reauth=1
network={
ssid="UPC31*****"
psk="********"
}
nicht gelingt, mich mit dem entsprechenden WLAN-Netzwerk zu verbinden. Bei dem Versuch, das Gerät mit
service netif restart
zu verbinden (FreeBSD-Handbuch Abschnitt 30.3.2), hat das Gerät urtwn0 zwar den Status "associated", aber die Ausgabe von ifconfig wlan0 ergibt "no carrier".

Aus diesem Grund habe ich versucht, es manuell mit
wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf zu starten, erhalte jedoch:
Code:
Successfully initialized wpa_supplicant
ioctl[SIOCS80211, op=103, val=0, arg_len=128]: Device not configured
wlan0: Failed to initiate AP scan
Vermutlich liegt das Problem entweder in wpa_supplicant oder dhclient; Zumindest kann ich problemlos eine Kabelverbindung zum Router herstellen. Es wäre aber praktisch, wenn auch das WLAN funktionieren würde.
Falls jemand eine Idee hat, woran das liegen könnte,so wäre ich dankbar für Hilfe.

(Dieses Thema ist identisch zu https://forums.freebsd.org/threads/56559/
, aber da dies leider nicht hilfreich war, poste ich das hier nochmal.)
 
#2
Moin C0gito,

bei manchen WLAN-Routern muss man die MAC-Adresse der WLAN-Karte des Clients eintragen,damit überhaupt eine Verbindung möglich ist. Ist das bei Deinem Router vielleicht der Fall?
Was steht in /etc/rc.conf?

Grüßle

Jürgen
 
Themenstarter #3
Bei meinem Router gibt es keine Möglichkeit, die MAC-Adresse des Clients einzutragen.
Die /etc/rc.conf beinhaltet (hier nur der relevante Teil):
Code:
ifconfig_alc0="DHCP" # for Ethernet-LAN
wlans_urtwn0="wlan0"
ifconfig_wlan0="WPA DHCP"
#ifconfig_urtwn0="DHCP"
Ich habe die Ausgabe von wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf -dd >& out.txt in dem Forum https://forums.freebsd.org/threads/56559/
genauer beschrieben, falls das hilfreich ist.
 
#4
Hallo!

Ich hatte ein ähnliches Problem mit der Kombination FreeBSD / RaspberryPi / Edimax-7811UN Wifi. Für diesen Edimax wird ebenfalls der urtwn-Treiber verwendet. Nachdem ich stundenlang alles mögliche probiert hatte, habe ich mir die urtwn-Manpage nochmal bis ganz zum Ende durchgelesen. Dort steht, daß der Treiber keinen Wifi Modus "802.11n" unterstützt. Nachdem ich den Router auf Mode "b/g" gestellt hatte, hat es funktioniert.

Grüße
 
Themenstarter #5
In der Manpage von urtwn(4) steht aber unter Harware:
The urtwn driver supports Realtek RTL8188CU (...)
based USB IEEE 802.11b/g/n wireless network adapters, including (...)
, müsste der Treiber dann nicht auch 802.11n unterstützen? Wie auch immer, ich habe in den Router-Einstellungen bei 802.11n Modus auf "Gemischt (802.11b, 802.11g und 802.11n)" umgestellt, jedoch ohne Erfolg. Merkwürdigerweise ging der Treiber mal; Als ich den wlan USB-Stick das erste Mal benutzt habe, konnte ich ihn mit dem Internet verbinden und für ein paar Tage nutzen. Erst als ich danach wieder eine Kabelverbindung benutzt habe, trat das Problem mit dem W-LAN auf.
 

pit234a

Well-Known Member
#6
um Probleme mit falscher Syntax in der wpa_supplicant.conf zu vermeiden, möchte ich zunächst empfehlen, diese anfangs so minimal wie möglich zu gestalten und sodann vielleicht wifimgr ( net-mgmt/wifimgr ) dafür zu verwenden. wifimgr ist ein grafischer Editor für die /etc/wpa_supplicant.conf der angeblich richtige Syntax produziert. Ich habe das nur ein einziges Mal probiert und da funktionierte es ausgezeichnet, um mir zumindest ein Gerüst zu verleihen, das ich dann ausbauen konnte.
Insbesondere fällt mir auf, dass du keine Angaben zum kyemanagement machst. key_mgmt=WPA-PSK steht bei mir in beinahe jedem Block.
Die Ausgabe, die du verlinkt hast, kann ich derzeit nicht finden. Wenn sie hilfreich sein sollte, stell sie doch bitte hier nochmal ein.

Wird deine eingebaute Karte wirklich nicht unterstützt oder hast du das nur aus Kompa-Listen entnommen?
Manchmal (fast immer) sind diese Listen nicht aktuell und es lohnt sich der Versuch. Kostet ja auch nichts.
 
Themenstarter #7
Ich habe mal gerade wifimgr(8) ausprobiert, das scheint ein praktisches Programm zu sein. Damit habe ich die Netzwerk-Informationen neu eingetragen, aber es hat in der wpa_supplicant.conf bis auf proto=RSN WPA nichts weiter verändert.
Code:
# /etc/wpa_supplicant.conf written by wifimgr(8)

   ctrl_interface=/var/run/wpa_supplicant
   eapol_version=2
   ap_scan=1
   fast_reauth=1

network={
   ssid="UPC3128905"
   key_mgmt=WPA-PSK
   proto=RSN WPA
   psk="********"
}
Bezüglich der eingebauten W-LAN Karte: Ich habe damals mit pciconf -lv den Chipsatz der Karte ermittelt (RTL8723AE) und ein paar Treiber ausprobiert; der Chip wird auch nirgendwo in den Hardware Notes aufgeführt. Da der USB-Stick aber in jeden Fall funktioniert, ist das auch nicht das Problem. Hier ist die Ausgabe von (Achtung, sehr lang)
wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf -dd >& out.txt
Code:
wpa_supplicant v2.0
Successfully initialized wpa_supplicant
Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
eapol_version=2
ap_scan=1
fast_reauth=1
Line: 8 - start of a new network block
ssid - hexdump_ascii(len=10):
  55 50 43 33 31 32 38 39 30 35  UPC3128905  
key_mgmt: 0x2
proto: 0x3
PSK (ASCII passphrase) - hexdump_ascii(len=8): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Priority group 0
  id=0 ssid='UPC3128905'
wpa_driver_bsd_capa: drivercaps=0x2181c001,cryptocaps=0x00000000
wlan0: Own MAC address: ff:ff:ff:ff:ff:ff
bsd_set_key: alg=0 addr=0x0 key_idx=0 set_tx=0 seq_len=0 key_len=0
bsd_del_key: key_idx=0
bsd_set_key: alg=0 addr=0x0 key_idx=1 set_tx=0 seq_len=0 key_len=0
bsd_del_key: key_idx=1
bsd_set_key: alg=0 addr=0x0 key_idx=2 set_tx=0 seq_len=0 key_len=0
bsd_del_key: key_idx=2
bsd_set_key: alg=0 addr=0x0 key_idx=3 set_tx=0 seq_len=0 key_len=0
bsd_del_key: key_idx=3
wpa_driver_bsd_set_countermeasures: enabled=0
wlan0: RSN: flushing PMKID list in the driver
wlan0: Setting scan request: 0 sec 100000 usec
WPS: Set UUID for interface wlan0
WPS: UUID based on MAC address - hexdump(len=16): 32 8c a6 57 e0 fa 54 6e ba e7 d3 90 05 da 90 13
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: Supplicant port status: Unauthorized
EAPOL: Supplicant port status: Unauthorized
Using existing control interface directory.
wlan0: Added interface wlan0
wlan0: State: DISCONNECTED -> DISCONNECTED
wlan0: State: DISCONNECTED -> SCANNING
wlan0: Starting AP scan for wildcard SSID
wpa_driver_bsd_set_wpa: enabled=1
wpa_driver_bsd_set_wpa_internal: wpa=3 privacy=1
EAPOL: disable timer tick
EAPOL: Supplicant port status: Unauthorized
wlan0: Event SCAN_RESULTS (3) received
Received 2528 bytes of scan results (8 BSSes)
wlan0: BSS: Start scan result update 1
wlan0: BSS: Add new id 0 BSSID 88:f7:c7:9b:63:cb SSID 'UPC3128905'
wlan0: BSS: Add new id 1 BSSID 14:49:e0:d9:e3:98 SSID 'UPC246152873'
wlan0: BSS: Add new id 2 BSSID 54:88:0e:b1:19:18 SSID 'UPC242585275'
wlan0: BSS: Add new id 3 BSSID c8:0e:14:64:df:f1 SSID 'Winter'
BSS: last_scan_res_used=8/32 last_scan_full=0
wlan0: New scan results available
WPS: AP 14:49:e0:d9:e3:98 type 0 added
WPS: AP 54:88:0e:b1:19:18 type 0 added
WPS: AP c8:0e:14:64:df:f1 type 0 added
WPS: AP[0] 14:49:e0:d9:e3:98 type=0 tries=0 last_attempt=-1 sec ago blacklist=0
WPS: AP[1] 54:88:0e:b1:19:18 type=0 tries=0 last_attempt=-1 sec ago blacklist=0
WPS: AP[2] c8:0e:14:64:df:f1 type=0 tries=0 last_attempt=-1 sec ago blacklist=0
wlan0: Selecting BSS from priority group 0
wlan0: 0: 88:f7:c7:9b:63:cb ssid='UPC3128905' wpa_ie_len=26 rsn_ie_len=24 caps=0x11 level=-47
wlan0:  selected based on RSN IE
wlan0:  selected BSS 88:f7:c7:9b:63:cb ssid='UPC3128905'
wlan0: Request association: reassociate: 0  selected: 88:f7:c7:9b:63:cb  bssid: 00:00:00:00:00:00  pending: 00:00:00:00:00:00  wpa_state: SCANNING
wlan0: Trying to associate with 88:f7:c7:9b:63:cb (SSID='UPC3128905' freq=2442 MHz)
FT: Stored MDIE and FTIE from (Re)Association Response - hexdump(len=0):
wlan0: Cancelling scan request
wlan0: WPA: clearing own WPA/RSN IE
wlan0: Automatic auth_alg selection: 0x1
RSN: PMKSA cache search - network_ctx=0x0 try_opportunistic=0
RSN: Search for BSSID 88:f7:c7:9b:63:cb
RSN: No PMKSA cache entry found
wlan0: RSN: using IEEE 802.11i/D9.0
wlan0: WPA: Selected cipher suites: group 8 pairwise 24 key_mgmt 2 proto 2
WPA: set AP WPA IE - hexdump(len=28): dd 1a 00 50 f2 01 01 00 00 50 f2 02 02 00 00 50 f2 04 00 50 f2 02 01 00 00 50 f2 02
WPA: set AP RSN IE - hexdump(len=26): 30 18 01 00 00 0f ac 02 02 00 00 0f ac 04 00 0f ac 02 01 00 00 0f ac 02 0c 00
wlan0: WPA: using GTK TKIP
wlan0: WPA: using PTK CCMP
wlan0: WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=22): 30 14 01 00 00 0f ac 02 01 00 00 0f ac 04 01 00 00 0f ac 02 00 00
wlan0: No keys have been configured - skip key clearing
wlan0: State: SCANNING -> ASSOCIATING
Limit connection to BSSID 88:f7:c7:9b:63:cb freq=2442 MHz based on scan results (bssid_set=0)
wpa_driver_bsd_associate: ssid 'UPC3128905' wpa ie len 22 pairwise 3 group 2 key mgmt 1
wpa_driver_bsd_set_drop_unencrypted: enabled=1
bsd_set_opt_ie: set WPA+RSN ie (len 22)
wpa_driver_bsd_associate: set PRIVACY 1
wlan0: Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - EAP fail=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portControl=Auto
EAPOL: Supplicant port status: Unauthorized
RSN: Ignored PMKID candidate without preauth flag
wlan0: Authentication with 88:f7:c7:9b:63:cb timed out.
Added BSSID 88:f7:c7:9b:63:cb into blacklist
wlan0: Request to deauthenticate - bssid=00:00:00:00:00:00 pending_bssid=88:f7:c7:9b:63:cb reason=3 state=ASSOCIATING
wlan0: Event DEAUTH (12) received
wlan0: Deauthentication notification
wlan0:  * reason 3 (locally generated)
Deauthentication frame IE(s) - hexdump(len=0): [NULL]
wlan0: CTRL-EVENT-DISCONNECTED bssid=88:f7:c7:9b:63:cb reason=3 locally_generated=1
wlan0: Auto connect enabled: try to reconnect (wps=0 wpa_state=5)
wlan0: Setting scan request: 0 sec 100000 usec
BSSID 88:f7:c7:9b:63:cb blacklist count incremented to 2
wlan0: Blacklist count 2 --> request scan in 500 ms
wlan0: Setting scan request: 0 sec 500000 usec
wlan0: Disconnect event - remove keys
(...)
Auffallend ist, dass er zwar die richtige SSID (UPC3128905) aus dem network block der wpa_supplicant.conf ausliest und versucht, sich mit dieser zu verbinden (s. fette Hervorhebung), aber anschliessend die entsprechende BSSID auf eine blacklist setzt. Was heißt überhaupt "RSN: No PMKSA cache entry found" ?
Vielen Dank für Eure Hilfe.

EDIT: Ich sehe gerade, dass man die Hervorhebung im CODE-Block nicht erkennt. Gemeint war die Zeile
Code:
wlan0: Trying to associate with 88:f7:c7:9b:63:cb (SSID='UPC3128905' freq=2442 MHz)
Das ist zwar das richtige Netzwerk, aber danach kommt ein
Code:
wlan0: Authentication with 88:f7:c7:9b:63:cb timed out.
und die BSSID landet auf einer blacklist.
 

pit234a

Well-Known Member
#8
viel habe ich dazu nicht mehr zu sagen.
zur internen Karte: meiner Meinung nach funktioniert eine Netzwerkkarte dann nicht, wenn sie bei ifconfig nicht aufgelistet ist. Es gibt zwar grundsätzlich die Möglichkeit über den NDISWRAPPER zu gehen, aber für mich kam das nie in Frage.
Erkennt das Betriebssystem die Karte und trägt sie passend ein, dann ist auch klar, welches Modul dafür geladen werden muss.
Wie du aber schon sagst: das ist nicht der Fehler, den du nun finden möchtest.

ifconfig wlan0 scan zeigt dir ja ein plausibles Ergebnis und deshalb kann man davon ausgehen, dass du die Karte richtig konfiguriert hast. Du hast damit einen passenden Treiber gewählt und dem passenden Gerät zugewiesen.
Du könntest nun probieren, ohne Verschlüsselung mit deinem AcessPoint zu verbinden. Nur Testweise natürlich.
Der Fehler stellt sich so dar, als wenn die wpa_supplicant.conf einen Fehler hätte. Das kommt ja leicht vor, dass man da einen Syntax-Fehler einbaut, irgendwo ein Komma vergisst oder ein Anführungszeichen zu wenig hat oder so etwas. Manchmal sieht man das nicht sofort und deshalb der Tip mit wifimgr.
Der allerdings nicht zum erhofften Erfolg führte.

Wenn also nun die Karte funktioniert und soweit unterstützt wird, wenn die wpa-supplicant.conf korrekt ist und die benötigten Dienste gestartet sind und wenn tatsächlich ein WPA-PSK benutzt wird (und nicht vielleicht WEP), dann weiß ich auch nicht, was da noch im Argen liegen könnte.
Nur zur Fehlersuche würde ich alle Möglichkeiten durchgehen, die ich habe. Also zunächst den AP ohne Verschlüsselung betreiben, dann mit WEP, dann WPA-PSK. Den AP wechseln (also vielleicht mal in einem anderen Netzwerk probieren, Internet-Caffee mit freiem Zugang oder so). Insgesamt ergibt sich dann vielleicht irgendwo ein weiterer Hinweis.
 

Wasp

Insektenspray-Gegner
#9
Habe jetzt ziemlich genau gleiches Problem unter FreeBSD 10.4 release auf ARMv6 (RaspberryPI-B).

Bis zu dem Punkt an dem ich via wpa_passphrase(8) die Netzwerkzugangsdaten in wpa_supplicant.conf eingebe ist alles gut. Erst wenn wpa_supplicant via`wla_cli reconfigure` versuche zu verbinden läuft es irgendwo schief:
Code:
wlan0: Trying to associate with b4:a5:ef:b8:6b:de (SSID='MeinWLAN' freq=2412 MHz)
wlan0: Associated with b4:a5:ef:b8:6b:de
ioctl[SIOCS80211, op=19, val=0, arg_len=64]: Device not configured
wlan0: WPA: Failed to set PTK to the driver (alg=3 keylen=16 bssid=b4:a5:ef:b8:6b:de)
wlan0: CTRL-EVENT-DISCONNECTED bssid=b4:a5:ef:b8:6b:de reason=1 locally_generated=1
wlan0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="MeinWLAN" auth_failures=1 duration=10
ioctl[SIOCS80211, op=20, val=0, arg_len=7]: Can't assign requested address
wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="MeinWLAN"
Hier noch die dmsg(8)-Ausgabe:
Code:
Oct 23 03:32:33 rpi-b kernel: wlan0: link state changed to UP
Oct 23 03:32:33 rpi-b kernel: ieee80211_load_module: load the wlan_ccmp module by hand for now.
Oct 23 03:32:33 rpi-b kernel: wlan0: link state changed to DOWN
Oct 23 03:32:33 rpi-b devd: Executing '/etc/rc.d/dhclient quietstart wlan0'
Der Witz an der Sache: unter FreeBSD 10.2 release auf AMD64 läufts prima. Habe ein wenig das Gefühl, daß ich was vergessen habe, aber weiß nicht was...

Nachtrag:
Habe gerade noch if_urtwn_load="YES" in /boot/loader.conf eingetragen und dann einen Neustart durchgeführt -- jetzt gehts! Aber nichts von beidem sollte eigentlich ein Grund sein... :/