Probleme autoconf-wrapper zu installieren (apache 2.x)

I.MC

Watt soll denn hier hin?
Moin zusammen,

wenn ich versuche apache 2.x zu aktualisieren, dann laufe ich in folgenden Fehler:

Code:
===>  Checking if devel/autoconf-wrapper already installed
ln: /usr/local/bin/autoconf: File exists
*** Error code 1

Stop in /usr/ports/devel/autoconf-wrapper.
*** Error code 1

Stop in /usr/ports/devel/autoconf-wrapper.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portinstall.36679.1 env make reinstall
** Fix the installation problem and try again.
--->  Skipping 'devel/autoconf261' because a requisite port 'devel/autoconf-wrapper' failed (specify -k to force)
--->  Skipping 'www/apache22' because a requisite port 'devel/autoconf261' failed (specify -k to force)
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! devel/autoconf-wrapper        (install error)
        * devel/autoconf261
        * www/apache22

Ports aktuell, geht einfach nicht. Weiß einer Rat?

Gruß, I.MC
 

Kamikaze

Warrior of Sunlight
Anscheinend ist der autoconf-wrapper schon installiert, aber irgendwie beschädigt. Die Datei /usr/local/bin/autoconf-wrapper scheint zu fehlen.

Ruf mal
# pkg_info -gx autoconf-wrapper

auf.
 

I.MC

Watt soll denn hier hin?
Ist nicht installiert. Zumindest nicht laut pkg_info. Zudem fehlt nicht die die Datei /usr/local/bin/autoconf-wrapper, sondern es existiert schon eine Datei namens /usr/local/bin/autoconf. Auch wenn ich die störende Datei lösche, ist sie beim kompilieren wieder da und im Weg, teilweise auch andere Dateien. Sehr seltsame Sache.
 

I.MC

Watt soll denn hier hin?
Ich glaube du liest nicht genau, was ich geschrieben habe bzw, wie die Fehlermeldung ist. Dennoch gehört die störende Datei keinem Paket an.
 

Kamikaze

Warrior of Sunlight
Irgendein Paket muss das Zeug doch anlegen. Also sollte sie auch zu irgendeinem Paket gehören.

Kann es sein, dass du make -j verwendest? Das darfst du nur zum build verwenden, beim install geht das oft schief. Dann schießt sich das install vom autoconf-wrapper selbst in den Fuß.

Der SUBTHREADS Parameter in den buildflags wird zum Beispiel aus diesem Grund automatisch deaktiviert, wenn das install Target aufgeraufen wird.

Wenn du einen Port baust der dependencies zieht, darfst du also nicht make -j verwenden, es sei denn du verwendest dazu ein Tool wie portmaster, dass die Schritte einzeln angeht und ein Framework wie buildflags, dass dafür sorgt, dass nur der build Teil parallelisiert wird.
 

I.MC

Watt soll denn hier hin?
Kein make -j, Portupgrade. Mir ist es ein Rätsel was hier los ist. Ich werde einmal den gesamten Ports Baum löschen und neu ziehen. Ansonsten fällt mir nichts mehr ein und ich werde mal auf die mailing list schreiben.
 

true

FreeBSD Desktop user
Gibt es da eine Lösung dazu? Habe das selbe Problem:

Code:
===>  Checking if devel/autoconf-wrapper already installed
ln: /usr/local/bin/autoconf: File exists
*** Error code 1
 

morromett

Well-Known Member
"/usr/local/bin/autoconf" sollte keine Datei sein, sondern ein Link auf "/usr/local/bin/autoconf-wrapper" (... wenn autoconf-wrapper-20071109 intstalliert ist). Anscheinend ist bei dir "autoconf-wrapper-20071109" nicht installiert. Versuche die "falsche" Datei "/usr/local/bin/autoconf" zu löschen und dann sofort mit "pkg_add -r autoconf-wrapper" den "autoconf-wrapper-20071109" zu installieren. Nach der Installation müsste ein Link "/usr/local/bin/autoconf" auf "/usr/local/bin/autoconf-wrapper" vorhanden sein.
 
Oben