• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Probleme bei Start von MariaDB

Themenstarter #1
Hallo alle zuammen,

ich bin neu hier und bräuchte mal etwas unterstützung zu manchen Themen.
Ich habe root zugriff auf einen jail FreeBSD 11.1-RELEASE-p4 den ich nur für mich und auch nur für lehrzwecke habe; also da kommt nichts lebensnotendiges oder so drauf, das ist nur zum spielen und probieren da, eine sms an den superadmin und alles ist wieder zurück gesetzt.

Ich habe die ports besser kennengelernt und nach kurzer zeit schon kam ich eigentlich ziemlich gut klar. Auch wie mit paketen umgegangen wird finde ich sehr toll.
Iwie finde ich es schon fast einfacher als linux selber, wo es je nach distribution unterschiede gibt.

Aber ok, genug davon.

Ich hatte mal apache und php drauf, das habe ich gelöscht und jetzt ist da nginx und php drauf, alles funktioniert. Nur jetzt bei mariadb komme ich iwie nicht so weiter...

Da ist mal die installationsbeschreibung
https://justpaste.it/5buzk

etwas weiter unten steht dann das hier
===> Creating groups.
Using existing group 'mysql'.
===> Creating users
Using existing user 'mysql'.

soweit auch nicht dramatisch

Damit meine ich startet der sql server automatisch
echo 'mysql_enable="YES"' >> /etc/rc.conf

Wenn ich den dienst starte und danach prüfe kommt das hier
/usr/local/etc/rc.d/mysql-server status
mysql is not running.

Mein nächster Schritt war dieser
/usr/local/bin/mysql_secure_installation

NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB
SERVERS IN PRODUCTION USE! PLEASE READ EACH STEP CAREFULLY!

In order to log into MariaDB to secure it, we'll need the current
password for the root user. If you've just installed MariaDB, and
you haven't set the root password yet, the password will be blank,
so you should just press enter here.

Enter current password for root (enter for none):
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (61)

A: Ich wollte mein Passwort noch nicht eingeben
B: Bei /tmp ist das hier
1 srwxrwxrwx 1 777 wheel 0 Feb 10 00:33 mysql.sock
5 -rw------- 1 777 wheel 6 Feb 10 00:33 mysql.sock.lock

Nun mal zur eigentlichen Frage:
Kann mir mal jemand einen kleinen Tipp geben worauf ich achten soll?
Ich erwarte nicht umbeding eine komplett antwort aber eine kleine hilfestellung wäre wirklich hilfreich

Ich danke für die Zeit und für das interesse
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#2
Hallo und willkommen auf BSDForen.de. :)

Dein "Problem" ist eigentlich ganz einfach, nämlich das hier:
Code:
Damit meine ich startet der sql server automatisch
echo 'mysql_enable="YES"' >> /etc/rc.conf
Damit sagst du dem System, dass es MySQL beim Hochfahren automatisch starten soll. Anders als einige Linux-Distros macht FreeBSD nun im Großen und Ganzen auch nur exakt das, was man gerade von ihm verlangt. Es denkt also nicht mit, im Sinne von "Der Nutzer will MySQL sicher auch nutzen, dann starte ich es gleich mal". Das musst du selbst machen. Also ein:
Code:
service mysql-server start
Anschließend müsste dann auch das 'mysql_secure_installation' funktionieren.
 
Themenstarter #3
also das habe ich ja auch eingegeben aber wenn ich dann
service mysql-server status --->eingebe kommmt dann
mysql is not running.

ich frage mich was ich alles einstellen/verändern muss damit zumindest auch diese meldung nicht mehr kommen würde:
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (61)
 

ralli

BSD Fanboy
#4
ich frage mich was ich alles einstellen/verändern muss damit zumindest auch diese meldung nicht mehr kommen würde:
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (61)
Hallo und willkommen im Forum.:) Ich hab zwar lange nichts mehr mit mysql gemacht, aber die Fehlermeldung ist eine Folge dessen, das die Verbindung zu mysql gescheitert ist, weil mutmaßlich der Server nicht gestartet ist. Irgendwie scheint die Konfiguration noch nicht erfolgreich. Bestimmt kann Dir jemand weiterhelfen, der den Server in Betrieb hat. Brauchst halt ein wenig Geduld, bei dem Wetter gibt es noch anderes .......
 

Rakor

Administrator
Mitarbeiter
#5
Ich hab den Thread mal umbenannt (wenn Du einen anderen Titel willst bitte melden) und verschoben.
 

pit234a

Well-Known Member
#7
ich habe das Gefühl eines DejaVu, was unberechtigt sein mag.
Als purer Endanwender kenne ich mich da gar nicht aus und habe auch keinerlei Ratschläge, glaube aber, dass ich solch ein Thema innerhalb der letzten zwölf Monate schon mal gelesen habe.
Hast du hier gesucht?
Ansonsten entschuldige ich mich für die Ablenkung.
 
Themenstarter #8
Ja kann mir gut vorstellen das einige themen sich wiederholen,
doch mit der Zeit sind es immer andere versionen, andere patches und und und
und dann kommt noch hinzu dass jeder andere ziele hat und irgendwie ist bei jedem einiges anderst

Bei /usr/local/share/mysql sind keine .cfg dateien ist mir noch aufgefallen
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#9
Lass uns das mal schrittweise durchgehen. Es ist wahrscheinlich kein großes Problem. Was ist denn die Ausgabe von:
Code:
service mysql-server start
 
#10
Hi,

schau mal ins Verzeichnis /var/db/mysql, ob dort eine Datei mit der Endung .err rumliegt.
Wenn ja, poste mal die letzten 10 Zeilen davon hier im Forum.

Rob
 
#11
1 srwxrwxrwx 1 777 wheel 0 Feb 10 00:33 mysql.sock
Ah, ein wichtiger Hinweis.

Du hattest wohl schon eine Installation von MySQL oder MariaDB, die nicht korrekt beendet wurde, auf dem System.

Lösche das Socket, dann wirst du warscheinlich MariaDB starten können.
Vorher solltest du dich noch vergewissen, ob eventuell ein MySQL-Prozess läuft:
Code:
ps aux| grep mysqld
Wenn ja, musst du den vorher auch abschießen.

Rob
 
Themenstarter #12
Soo ok dann fangen wir mal an:
Das erste:
service mysql-server start
Starting mysql.

Doch bei
service mysql-server status
mysql is not running.

Hmmm bei /var/db/mysql ist was mit .err, aber da steht mein domain name, bzw der name vom Jail und die letzten zeilen sehen so aus
2018-02-09T23:33:13.365360Z 0 [Note] InnoDB: File '/var/db/mysql/ibtmp1' size is now 128 MB.
2018-02-09T23:33:13.366917Z 0 [Note] InnoDB: 96 redo rollback segment(s) found. 96 redo rollback s$
2018-02-09T23:33:13.367034Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.
2018-02-09T23:33:13.367359Z 0 [Note] InnoDB: Waiting for purge to start
2018-02-09T23:33:13.421655Z 0 [Note] InnoDB: 5.7.21 started; log sequence number 2551578
2018-02-09T23:33:13.421964Z 0 [Note] InnoDB: Loading buffer pool(s) from /var/db/mysql/ib_buffer_p$
2018-02-09T23:33:13.422157Z 0 [Note] Plugin 'FEDERATED' is disabled.
2018-02-09T23:33:13.426641Z 0 [Note] InnoDB: Buffer pool(s) load completed at 180210 0:33:13
2018-02-09T23:33:13.436142Z 0 [Note] Found ca.pem, server-cert.pem and server-key.pem in data dire$
2018-02-09T23:33:13.436171Z 0 [Note] Skipping generation of SSL certificates as certificate files $
2018-02-09T23:33:13.436816Z 0 [Warning] CA certificate ca.pem is self signed.
2018-02-09T23:33:13.436880Z 0 [Note] Skipping generation of RSA key pair as key files are present $
2018-02-09T23:33:13.437020Z 0 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
2018-02-09T23:33:13.437066Z 0 [Note] - '127.0.0.1' resolves to '127.0.0.1';
2018-02-09T23:33:13.437147Z 0 [Note] Server socket created on IP: '127.0.0.1'.
2018-02-09T23:33:13.450630Z 0 [Note] Event Scheduler: Loaded 0 events

Das ist ja februar... Da hatte ich mal mysql installiert

Lösche das Socket? Wo ist den die datei überhaupt?
Bei
ps aux| grep mysql
kommt
root 56534 0.0 0.0 14828 1820 30 S+J 19:51 0:00.00 grep mysql

doch ich habe gemerkt da kann ich alles hinschreiben was ich will, die zeile sieht immer gleich aus


Hmmmm
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#13
Gut, er startet zumindest schon mal:
Code:
service mysql-server start
Starting mysql.
Aber hinterher läuft er nicht, wie uns 'ps' zeigt:
Code:
root  56534  0.0  0.0 14828 1820 30  S+J  19:51   0:00.00 grep mysql
Er beendet sich also sofort wieder. Außerdem schreibt er nichts in seine Log. Das riecht nach einem Rechteproblem. Da du in dem alten MariaDB sicher keine Daten hattest, die du noch brauchst, würde ich es einfach in Tabularasa-Manier löschen:
Code:
rm -rf /var/db/mysql
Anschließend ihn noch mal starten. Idealerweise läuft es denn, aber zumindest sollte etwas in der Log landen.
 
Themenstarter #14
Wahnsinn, was jetzt kam
service mysql-server start
error: Found option without preceding group in config file: /usr/local/etc/my.cnf at line: 1
Fatal error in defaults handling. Program aborted
Installing MariaDB/MySQL system tables in '/var/db/mysql' ...
Segmentation fault (core dumped)

Installation of system tables failed! Examine the logs in
/var/db/mysql for more information.

The problem could be conflicting information in an external
my.cnf files. You can ignore these by doing:

shell> /usr/local/bin/mysql_install_db --defaults-file=~/.my.cnf

You can also try to start the mysqld daemon with:

shell> /usr/local/libexec/mysqld --skip-grant-tables --general-log &

and use the command line tool /usr/local/bin/mysql
to connect to the mysql database and look at the grant tables:

shell> /usr/local/bin/mysql -u root mysql
mysql> show tables;

Try 'mysqld --help' if you have problems with paths. Using
--general-log gives you a log in /var/db/mysql that may be helpful.

The latest information about mysql_install_db is available at
https://mariadb.com/kb/en/installing-system-tables-mysql_install_db
You can find the latest source at https://downloads.mariadb.org and
the maria-discuss email list at https://launchpad.net/~maria-discuss

Please check all of the above before submitting a bug report
at http://mariadb.org/jira

/usr/local/etc/rc.d/mysql-server: WARNING: failed precmd routine for mysql
 
Themenstarter #15
Jetzt habe ich
pkg remove mariadb103-server-10.3.7
pkg install mariadb103-server-10.3.7

gemacht, sollte nun alles wieder auf "grundstellung" sein?

folgendes steht da nun
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking integrity... done (0 conflicting)
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
mariadb103-server: 10.3.7

Number of packages to be installed: 1

The process will require 179 MiB more space.

Proceed with this action? [y/N]: y
[arslan.uugrn.lan] [1/1] Installing mariadb103-server-10.3.7...
===> Creating groups.
Using existing group 'mysql'.
===> Creating users
Using existing user 'mysql'.
[arslan.uugrn.lan] [1/1] Extracting mariadb103-server-10.3.7: 100%
Message from mariadb103-server-10.3.7:

************************************************************************

Remember to run mysql_upgrade (with the optional --datadir=<dbdir> flag)
the first time you start the MySQL server after an upgrade from an
earlier version.

MariaDB respects hier(7) and doesn't check /etc and /etc/mysql for
my.cnf. Please move existing my.cnf files from those paths to
/usr/local/etc and /usr/local/etc/mysql.

This port does NOT include the mytop perl script, this is included in
the MariaDB tarball but the most recent version can be found in the
databases/mytop port
 
#16
Software neu zu installieren ist auf UNIX/Linux in der Regel unnötig.
Startet MariaDB denn nun?

Wenn nicht: wieder in die Datei mit .err am Ende im Verzeichnis /var/db/mysql schauen!
Das ist dein Fehlerlog, nur dies kann dir weiterhelfen.

Rob
 
#19
Existiert denn das Verzeichnis /var/db/mysql mittlerweile?
Welche Dateien sind dort vorhanden?
Gibt es die Datei /usr/local/etc/my.cnf bzw. /usr/local/etc/mysql/my.cnf?
Wenn ja: diese Datei(en) bitte umbenennen, z.B. in my.cnf.bak und dann mal MariaDB starten.

Ein genereller Hinweis: wenn du hier Hilfe haben willst, musst du jede Frage beantworten.

Rob
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#20
Code:
error: Found option without preceding group in config file: /usr/local/etc/my.cnf at line: 1
Fatal error in defaults handling. Program aborted
Installing MariaDB/MySQL system tables in '/var/db/mysql' ...
Segmentation fault (core dumped)
Das sieht sehr fischig aus. Probiere aber erstmal @KobRheTillas Vorschlag.
 
Themenstarter #21
Ohh hab ich eine Frage übersehen? Sorry
Gibt es die Datei /usr/local/etc/my.cnf bzw. /usr/local/etc/mysql/my.cnf? -> Nein da ist leider nichts
und auch in /var/db/mysql ist nichts
Ohjee warum klappt das denn nicht? Ich hab doch "nur" das Paket installiert und das wars ja auch schon
 
#22
Themenstarter #25
uname -m sagt amd64


wenn ich mysqld schreibe kennt es den befehl nicht...

So langsam weis ich leider nicht mehr was ich machen soll..
Nicht mal "sauber" deinstallieren habe ich hinbekommen.
Den jail zurücksetzen wäre wirklich zu sehr windowsmäßig, das will ich nicht.