Probleme sudoers file, visudo, SSD-Anmeldebildschirm

Alberich

Well-Known Member
Hallo,

Bei der Grundinstallation von FreeBSD 13.0 bin ich auf ein Problem bzgl. der Bearbeitung der sudoers file im vi-Editor gestoßen.

Ich konnte zwar die Raute per doppelklick auf x entfernen, jedoch wußte und konnte ich die Datei nicht mit der Esc und der Shift Taste
speichern bzw. verlassen, noch konnte ich am ende :wq setzen, weil die Tastatur nicht funktionierte.

Ich habe dann den PC durch drücken der Ein- und Aus-Taste am PC neugestartet, gelang aber nach dem hochfahren des PC wieder auf
der Welcome to FreeBSD Seite wo ich mich mit meinen Benutzerdaten einloggen kann, ich installierte danach mit pkg install kde5, xorg und sddm, und
startete den PC erneut, loggte mich ein, kam aber immer wieder auf die FreeBSD Welcome Site.

So wie im screen zu sehen, habe ich es gemacht, danach wußte ich nicht mehr weiter, weil Esc, Shift und :wq nicht ging.

Was habe ich falsch gemacht ?
 

Anhänge

  • Screenshot_20211224_161100.png
    Screenshot_20211224_161100.png
    1.022,6 KB · Aufrufe: 71

pit234a

Well-Known Member
Zunächst mal kommt afaik auch ein neues FreeBSD noch immer ohne sudo, so dass du das installiert haben müsstest. Dann gibt es dazu visudo, um das sudoers file zu editieren. visudo hat dann auch eine eigene man.

Die Installation irgendwelcher Pakete aktiviert nichts.
Dienste, die du automatisch starten möchtest, musst du in einer der passenden Dateien eintragen, etwa in der rc.conf. Ob sddm so gestartet wird, weiß ich aber nicht. Außerdem gab es mit dem sddm auch einige Probleme mit lang-Einstellungen, da kannst du hier fündig werden.

Hast du ein passendes Tastatur-Layout eingestellt?
Vielleicht geht die Steuerung von VI ja deshalb nicht, weil du versehentlich eine falsche (Englische) Tastatur benutzt?
 

Alberich

Well-Known Member
Ich habe mich als root mit meinem Passwort angemeldet, und dann mit pkg install sudo installiert, was auch geklappt hat.

Das es visudo gibt um das sudoers file zu editieren weiß ich, habe ich auch so gemacht, nur kam ich irgendwie nicht mehr weiter.

Das Tastatur-Layout war in deutsch eingestellt.

Was heist oder ist "man" ?
 

bluescreen

verstört
Hallo !

Wie wärs wenn du den "default" Editor von vi auf ee umstellst !
Der ee ist ähnlich nano .

In der .cshrc von root oder auch dem Benutzer zu ändern !

Also : ee /root/.cshrc

Dann nutzt auch der Befehl visudo den ee !

Gruss
 

Alberich

Well-Known Member
Ich habe den "env EDITOR=nano" verwendet, und das hat sehr gut geklappt, mit nano komme ich am besten klar.

Ich habe FreeBSD KDE installiert und konfiguriert, ich war bis ca. 04:00 Uhr mit der Fehlersuche und Konfiguration beschäftigt.

Trotzdem kam ich nicht auf den SDDM-Anmeldebildschirm, ich meldete mich mit meinem Benutzernamen und dem Passwort an,
aber der Bildschirm blieb schwarz.

Ich versuchte es dann mit startx, und da stand irgendetwas mit xinit-server error.

Kann es sein, das der Fehler mit der fehlenden oder falschen Xorg installation und Konfiguration liegt, und ich deshalb nicht auf
den SDDM-Anmeldebildschirm komme, oder habe ich komplett falsch installiert ?

Wäre diese FreeBSD Reihenfolge am besten ?

Sollte man Pakete etc. lieber als Paket oder Ports installieren?
Im Handbuch sind die Installationen aus den Ports sehr gut beschrieben.

 

Andy_m4

Well-Known Member
Dein Nutzer muss in der Gruppe video sein, damit Zugriff auf die Grafikhardware/-beschleunigung möglich ist.
By the way: Über welche Grafik reden wir hier eigentlich? Intel, AMD oder nvidia?

Ich versuchte es dann mit startx, und da stand irgendetwas mit xinit-server error.
Die konkrete Fehlermeldung zu nennen wäre schon nett. Sonst wird es mit Hilfe schwierig.
ggf. auch die Logfiles des XServers (/var/log/X.org.0.log) und das System-Log (/var/log/messages)

Auf sddm zunächst zu verzichten ist ne gute Idee. Wenn es mit startx läuft, dann gucken wir weiter. Allerdings brauchst Du dann auch eine für KDE passende ~/.xinitrc in Deinem Homeverzeichnis mit folgendem Inhalt:
exec ck-launch-session startplasma-x11

Sollte man Pakete etc. lieber als Paket oder Ports installieren?
Im Prinzip kannst Du Pakete nehmen. Sie sollten allerdings aus dem latest-Repository kommen (womit die Pakete dann im Prinzip auf den Versionsstand der Ports sind). Per default wird das quarterly-Repository genommen.
Du kannst den default relativ einfach überschreiben, in dem Du das Verzeichnis /usr/local/etc/pkg/repos anlegst:
mkdir -p/usr/local/etc/pkg/repos
und dort eine Datei FreeBSD.conf mit folgendem Inhalt reinpackst:
Code:
FreeBSD: {
   url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest",
   mirror_type: "srv",
   signature_type: "fingerprints",
   fingerprints: "/usr/share/keys/pkg",
   enabled: yes
}
(ist im Prinzip eine entsprechend angepasste /etc/pkg/FreeBSD.conf)

Für ein komplettes KDE reicht dann im Prinzip ein:
pkg install kde5
den Rest zieht er sich via Abhängigkeiten nach (inkl. Xorg).

KDE braucht dbus. In der /etc/rc.conf sollte also irgendwo diese Zeile stehen:
dbus_enable="YES"

Außerdem braucht KDE procfs. In der /etc/fstab sollte also irgendwo diese Zeile stehen:
proc /proc procfs rw 0 0

Alle Klarheiten beseitigt? :-)
 

Alberich

Well-Known Member
Ich war in der Gruppe wheel und video, und ich habe eine Intel HD Graphics 530.

sddm habe ich immer mitinstalliert gehabt, finde den besser als xdm, kde5 hatte ich mit pkg installiert gehabt, dbus_enable="YES" war
ebenfalls korrekt, auch procfs hatte ich in der /etc/fstab drinnstehen.

Ich werde FreeBSD nochmals neuinstallieren, und mich an der FreeBSD Installationsanleitung aus dem FreeBSD Handbuch halten,
anstatt an diversen Installationsanleitung aus dem Internet bzw.youtube.
 

Andy_m4

Well-Known Member
sddm habe ich immer mitinstalliert gehabt,
Das kannst du ja auch machen. Es geht ja lediglich darum Xorg/KDE Plasma überhaupt erst mal zum laufen zu kriegen.
Und da ist eben die Fehlermeldung aber wichtig.

und ich habe eine Intel HD Graphics 530.
Dann brauchst Du den i915kms Kernel-Treiber.
Den installierst Du bei FreeBSD 13 mit:
pkg install drm-fbsd13-kmod

Am besten lädt man den über die /etc/rc.conf und der Variable kld_list. Mit dem sysrc-Tool kannst Du das leicht hinzufügen:
sysrc kld_list+="i915kms"
Danach Reboot um die Änderung wirksam werden zu lassen.
Mit kldload kannst du den Treiber auch "zur Laufzeit" laden. Mit kldstat guckst Du nach, ob er auch geladen ist.
 

Alberich

Well-Known Member
den i915kms Kernel-Treiber hatte ich nicht installiert gehabt.

Welcher Treiber ist für das laden des sddm-Anmeldefenster und der KDE-Oberfläche verantwortlich ?
Ist doch xorg oder ?
 
Zuletzt bearbeitet:

pit234a

Well-Known Member
Ich habe den "env EDITOR=nano"
ohne nun einen auf reißerisch machen zu wollen oder wunders was für Wissen vor zu gaukeln: nano gehört nicht zu FreeBSD.
So war es jedenfalls immer.
nano muss also erst installiert werden und um etwas installieren zu können, muss schon ein "gewisses Maß" an FreeBSD vorhanden sein und funktionieren. Allermeist ist das auch so und es spricht nichts dagegen, seinen Lieblingseditor und seine Lieblingsshell nach zu installieren und dann nur diese zu benutzen. Es gibt aber immer wieder die 1% Chance, dass nicht das komplette System verfügbar ist (/usr/local zB fehlt) und man dann ohne diese zusätzliche SW da steht.
Der ee oder vi sind immer da, die (t)csh ebenfalls und es empfiehlt sich deshalb durchaus, gelegentlich damit zu üben und was den nano angeht, sehe ich persönlich gegenüber dem ee absolut keine Vorteile, außer man kennt den nano sehr gut und möchte nicht etwas neues lernen. Mir geht es eher so, dass ich mich in GNU/Linux-Systemen ärgere, dass die nicht so einen tollen Einfachen Editor haben.

Nun lehne ich mich mal wieder weit aus dem Fenster und das betrifft deine Idee, nochmal neu zu installieren und dem Handbuch lieber als einem Youtube-Video zu folgen. Der vi ist der Standard-Editor und in gewissem Maße gilt das auch heute noch. Deshalb wird er bei FreeBSD Default genutzt. Nun frage ich mal dezent, was das wohl für Leute sind und was man von deren Empfehlungen dann halten soll, wenn die als einfache Alternative den nano vorschlagen und erst mal installieren, ohne zu realisieren, dass es den ee bereits gibt und gar kein nano gebraucht wird?
Ich zumindest denke mir, dass diese Leute sich gar nicht mit FreeBSD befasst oder sich zumindest nicht wirklich darauf eingelassen haben.
Aber vielleicht liege ich da falsch und ich möchte niemandem zu nahe treten und Dinge ohne ausreichende Belege behaupten. Nur ein wenig skeptisch werde ich da schon und ich denke, dass der nano auch nicht im Handbuch vorkommt.
 

Alberich

Well-Known Member
Dein Nutzer muss in der Gruppe video sein, damit Zugriff auf die Grafikhardware/-beschleunigung möglich ist.
By the way: Über welche Grafik reden wir hier eigentlich? Intel, AMD oder nvidia?


Die konkrete Fehlermeldung zu nennen wäre schon nett. Sonst wird es mit Hilfe schwierig.
ggf. auch die Logfiles des XServers (/var/log/X.org.0.log) und das System-Log (/var/log/messages)

Auf sddm zunächst zu verzichten ist ne gute Idee. Wenn es mit startx läuft, dann gucken wir weiter. Allerdings brauchst Du dann auch eine für KDE passende ~/.xinitrc in Deinem Homeverzeichnis mit folgendem Inhalt:
exec ck-launch-session startplasma-x11


Im Prinzip kannst Du Pakete nehmen. Sie sollten allerdings aus dem latest-Repository kommen (womit die Pakete dann im Prinzip auf den Versionsstand der Ports sind). Per default wird das quarterly-Repository genommen.
Du kannst den default relativ einfach überschreiben, in dem Du das Verzeichnis /usr/local/etc/pkg/repos anlegst:
mkdir -p/usr/local/etc/pkg/repos
und dort eine Datei FreeBSD.conf mit folgendem Inhalt reinpackst:
Code:
FreeBSD: {
   url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest",
   mirror_type: "srv",
   signature_type: "fingerprints",
   fingerprints: "/usr/share/keys/pkg",
   enabled: yes
}
(ist im Prinzip eine entsprechend angepasste /etc/pkg/FreeBSD.conf)

Für ein komplettes KDE reicht dann im Prinzip ein:
pkg install kde5
den Rest zieht er sich via Abhängigkeiten nach (inkl. Xorg).

KDE braucht dbus. In der /etc/rc.conf sollte also irgendwo diese Zeile stehen:
dbus_enable="YES"

Außerdem braucht KDE procfs. In der /etc/fstab sollte also irgendwo diese Zeile stehen:
proc /proc procfs rw 0 0

Alle Klarheiten beseitigt? :-)
Wie nenne ich die Fehlermeldung bzw.die Logfiles, wenn ich nicht auf der Benutzeroberfläche bin, da ich mich ja
nicht anmelden kann ?

und der test mit "service sddm onestart" ergab, "sddm already running ? (pid=1173)
 

Alberich

Well-Known Member
Ich habe FreeBSD bis heute vier mal installiert und mich an der Installationsanleitung vom Handbuch
gehalten, ich kam nicht zurecht, alles hat nicht geholfen.

Und mit dem Editor ee komme ich auch nicht zurecht, weiß nicht wie ich das file im ee speichern und verlassen kann,
deshalb verwende ich auch lieber den nano, da komme ich am besten zurecht.

Es hätte nicht so sein sollen, aber die Installation ist mir zu komplex, da bleibe ich doch lieber bei Arch Linux,
die Installation ist am einfachsten.

Oder ich habe /proc procfs rw 0 0 in der /etc/fstab falsch in der Datei /etc/fstab eingefügt.
 
Zuletzt bearbeitet:

bluescreen

verstört
Moin !

Also ich bin jetzt ein wenig überrascht !! Wenn du eine Arch-Installation hinbekommst
solltest du auch eine FreeBSD - Installation hinbekommen !
Oder meinst du Manjaro oder ähnliches ?

Kurz zum "ee" .... wenn fertig , einfach Escape-Taste drücken !!

FreeBSD-Installatios in kurzen Schritten :

1. FreeBSD installieren -> Neustart ! ( User den Gruppen wheel & video zuordnen )
2. Einloggen als root !
3. #pkg update -> enter
4. #pkg install xorg drm-fbsd13-kmod drm-kmod kde5 -> enter
5. In die fstab eintragen : proc /proc procfs rw 0 0
6. Die "/etc/rc.conf" um folgendes ergänzen :

dbus_enable="YES"
kld_list="i915kms"

7. Als root ausloggen
8. Als user einloggen
9. Eine /home/user/.xinitrc mit folgenden Inhalt erstellen !

#
setxkbmap de
exec ck-launch-session startplasma-x11

10. Fertig & Neustart

11. Als user wieder einloggen
12. Mit :

#startx

den Desktop starten !


Theoretisch in 15min. eledigt !! Alles andere wie "sddm" und anderen Feinschliff
würde ich später ausprobieren !

Gruss
 

Alberich

Well-Known Member
OK, werde ich so machen, und alles neuinstallieren, aber wie ordne ich den User den Gruppen wheel und video zu ?
möglich, das ich hier einen Fehler gemacht habe.

In der Installationsanleitung des Benutzerhandbuch steht unter Kapitel 5. Das X-Window-System
5.1.4. Schnellstartanleitung
  1. Fügen Sie die Benutzer, die Xorg verwenden, zur Gruppe video oder wheel hinzu, um die 3D-Beschleunigung zu aktivieren. Um den Benutzer jru in eine der verfügbaren Gruppen hinzuzufügen:
    # pw groupmod video -m jru || pw groupmod wheel -m jru

    ist der Name "jru" so richtig oder muß ich anstelle von "jru" meinen Namen eintragen ?
Das gleiche auch unter 5.4.2. Benutzergruppen für Grafikbeschleunigung

# pw groupmod video -m slurms || pw groupmod wheel -m slurms

Muß ich auch hier, anstatt "slurms" meinen Namen eintragen ?
 

bluescreen

verstört
Hallo !

Das kannst du schon während des Installations - Vorganges erledigen !

Bei der Abfrage zum "Benutzer zu Gruppe hinzufügen" wird nach den Gruppen
gefragt !
Bei der ersten Frage nach der Gruppe, gibst du wheel an , die zweite Frage,
weitere Gruppen ? ... gibst du video an .

Zu deiner Frage : jru ist nur ein Beispiel ! Bei mir steht "user" , auch ein Beispiel !

Gemeint ist immer dein Username !

:ugly:
 

Alberich

Well-Known Member
Nur noch eine Frage, welches Dateisystem ZFS oder UFS ?

Mein RAM hat 8GB und meine SSD 120GB.

Den User habe ich nie in die Gruppe video hinzugefügt, liegt da eventuell das Problem mit dem Anmeldebildschirm ?
 

bluescreen

verstört
Hallo !

Für Anfänger würde ich UFS nehmen !

Das sddm-Problem könnte an der fehlenden
Gruppe "video" für deinen user liegen !

Gruss
 

Alberich

Well-Known Member
Es ist vollbracht, FreeBSD mit KDE5 ist installiert, ich beginne jetzt mit der Installation eines Browsers sowie
mit der Installation von Libreoffice Fresh sowie sonstige Programme, mit anschließender konfiguration.

Allerdings habe ich sddm installiert, weil ich nicht wußte, wie ich eine /home/user/.xinitrc erstellen muß.

Danke allen für die sehr freundliche Unterstützung, werde mich jetzt erstmal mit FreeBSD befassen.
 

Alberich

Well-Known Member
Ein kleines Poblem habe ich noch bzgl. des Chromium Browsers, ich kann keine Erweiterungen installieren,
es erscheint immer die Fehlermeldung;

Ein Fehler ist aufgetreten
Paket konnte nicht installiert werden:
"FAILED_TO_COPY_EXTENSION_FILE_TO_TEMP_DI RECTORY".

Und jetzt, ich weiß nicht mehr weiter
 
Oben