qjail kann keine Jails mehr anlegen

pbtraveller

Well-Known Member
Moin,

nutze seit einiger Zeit qjail zum Administrieren der Jails. bekomme jetzt beim Anlegen von Jails immer folgende Fehlermeldung:


error: conflicting output format options.


usage: diff [-aBbdilpTtw] [-c | -e | -f | -n | -q | -u] [--ignore-case]


[--no-ignore-case] [--normal] [--strip-trailing-cr] [--tabsize]


[-I pattern] [-L label] file1 file2


diff [-aBbdilpTtw] [-I pattern] [-L label] [--ignore-case]


[--no-ignore-case] [--normal] [--strip-trailing-cr] [--tabsize]


-C number file1 file2


diff [-aBbdiltw] [-I pattern] [--ignore-case] [--no-ignore-case]


[--normal] [--strip-trailing-cr] [--tabsize] -D string file1 file2


diff [-aBbdilpTtw] [-I pattern] [-L label] [--ignore-case]


[--no-ignore-case] [--normal] [--tabsize] [--strip-trailing-cr]


-U number file1 file2


diff [-aBbdilNPprsTtw] [-c | -e | -f | -n | -q | -u] [--ignore-case]


[--no-ignore-case] [--normal] [--tabsize] [-I pattern] [-L label]


[-S name] [-X file] [-x pattern] dir1 dir2


diff [-aBbditwW] [--expand-tabs] [--ignore-all-blanks]


[--ignore-blank-lines] [--ignore-case] [--minimal]


[--no-ignore-file-name-case] [--strip-trailing-cr]


[--suppress-common-lines] [--tabsize] [--text] [--width]


-y | --side-by-side file1 file2


Error invalid directories in flavor default.

Habe schon /usr/jails/flavors/default gelöscht und qjail neu installiert. Bekomme aber immer noch die Fehlermeldung. Wenn ich es richtig sehe, dann liegt es auch nicht an meinem syntaxfehler meinerseits bei Anlegen der Jail. Die Dateien in /usr/jails/flavors/default/... sehe auch erst mal nicht verdächtig aus...

Kann mir jemand helfen?

 

bsd4me

Well-Known Member
ich kenne qjail nicht, aber könnte es sein, das mehrere diff Kommandos bei Dir im PATH liegen? Z.B. durch eine paket installation?

Bei mir sieht das so aus :)

# where diff
/usr/bin/diff

VG, Norbert
 

pbtraveller

Well-Known Member
Hi Rob,

hatte zwar das letzte Paket installiert und auch den Stand gecheckt (dort ist die letzte Version 5.4), nicht aber in den Ports. Hab jetzt Version 5.5 aus den Ports genommen. Jetzt geht es wieder! Auf die Idee hätte ich auch selbst kommen können. Mea culpa und vielen Dank!

VG pbtraveller
 
Oben