• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

qpdfview - Speicherschutzverletzung

Themenstarter #1
Nach einem "pkg upgrade" (am 17.11.2020 mit FreeBSD 12.1), stürzt qpdfview beim öffnen von pdf-Dateien, ab, mit folgender Meldung:
Code:
:~% qpdfview
** (<unknown>:5723): WARNING **: 11:29:30.864: Invalid borders specified for theme pixmap:
/usr/local/share/themes/Adapta/gtk-2.0/Entry/ltr-entry-insensitive.png,
borders don't fit within the image
(<unknown>:5723): GVFS-RemoteVolumeMonitor-WARNING **: 11:29:47.150: remote volume monitor with dbus name org.gtk.vfs.HalVolumeMonitor is not supported
(<unknown>:5723): GVFS-RemoteVolumeMonitor-WARNING **: 11:29:47.163: remote volume monitor with dbus name org.gtk.vfs.GPhoto2VolumeMonitor is not supported
Speicherschutzverletzung
BTW: qpdfview ist am 17.11.2020 nicht updatet worden. Es waren nur der Firefox und Libreoffice die updatet worden sind.
 

Andy_m4

Well-Known Member
#2
Kann ich hier nicht nachvollziehen. Ist allerdings auch ein FreeBSD 12.2. Weiß nicht, obs damit zusammenhängt.
Aber ich bekomme nicht mal die von Dir beschriebenen Warnings.

Alle Packages aus dem latest-Repository.
 
Themenstarter #3
Kann ich hier nicht nachvollziehen.
Ja, ... ich kann es auf meinem 2. Laptop (auch FreeBSD 12.1 und auch quaterly-Repository), auch nicht nachvollziehen.

Und es blieb ja nicht beim pdfview, weitere Software (wie Firefox, LibreOffice, Chromium), die alle ein built-in-pdf konfiguriert/aktiviert haben, stürzen auch ab (mit segfault). Midori funktioniert, da ja kein built-in-pdf dort konfiguriert ist bzw. nicht vorhanden ist.

Ich habe im NomadBSD-Forum (vom 10.09.2020), bzgl. Firefox etwas ähnliches gefunden:
Code:
(firefox:38720): GVFS-RemoteVolumeMonitor-WARNING **: 18:13:02.440: remote volume monitor with dbus name org.gtk.vfs.HalVolumeMonitor is not supported
Quelle: https://forum.nomadbsd.org/t/sound-gremlins/379