Raspberry Pi 4 Model B/4GB / FreeBSD 13.0-CURRENT #0 7578a4862f0-c255032 / Samba Speed

mrx86

Member
Hatte Probleme mit dem RPI4 dass mein SMB Speed nur ca 50 MB/s war
via LAN auf eine USB3 SSD.


nach dem ändern in: /etc/rc.conf auf:
powerd_enable="YES"


Hatte ich ca 90 MB/s


Dachte das währe nützlich für den einen oder andern Benutzer hier.

LG
MRX86
 

mrx86

Member
Nachtrag:

Was mir noch fehlt ist die Software "htop"


Interessant:
Das teil ist unter pkg search nicht da...
Muss es mit postsnap versuchen oder von Hand....
 

mrx86

Member
Das wäre in der Tat interessant! Bisher waren all meine Versuche mit FreeBSD auf einem 8GB-Raspi erfolglos.
Open- und NetBSD laufen dafür einwandfrei! :)
Das kann ich verstehen.
ältere FreeBSD Images gingen nicht so plug&play mässig.
(Kein Bild usw..) vermutlich bezüglich dem u-boot...


NetBSD/OpenBSD habe ich auf dem RPI3B. ist OK.

NetBSD/OpenBSD habe ich auf dem RP4 nicht getestet.

LG
MrX86
 

mrx86

Member
Update:

Anstatt:
powerd_enable="YES" by /etc/rc.conf zu setzen geht auch:

in der shell:
sysctl -a dev.cpu.0.freq=1500


Default ist FreeBSD auf dem RPI4 by 600 MHZ und wir brauchen 1500 MHZ für mehr als 50 MB/s
 

Kamikaze

Warrior of Sunlight
Update:

Anstatt:
powerd_enable="YES" by /etc/rc.conf zu setzen geht auch:

in der shell:
sysctl -a dev.cpu.0.freq=1500


Default ist FreeBSD auf dem RPI4 by 600 MHZ und wir brauchen 1500 MHZ für mehr als 50 MB/s
Das ergibt schon mehr Sinn. Ich frage mich aber warum der RPI4 gedrosselt hoch kommt.
 

mrx86

Member
Das ergibt keinerlei Sinn. Ich kenne den Code von powerd ziemlich genau.
Info:
Ja es ist aber da so. Der RPI mit der genannten Rev. bootet only mit 600 MHZ
Durch den Eintrag in der rc.conf springt er auf 1500 MHZ
Warum er das macht weis ich nicht.
Da aber mit sysctl -a dev.cpu.0.freq=1500 das auch geht habe ich den EIntrag in der rc.conf wieder
gelöscht und es geht wie erklährt

Warum er das macht ist mir unbekannt
Ich denke daher ist es wichtig das man das weis.
 

mrx86

Member
Installierte Samba Version ist:
samba411-4.11.15

erreiche immer uber 80 MB/s via LAN auf eine USB3 Samsung T5 SSD 2 TB Externe SSD

UFS Formatiert und gemountet
 

morromett

Well-Known Member
Durch den Eintrag in der rc.conf springt er auf 1500 MHZ
Warum er das macht weis ich nicht.
Da aber mit sysctl -a dev.cpu.0.freq=1500 das auch geht habe ich den EIntrag in der rc.conf wieder
gelöscht und es geht wie erklährt
Lt. wiki wird der Eintrag mit sysctl nicht benötigt, denn der Eintrag in der rc.conf bewirkt:
to enable automatic scaling to it`s default(non-overclocked) @1500MHZ
Quelle: https://wiki.freebsd.org/arm/Raspberry Pi
 

overflow

OpenBSD Enthusiast
Das kommt wie gerufen... Teste ich sofort aus...

Ich habe nen Raspi Proxmox Cluster mit nvme statt normalem SSD. Kann das auch nur empfehlen:

 

mrx86

Member
Was noch auffällig ist bei:

CURRENT #0 7578a4862f0-c255032​



Motd Strucktur ist nicht mehr statisch unter /etc/motd
pkg search: der mc und usbmuxd ist weg

CPU Temp: geht hoch bis 80C mit passiver Kühler aber er drosselt nicht
Daher IO auch unter Hochlast über 24h...
 
Oben