• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Rauschen am Audio Ausgang

bsd4me

Well-Known Member
Themenstarter #1
Hallo,

ich habe ein MSI 350M-PRO VDH Mainbaord, und FreeBSD 12.1 installert. Seit Monaten konnte ich meine kleinen Boxen immer nutzen um einen angemessenen Sound zu erzeugen. Nun rauschen sie seit einiger Zeit - ich hatte mal mit cuse und webcamd experementiert, da ganze aber wieder aus dem Boot herausgenommen. Ich meine, dass nicht allzulang danach das Rauschen anfing. Keine Ahnung, ob man das Device zurücksetzen kann und wie... hier ein paar Ausgaben:

> cat /dev/sndstat
Installed devices:
pcm0: <NVIDIA (0x0081) (HDMI/DP 8ch)> (play)
pcm1: <NVIDIA (0x0081) (HDMI/DP 8ch)> (play)
pcm2: <Realtek ALC892 (Rear Analog)> (play/rec) default
pcm3: <Realtek ALC892 (Front Analog)> (play/rec)
No devices installed from userspace.

> mixer
Mixer vol is currently set to 100:100
Mixer pcm is currently set to 100:100
Mixer speaker is currently set to 74:74
Mixer line is currently set to 1:1
Mixer mic is currently set to 67:67
Mixer mix is currently set to 74:74
Mixer rec is currently set to 35:35
Mixer igain is currently set to 4:4
Mixer ogain is currently set to 100:100
Recording source: mic

> pciconf -vl
...
hdac0@pci0:31:0:1: class=0x040300 card=0x8c981462 chip=0x0fb810de rev=0xa1 hdr=0x00
vendor = 'NVIDIA Corporation'
device = 'GP108 High Definition Audio Controller'
class = multimedia
subclass = HDA
hdac1@pci0:33:0:3: class=0x040300 card=0xfa381462 chip=0x14571022 rev=0x00 hdr=0x00
vendor = 'Advanced Micro Devices, Inc. [AMD]'
device = 'Family 17h (Models 00h-0fh) HD Audio Controller'
class = multimedia
subclass = HDA
...

wäre toll, wenn jemand eine Idee hätte :) :)

Viele Grüße, Norbert
 

Kamikaze

Warrior of Sunlight
#5
Nur so zur Erklärung, natürlich gibt es übersprechen von Leitungen, besonders bei langen. Bei digitalen Signalen ist das nicht so schlimm aber der Mikrofoneingang ist Analog, wenn der zur Front geführt wird fängt die Leitung Störungen von den ganzen Bussen ein. USB1/1.1/2 ist da besonders notorisch, i²C könnte auch eine Quelle sein andere Busse sind als Störquelle in der Regel zu hochfrequent zumindest theoretisch können die aber auch niederfrequente Störungen verursachen wenn es in der Kommunikation zu Mustern kommt, z.B. durch Polling, was oft im hörbaren unteren kHz Bereich passiert.

Dazu kommt, dass hinter der Leitung noch ein Vorverstärker kommt der dann all die Störungen mitverstärkt. Besser aber teurer wäre es wenn die Frontblende einen Vorverstärker hätte, so dass das Signal vor dem Einstreuen der Störungen verstärkt wird. Das heißt aber man braucht 2 Vorverstärker, für vorne und hinten.

Bessere Audiolösungen sind komplett extern in einem eigenen Gehäuse und umgehen die Problematik damit ganz.