• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

read-only file system

Themenstarter #1
hi erst mal,
ich habe bei der installation von openbsd folgendes problem. die installation verläuft einwandfrei aber wenn ich danach rebooten will, bekomme ich immer die meldung dass meine platte ein read-only file system sein soll und deswegen funktioniert nix. find ich ziemlich komisch dass ich installieren kann und danach soll kein schreibzugriff mehr möglich sein? deswegen wird der ootvorgang natürlich nicht mal abgeschlossen. ich hab auch schon neuinstallation aber passiert immer das gleiche. wer kann mir helfen?
 

napolion

Well-Known Member
#2
Hallo,
Sieht ganz danach aus als
ob du im singleuser Modus
startest.
Gib mal folgendes ein:
CODE]mount -aw[/CODE]
Damit werden erzwungenermaßen
alle Dateisysteme der fstab
(ausser fs die mit "noauto" od. "-t"
gekennzeichnet sind)
beschreibbar eingehangen.

Die Möglichkeiten der Ursache die mir so einfallen:
...das in der Datei loader.conf die
Variable "single_user="YES" gesetzt ist.
...init entdeckt kein sauberes
Dateisystem.


Wichtig:...ist bei freebsd so wie oben beschrieben.Habe kein openBsd,verwende daher meine Aussagen
mit vorbehalt und schaue welche Sachen auf obsd zutreffen,vielleicht bootet obsd Standartmässig im singleuser-modus,keine Ahnung.

MfG nap
______________________________________
Man kann keinen Eierkuchen backen, ohne ein paar Eier zu zerschlagen
 
#3
Auch Hi,

der von Dir beschriebene Fehler tritt immer dann auf wenn man am Ende der Installation reboot und nicht halt eingibt.

Gebe am Ende halt ein und mache dann einen Reset.

Schon funz0rt die Sache :)
 
Themenstarter #4
erst mal danke für die antworten aber
1. eingeben kann ich nix weil wie schon gesagt der bootvorgang bricht irgendwann ab und ich bekomm keine shell
2. ich bin mir sicher dass ich halt eingegeben hab
 
#5
Moin,

deine Fehlerbeschreibung ist zu duerftig um genauere Aussagen zu treffen.
Hast du deine Platte partitioniert ?
Ein Fehler koennte sein das /bsd nicht innerhalb der ersten 8GB liegt.
Was sagt die Kiste zuletzt wenn se hängenbleibt?

Du kannst (wie napolion schon sagte) am Bootprompt "bsd -s" eingeben (SingleUserMode) und dann den ganzen Kram mit "mount -aw /" einhaengen um zu gucken ob die Sache ueberhaupt funzt.

Ein weiterer Fehler koennte sein das dein Pladde oder Partition kein "active flag" hat.
Dann musst du von Diskette booten und dich durch fdisk wurschteln, steht auf:

http://www.openbsd.org/faq/faq4.html#InstProb