rspamd: Müsste sich Verschieben einer Spam-Mail in JUNK-Ordner Roundcube/Dovecot in rspamd.log zeigen?

testit

Well-Known Member
Einen schönen Adventsonntag!

Sicher nutzt von Euch ja der Eine oder Andere auch die Kombi postfix+Dovecot/Pigeonhole-Roundcube-Spamrd.

Wenn ich das richtig verstehe, müsste normalerweise - bei korrekt eingerichtetem o. a. System - das Verschieben einer SPAM-Mail aus der INBOX in den JUNK-Ordner in Roundcube "rspamc" involvieren, damit rspamd dazulernt.

Ich habe das eben einmal getestet, aber bei mir tut sich bei o. a. Verschiebevorgang nichts im rspamd.log.

Könnte freundlicherweise von Euch jemand, der ebenfalls diese Kombi aufgesetzt hat, nachschauen, ob bei ihm dann in rspamd.log das Füttern mit einer Spam-Message angezeigt wird, wenn man in Roundcube die Mail in den JUNK-Ordner schiebt?

Kann es sein, dass dies nur mit IMAP funktioniert, aber nicht bei Nutzung von POP3?


Herzlichen Dank und viele Grüße
testit
 

testit

Well-Known Member
Hallo,

danke Dir für diese Info!

Ich hatte heute schon testweise einen weiteren Account mit gleichem Usernamen, aber mit IMAP Protokoll angelegt.

Und obwohl man auf dem Server sieht, dass dort eingehende Mails in entsprechenden IMAP-Ordnern vorliegen und Dovecot auch an Port 993 lauscht, rührt sich bei mir in Thunderbird beim IMAP-Konto NULL. Das Gleiche gilt, wenn ich testweise ein IMAP-Konto mit Outlook anlege.

Kann es sein, dass irgendwo versehentlich von mir eingestellt wurde, dass der betreffende Useraccount von Dovecot nur mit POP3 genutzt werden darf?

dovecot -n zeigt u. a. aber an, dass das IMAP-Protokoll aktiviert ist:
protocols = imap pop3 lmtp sieve

namespace inbox:
namespace inbox {
inbox = yes
location =
mailbox Archive {
auto = subscribe
special_use = \Archive
}
mailbox Drafts {
auto = subscribe
special_use = \Drafts
}
mailbox Junk {
auto = subscribe
special_use = \Junk
}
mailbox Sent {
auto = subscribe
special_use = \Sent
}
mailbox "Sent Messages" {
special_use = \Sent
}
mailbox Trash {
auto = subscribe
special_use = \Trash
}
prefix =
separator = /
type = private
}

Viele Grüße
testit
 

midnight

OpenBSD & FreeBSD
Ich habe meine dovecot, rspamd und imap_sieve configs so ziemlich 1 zu 1 von hier uebernommen und nur minimal an meine Beduerfnisse angepasst und erweitert:


Ansonsten wird es hier auch ganz gut unter Debian beschrieben:


Evtl. hilft Dir das ja etwas weiter.
 

testit

Well-Known Member
Hallo,

den 1. Link kannte ich nicht, den 2. dagegen schon!

Im Grunde läuft ja serverseitig alles rund, mit POP3 ohnehin!

Dass jetzt Clientseitig die IMAP-Kombination nicht funktioniert, kann/sollte hoffentlich einen trivialen Grund haben. Die betreffenden Firewallports 993 und 443 habe ich übrigens bewusst in der rc.conf geöffnet.

Viele Grüße
testit
 

testit

Well-Known Member
Wie ich dann irgendwann herausgefunden habe, ist das Anlegen des eingangs genannten IMAP-Kontos in Android auf meinem Smartphone problemlos möglich, während unter Windows 10 Prof. sowohl bei Thunderbird als auch bei Outlook die Versuche fehlschlagen.

Viele Grüße
testit
 
Oben