• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Samba 4 config - Umlaute/Sonderzeichen in Dateinamen

Themenstarter #1
Hallo zusammen,

habe bei mir einen samba in der Version 4.10.8, auf freeBSD 12.0 laufen. Mein Problem ist, dass die angelegten Dateinamen, von macOS 10.14.6 aus, zwar richtig angezeigt werden, jedoch nicht in der freeBSD console.

macOS foö.md
freeBSD fo??.md

Hier meine /usr/local/etc/smb4.conf aka $ testparm output:
Code:
...
[global]
        deadtime = 30
        disable spoolss = Yes
        load printers = No
        name resolve order = bcast host lmhosts wins
        netbios name = NETBIOS
        printcap name = /dev/null
        security = USER
        server min protocol = SMB3_00
        server multi channel support = Yes
        server string = samba %v
        socket options = TCP_NODELAY IPTOS_LOWDELAY IPTOS_THROUGHPUT SO_KEEPALIVE SO_RCVBUF=65536 SO_SNDBUF=65536
        unix extensions = No
        wins support = Yes
        fruit:encoding = native
        idmap config * : backend = tdb
        aio read size = 16384
        aio write size = 16384
        strict locking = No
        strict sync = No
        vfs objects = catia fruit streams_xattr
...
Habe gefühlt bereits alle gelesen und ausprobiert. Hier meine Link-Liste:
Die locale in der /etc/login.conf habe ich ebenfalls ergänzt und rebuilded $ cap_mkdb /etc/login.conf.
Code:
...
default:\
...
    :charset=UTF-8:\
    :lang=en_US.UTF-8:\
    :setenv=LC_COLLATE=C:
...
Danke im Voraus für Hinweise und Hilfe.

runBSD :) Grüße
 

foxit

Moderator
Mitarbeiter
#2
Zeig mal deine komplette "/etc/login.conf". Hast du in $HOME noch eine ".login_conf"?
Bei mir funktioniert es aber ich habe kein ":setenv=LC_COLLATE=C:" gesetzt sondern nur:
Code:
  :charset=UTF-8:\
  :lang=en_US.UTF-8: