Samba PDC Problem!

Styx

Universaldilettant
Hallo Leute!
Ich habe ein ziemlich dringliches Problem mit einem Samba-Server, der als PDC laufen soll. Der Server an sich funktioniert einwandfrei. Bisher greifen 7 Windows-Clients darauf zu und schieben Daten auf einen angeschlossenen Fileserver, der mit FreeBSD 5.4 p6 bespielt ist und sehr gut arbeitet. Das Problem ist nun, dass es mir einfach nicht gelingen will, dass die Clients sich über die Domäne bei Samba anmelden können.

Zur Einrichtung des Samba PDC habe ich folgende Anleitungen/Threads studiert:
http://www.bsdforen.de/showthread.php?t=2174&highlight=Samba+PDC+HowTo
http://wiki.bsdforen.de/index.php/FreeBSD_-_Samba_PDC
http://www.bsdforen.de/showthread.php?t=11357

Auch auf der Samba-Homepage habe ich mir diverse Artikel durchgelesen sowei Google bemüht. Ich vermute es ist irgendeine simple, kleine Einstellung und ich sehe den Wald vor lauter Bäumen nicht.

Jeder Rechner hat einen Maschinenaccount auf dem Sambaserver und es sind diverse Benutzer eingerichtet.

Ein Beispiel:
Maschinenaccount: wxp001
Benutzer: mklemrath

Beide Benutzer sind sowohl als Unix-Accounts als auch als Samba-Accounts vorhanden.

Hier die smb.conf:

Code:
[global]
	log file = /var/log/samba/log.%m
	display charset = ISO-8859-15
	load printers = yes
	socket options = TCP_NODELAY
	wins support = true
	dns proxy = no 
	server string = Fileserver
	writeable = yes
	dos charset = 850
	workgroup = betterday
	os level = 20
	valid users = @smb-users
	create mode = 777
	security = domain
	unix charset = ISO-8859-15
	max log size = 50
	directory mode = 777

        passdb backend = tdbsam
        netbiosname = Server
        browseable = no
        public = no
        writeable = no
        guest ok = no
        preferred master = yes
        domain master = yes
        # preferred domain = yes
        domain logons = yes
        # Passwort Einstellungen
        encrypt passwords = yes
        update encrypted = yes
        password level = 4

        wins server = 192.168.1.1
        wins support = yes
        # Performance Einstellungen
        short preserve case = yes
        max log size = 5000
        case sensitive = no
        default case = lower
        dead time = 15
        read raw = yes
        write raw = yes
        oplocks = yes
        fake oplocks = no
        debug level = 2
        preserve case = yes
        getwd cache = yes


[homes]
	browseable = no
	comment = Home Directories
	writable = yes
	available = no

[printers]
   comment = All Printers
   path = /var/spool/samba
   browseable = no
# Set public = yes to allow user 'guest account' to print
   guest ok = no
   writable = no
   printable = yes

[netlogon]
	comment = Netlogon
	browseable = no
	writeable = yes
	valid users = @smb-workstations
	path = /usr/data/netlogon
	write list = wxp001$,mklemrath,@smb-workstations,@smb-users

        # LogOn einstellungen fuer Windows
        logon drive = p:
        logon path = \\\\%L\\profiles\\%U
        logon home = \\\\%L\\%U
        logon script = logon.cmd        

[public]
        path = /usr/home/public
        browseable = yes
        writeable = yes
        guest ok = yes
        public = yes
        comment = Testordner

[Daten]
	force create mode = 777
	force user = marco
	locking = no
	path = /home/daten/Daten/Daten
	write list = mfunk,mhafke,mhoelz,mklemrath,Myriam,sbednarek,marco,Buchhaltung,Administrator,Silke,@smb-users
	force directory mode = 777

[Buchhaltung]
	valid users = rhoelz,Buchhaltung
	write list = Buchhaltung,rhoelz
	path = /home/daten/Daten/Buchhaltung


[Profiles]
	browseable = no
	security mask = 0600
	writeable = yes
	write list = @smb-workstations,@smb-users
	path = /usr/data/profiles
	create mask = 0600
	comment = Profile
	directory mask = 0700
	valid users = @smb-workstations,@smb-users
	directory security mask = 0700

[mklemrath]
        comment = Klemrath
        path = /usr/home/mklemrath
        write list = mklemrath
        create mask = 0777
        directory mask = 0777

Wenn ich mich mit dem Rechner wxp001 (momentan noch ein Win2000-Rechner) als User mklemrath an der Domain anmelden möchte kommt folgende Fehlermeldung:

Beim Versuch der Domäne "betterday" beizutreten, trat folgender Fehler auf: Die angegebenen Anmeldeinformationen stehen mit vorhandenen Anmeldeinformationen in Konflikt.

Ich bin wirklich für jeden Tipp dankbar!

Grüße
Styx
 

asg

push it, don´t hype
Heisst der W2K Rechner auch wirklich "wxp001"? Wie ist denn der Netbios Name von dem Rechner und hast Du diesen mit pdbedit angelegt? (-u -m -a).
 

Styx

Universaldilettant
Ja, der Rechner heisst wirklich auch wxp001 und angelegt wurde der Maschinen-Account mit pdbedit -u -m -a. er wird in Webmin auch als "Rechneraccount (Domäne)" angezeigt.
 
Hi,


Beim Versuch der Domäne "betterday" beizutreten, trat folgender Fehler auf: Die angegebenen Anmeldeinformationen stehen mit vorhandenen Anmeldeinformationen in Konflikt.

Anscheinend besteht noch eine Laufwerk/Druckerverbindung auf Basis einer früheren Authorisation auf Freigabeebene. Der User will sich ja an der Domäne anmelden. Das klappt m.W. auch unter Windows nicht, wenn bereits z.B. ein Laufwerk gemappt ist...
 

Styx

Universaldilettant
Dieser Tipp war schonmal sehr gut. Ich habe alle Verbindungen zum Server gekappt. Allerdings bekomme ich nun folgende Meldung:

"Beim Versuch der Domäne "betterday" beizutreten, trat folgender Fehler auf: Anmeldung fehlgeschlagen: unbekannter Benutzername oder falsches Kennwort"

Es ist zum Mäusemelken...
 

maus

Maus-Phobie überwunden
Styx schrieb:
Ja, der Rechner heisst wirklich auch wxp001 und angelegt wurde der Maschinen-Account mit pdbedit -u -m -a. er wird in Webmin auch als "Rechneraccount (Domäne)" angezeigt.
Samba 3 "Das offizielle Handbuch" Seite 93; 5.6 Häufige Fehler:
..FreeBSD (und andere BSD-Systeme) legen keinen Benutzer mit einem "$" im Namen an. Es wird empfohlen den Maschinennamen zunächst ohne "$" anzulegen und dann das Zeichen "$" mit vipw hinzuzufügen.
 
Zuletzt bearbeitet:

0815Chaot

FreeBSD/sparc64-Tüftler
maus schrieb:
Samba 3 "Das offizielle Handbuch" Seite 93; 5.6 Häufige Fehler:
..FreeBSD (und andere BSD-Systeme) legen keinen Benutzer mit einem "$" im Namen an.
Das halte ich aber für ein ganz dickes Gerücht:
Code:
> pw useradd dose$ -u 999 -g nogroup -s /sbin/nologin -d /nonexistent
> grep ^dose /etc/passwd
dose$:*:999:65533:User &:/nonexistent:/sbin/nologin
> uname -sr
FreeBSD 5.3-RELEASE
Styx schrieb:
Code:
       logon drive = p:
        logon path = \\\\%L\\profiles\\%U
        logon home = \\\\%L\\%U
        logon script = logon.cmd [/quote]Wie AndreasMeyer schon schrieb, muß das in [global]. Außerdem sind bei dir alle Backslashes doppelt. Und nimm [i]valid users[/i] und [i]write list[/i] aus [netlogon] raus. In [global] darf kein [i]writeable[/i] stehen. [i]public[/i] und [i]browseable[/i] haben da ebensowenig was verloren. Warum verwendest du den Samba-Server nicht als WINS-Server? [i]directory mode[/i] in [global] ist ziemlich fahrlässig.

Da sind bestimmt noch mehr Fehler, aber ich habe ehrlich gesagt keine Lust mehr, weiter zu gucken.  Wirf diese Konfiguration weg und fange noch mal ganz von vorne an. Wenn du eine funktionierende Beispielkonfiguration haben willst, schreib mir eine PM. Hast du erst mal eine minimale(!), funktionierende Konfiguration, kannst du darauf aufbauen.
 

Styx

Universaldilettant
So, dann werde ich mal nach einer längeren Pause mein eigenes Thema wieder rausbuddeln, da ich mich in den letzten Tagen wieder intensiv mit dem (zwar nicht dringenden aber nervigen) Problem beschäftige.

Ich habe tatsächlich mit der Konfiguration nochmal ganz von vorne angefangen. Testweise hatte ich mal Samba 3 runter genommen und die 2er Version installiert. Interessanterweise funktionierte damit die Anmeldung an die Domain problemlos. Da es aber andere Schwierigkeiten (vor allem mit den Charsets) gab, habe ich wieder die 3er-Version (genauer gesagt Version 3.012) genommen. Die smb.conf habe ich übernommen. Dennoch sagt mir die gleiche Windoof-Kiste, die ich unter 2.x der Domain hinzugefügt habe, dass die Domain jetzt nicht erreichbar wäre. Hier die smb.conf:

Code:
# Global parameters
[global]
        unix charset = ISO-8859-15
        display charset = ISO-8859-15
        workgroup = BETTERDAY
        netbios name = FILESERVER
        server string = Fileserver
        passdb backend = tdbsam
        log file = /var/log/log.%m
        max log size = 50
        logon script = logon.cmd
        logon path = \\\\%L\\profiles\\%U
        logon drive = z:
        logon home = \\\\%L\\%U
        domain logons = Yes
        os level = 65
        preferred master = Yes
        domain master = Yes
        dns proxy = No
        wins support = Yes
        ldap ssl = no

[homes]
        comment = Home Directories
        read only = No
        create mask = 0700
        security mask = 0700
        directory mask = 0700
        directory security mask = 0700
        veto files = /.*/
        browseable = No
        available = No

[printers]
        comment = All Printers
        path = /var/spool/samba
        printable = Yes
        browseable = No

[Netlogon]
        comment = Netlogon
        path = /usr/data/netlogon
        browseable = No

[Profiles]
        comment = Profiles
        path = /usr/data/profiles
        read only = No
        create mask = 0600
        security mask = 0600
        directory mask = 0700
        directory security mask = 0700
        browseable = No
        writeable = yes
        write list = @smb-users

[Daten]
        comment = Daten
        path = /usr/home/daten
        valid users = @smb-users
        write list = @smb-users
        force user = marco
        read only = No
        create mask = 0777
        force create mode = 0777
        directory mask = 0777
        force directory mode = 0777

Das schreiben und lesen auf die Shares klappt einwandfrei. Ich konnte auch das Profil eines Users auf den Server kopieren, aber anmelden kann er sich trotzdem nicht :(

0815Chaot schrieb:
...Außerdem sind bei dir alle Backslashes doppelt.

Hmm....das habe ich aus dem Foren-Wiki ;) Siehe hier:

http://wiki.bsdforen.de/index.php/FreeBSD_-_Samba_PDC#Webmin_2

Und es funktionierte unter 2.x ja auch. Die Anleitung im Wiki ist für 3.x geschrieben und da geht es dann plötzlich nicht mehr :confused: Mit jeweils der Hälfte an Backslashes habe ich es auch mal probiert, was ebenfalls keinen Erfolg hatte.

Wer hat denn noch einen heissen Tipp für mich? ich bin für jede Hilfe dankbar. Danke im voraus. :)

Grüße
Styx
 

AndreasMeyer

SLED 10
Zum Testen der smb.conf-Konfiguration dient das Programm "testparm". Testparm ist mit deiner [homes]-Konfiguration nicht zufrieden:

# testparm
Load smb config files from /usr/local/etc/smb.conf
Processing section "[homes]"
NOTE: Service homes is flagged unavailable.
Processing section "[printers]"
Processing section "[Netlogon]"
Processing section "[Profiles]"
Processing section "[Daten]"
Loaded services file OK.
Server role: ROLE_DOMAIN_PDC
Press enter to see a dump of your service definitions
Mit der [homes]-Konfiguration aus:

http://wiki.bsdforen.de/index.php/FreeBSD_-_SambaNeu

gibt es keine Testparm-Fehlermeldung.
 
Zuletzt bearbeitet:

Styx

Universaldilettant
Danke für den Hinweis. Allerdings scheint das nicht die Lösung für das Problem zu sein, denn jetzt meldet er keine Fehler mehr und es geht trotzdem nicht :(
 

Styx

Universaldilettant
Problem gelöst...!

Ich habe soeben das Problem gelöst. Ich bin mir nicht ganz sicher, woran es lag. Vermutlich an ein paar kleineren Änderungen und daran, dass ich den Rechner nochmal aus der Domain rausgenommen und wieder reingepackt habe. Der Vollständigkeit halber hier die komplette smb.conf nochmal:

Code:
[global]
        unix charset = ISO-8859-15
        display charset = ISO-8859-15
        workgroup = BETTERDAY
        netbios name = FILESERVER
        server string = Fileserver
        passdb backend = tdbsam
        log file = /var/log/log.%m
        max log size = 50
        logon script = logon.cmd
        [COLOR="Red"]logon path = \\%L\profiles\%U
        logon drive = z:
#       logon home = \\\\%L\\%U
        domain logons = Yes
        security = user
        encrypt passwords = yes[/COLOR]
        os level = 65
        preferred master = Yes
        domain master = Yes
        dns proxy = No
        wins support = Yes
        ldap ssl = no

[homes]
        comment = Home Directories
        writable         = yes
        browseable       = no
        create mask = 0700
        security mask = 0700
        directory mask = 0700
        directory security mask = 0700
        veto files = /.*/
        browseable = No
[COLOR="Red"]#       available = No[/color]

[printers]
        comment = All Printers
        path = /var/spool/samba
        printable = Yes
        browseable = No

[Netlogon]
        comment = Netlogon
        path = /usr/data/netlogon
        browseable = No

[Profiles]
        comment = Profiles
        path = /usr/data/profiles
        read only = No
        create mask = 0600
        security mask = 0600
        directory mask = 0700
        directory security mask = 0700
        browseable = No
        writeable = yes
        write list = @smb-users

[Daten]
        writeable = yes
        path = /usr/home/daten
        write list = @smb-users
        force directory mode = 0777
        force create mode = 0777
        force user = marco
        create mask = 0777
        comment = Daten
        directory mask = 0777
        valid users = @smb-users

[COLOR="Red"][tmp]
        comment = Temporary file space
        path = /tmp
        read only = no
        public = yes
[/COLOR]

Die Änderungen der smb.conf habe ich zur besseren Übersicht in rot markiert. Danke nochmal an alle, die mir geholgen haben! :)

Grüße
Styx
 
Zuletzt bearbeitet:
Oben