• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Schrift im Web unter Firebird unlesbar

L

Leno

Guest
Themenstarter #1
Hi!

Ich habe unter OpenBSD Mozilla-Firebird installiert, doch die Darstellung der Schriften im Web ist grausam und zum Teil unlesbar. Also habe ich versucht Xft einzustellen. Dazu habe ich im Makefile folgende Flags zusätzlich gestzt:

Code:
--with-ft-prefix=/usr/X11R6
--enable-xft
Der Make-Befehl sah folgendermaßen aus:

Code:
env PKG_CONFIG_PATH=/usr/X11R6/lib/pkgconfig make install
Die Installation brach aber mit Fehler ab.
Habe dann zwischenzeitlich Dillo installiert damit ich überhaupt einen Browser hab; und hier ist die Schrift vollkommen in Ordnung. Der Funktionsumfang von Dillo ist mir aber zu beschränkt (unterstütz noch keine Doenloads, kein FTP)

Die bitstream-vera-fonts sind auch installiert, aber die helfen auch nichts.

Hat jemand von euch Firebird unter OpenBSD laufen und kann mir helfen, oder falls nicht was für einen Browser habt ihr dann laufen?


Leno


P.S: Google hab` ich schon bemüht, da kommt mein Ansatz mit dem veränderten Makefile her. Fehlermeldung kann ich im Moment nicht posten da ich am falschen Rechner sitz, kann ich aber nachholen falls es was nützt.
 

oenone

Well-Known Member
#2
bei mir laeuft firebird und die schrift ist in ordnung...
schick mal nen screenshot davon.
welche openbsd version hast du ?

auf bald
oenone
 
L

Leno

Guest
Themenstarter #3
Schicke den Screenshot morgen, da ider Rechner gerade unter FreeBSD compiliert.

Habe OpenBSD 3.4 installiert. (aus dem Web)

Hast du an den Fonts etwas geändert, oder oder zusätzliche installiert?


Leno
 

oenone

Well-Known Member
#4
ich hab gar nichts geaendert... ein einfaches "make install clean" in /usr/ports/www/mozilla-firebird/

auf bald
oenone
 
L

Leno

Guest
Themenstarter #5
Ich poste morgen ein Screenshot von Firebird und eins von Dillo zum Vergleich.

Bis denn

Leno
 
L

Leno

Guest
Themenstarter #6
Hier ist jetzt ein Screen-Shot.

Oben ist der Firebird und unten ist Dillo.

Ich denke man sieht den Unterschied.



Leno
 
#7
Hmm, bin zwar kein Obsd-User, aber unter Freebsd haben die Webfonts das Problem bei mir geloest. Vielleicht gibt es die auch unter den Ports?
 
L

Leno

Guest
Themenstarter #8
Unter OpenBSD gibt es keine Webfonts. Zumindest nicht in den Ports.

Ist also leider auch keine Lösung. Werde mal die Mailinglists auf OpenBSD.org durchsuchen, ob ich da was finden kann.


Danke trotzdem für den Tip


Leno
 
L

Leno

Guest
Themenstarter #9
Nochmal ich:

Habe nochmal gesucht und bei mir läuft mittlerweile xterm mit Xft. Aber leider nicht Firebird.

@oenone: Ist bei dir Antialiasing eingeschaltet?

Mach jetzt noch einen Versuch indem ich folgende Änderungen noch versuch:

Code:
Index: Makefile
===================================================================
RCS file: /cvs/ports/www/mozilla-firebird/Makefile,v
retrieving revision 1.24
diff -u -r1.24 Makefile
--- Makefile	2003/11/25 05:13:02	1.24
+++ Makefile	2003/12/22 18:00:21
@@ -61,6 +61,15 @@
 MAKE_ENV=	MOZ_PHOENIX=1 \
 		LD_LIBRARY_PATH="${WRKSRC}/dist/bin"
 
+FLAVORS=	xft
+FLAVOR?=
+
+.if ${FLAVOR:L:Mxft}
+CONFIGURE_ARGS+=	--enable-xft
+CONFIGURE_ENV+=		PKG_CONFIG_PATH="${LOCALBASE}/lib/pkgconfig:${X11BASE}/lib/pkgconfig"
+BUILD_DEPENDS+=		:pkgconfig-*:devel/pkgconfig
+.endif
+
 MOB=		${WRKSRC}/dist/bin
 MOZ=		${PREFIX}/mozilla-firebird
 
Index: pkg/DESCR
===================================================================
RCS file: /cvs/ports/www/mozilla-firebird/pkg/DESCR,v
retrieving revision 1.2
diff -u -r1.2 DESCR
--- pkg/DESCR	2003/11/25 05:13:02	1.2
+++ pkg/DESCR	2003/12/22 18:00:21
@@ -1,3 +1,7 @@
 The Mozilla Firebird project is a redesign of Mozilla's browser
 component, written using the XUL user interface language and designed
 to be cross-platform.
+
+Flavors:
+
+  xft: enables the X freetype extension for anti-alias font rendering
Index: pkg/PFRAG.xft
===================================================================
RCS file: PFRAG.xft
diff -N PFRAG.xft
--- /dev/null	Mon Nov  3 01:42:15 1997
+++ PFRAG.xft	Mon Dec 22 18:00:21 2003
@@ -0,0 +1,2 @@
+ [at] comment $OpenBSD$
+mozilla-firebird/res/fonts/fontEncoding.properties
Index: pkg/PLIST
===================================================================
RCS file: /cvs/ports/www/mozilla-firebird/pkg/PLIST,v
retrieving revision 1.10
diff -u -r1.10 PLIST
--- pkg/PLIST	2003/11/25 05:13:02	1.10
+++ pkg/PLIST	2003/12/22 18:00:22
@@ -209,6 +209,7 @@
 mozilla-firebird/res/entityTables/htmlEntityVersions.properties
 mozilla-firebird/res/entityTables/mathml20.properties
 mozilla-firebird/res/entityTables/transliterate.properties
+%%xft%%
 mozilla-firebird/res/fonts/mathfont.properties
 mozilla-firebird/res/fonts/mathfontCMEX10.properties
 mozilla-firebird/res/fonts/mathfontCMSY10.properties
Poste wieder wenn ich Firebird neu gebaut habe.


Leno

P.S: Konqueror würde mit den Einstellungen für Xterm auch Kantenglättung beherrschen, aber den Konqueror will ich nicht.
 
L

Leno

Guest
Themenstarter #11
Kann dir leider nicht sagen wo du das nachschauen könntest.

Die Sache mit dem Flavor hat aber auch nicht geholfen. Bricht ab weil Abhängigkeiten nicht simmen.

Habe also die Änderungen im Makefile und den anderen Dateien rückgängig gemacht und versuche jetzt noch mal was neues.

Aber wenn das nicht klappt weiß ich auch nicht mehr weiter.



Für heute ist aber erst mal genug.


Leno
 
L

Leno

Guest
Themenstarter #12
Problem gelöst. Mein letzter Versuch brachte den gewünschten Erfolg.

Also was zu machen ist um Mozilla-Firebird mit Xft zu kompilieren:

Code:
 		--with-system-jpeg=${LOCALBASE}	\
 		--with-system-mng=${LOCALBASE}	\
 		--with-system-png=${LOCALBASE}	\
+		--with-ft-prefix=${X11BASE}	\
+		--with-ft-exec-prefix=${X11BASE}/bin \
+		--enable-xft			\
 		--with-system-zlib=/usr/lib	\
 		--with-pthreads			\
 		--disable-composer		\
 		--disable-ldap
 
 CFLAGS+=	-fno-stack-protector
-CONFIGURE_ENV=	MOZ_PHOENIX=1
+CONFIGURE_ENV=	MOZ_PHOENIX=1 \
+		PKG_CONFIG_PATH=${X11BASE}/lib/pkgconfig
 MAKE_ENV=	MOZ_PHOENIX=1 \
 		LD_LIBRARY_PATH="${WRKSRC}/dist/bin"
Die Lösung ist natürlich nicht auf meinem Mist gewachsen und daher geb ich noch den Link an, der mir dann geholfen hat:

http://news.gw.com/openbsd.ports/15402

Außer dem patchen des Makefiles habe ich noch zusätzlich die im Link erwähnten msttcorefonts installiert, ttmkfdir und pkgconfig. Dazu hab' ich noch die bitstream-vera Fonts installiert, und in XF86Config die Bitstream-Vera-Fonts hinugefügt und freetype ausgeklammert. Damit läufts und sieht auch gut aus.

Wer für sein Xterm Xft aktivieren will für den gibts folgendes:

http://www.openbsd.org/faq/truetype.html





Danke @moonlock und oenone


Leno