• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Schwarzer Bildschirm in xfce4 - Anscheinend Zusammenhang mit nvidia-driver

cabriofahrer

Well-Known Member
Themenstarter #1
Sicherlich könnt Ihr Euch noch daran erinnern, dass ich vor einiger Zeit hier einen Thread eröffnete, weil ich nach einem pkg upgrade auf dem Rechner meiner Freundin plötzlich nach dem Start von xfce einen schwarzen Bildschirm bekam. Den Thread wollte ich nicht weiterführen und eröffne lieber einen neuen, weil der alte Thread viele andere Aspekte enthielt die nicht zur Sache tun (z.B. Remotezugriff) und ich jetzt neuere Erkenntnisse habe, die das Problem eingrenzen. OK, erstmal die seit dem gesammelten neuen Schritte/Erkenntnisse:

Zur Erinnerung: Das Problem trat nicht nur auf dem Rechner meiner Freundin auf, sondern auch auf meinem Laptop.
Es fiel auf, dass nach einem Löschen der Verzeichnisse "Thunar" und "xfce4" in .config xfce normal startete, nach einem Logout und dem Wiedervorhandensein der beiden Dateien dann aber nicht mehr, also wieder schwarzer Bildschirm.
Den Laptop stellte ich auf Latest-Packages, um möglichst schnell immer die neuesten Versionen zu bekommen. Zwei upgrades (letztes gestern) seit dem haben nichts gebracht.
Ich kam auf die Idee, FreeBSD in einer VirtualBox auf meinem Hauptrechner zu installieren und stellte fest, dass das Problem in der virtuellen Maschine nicht auftritt.
Jetzt also die große Idee: Durch Umbenennen der xorg.conf in xorg.conf.bak, den nvidia-driver beim Start von X verhindern und gucken, was passiert. Und siehe da, xfce startet. Die Auflösung ist natürlich mit dem VESA-Treiber geringer, aber xfce funktioniert. Und ich kann mich ausloggen und wieder xfce wieder neu starten (xinit startxfce4) und es funktioniert wunderbar und immer wieder.
Doch sobald ich xorg.conf.bak wieder in xorg.conf umbenenne (also den nvidia-driver wieder benutze), wieder schwarzer Bildschirm.

Was sagt uns das? Wer ist jetzt Schuld, wenn andere Desktops wie MATE, openbox oder fluxbox mit dem nvidia-driver funktionieren, nur xfce nicht mehr? Xfce oder nvidia (und es sind anscheinend alle Versionen betroffen)?

Ich habe noch das hier gefunden, es scheint das gleiche Problem zu sein, kann damit aber nicht viel anfangen:

https://devtalk.nvidia.com/default/...k-screen-at-desktop-login-gtx-750-ti-390-25-/
 
#2
Moin cabriofahrer,

vorweg muß ich mitteilen, dass ich keine NVidia-Installation habe, aber dem von Dir genannten Link zum NVidia-Forum bin ich mal nachgegangen. Im Beitrag #32 steht etwas interessantes, was vielleicht helfen könnte:
Zitat:
did manage to get things sorted out regarding xorg with CompositionPipeline enabled on boot by deleting the secondary display position values in the displays.xml file for xfce in /home/XXXXX/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml (deleting that file also works).
When ever the position for the secondary monitor in displays.xml, was set to the same x and y position value in xorg.conf, provided by the nvidia driver, the black screen would appear upon boot with {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On} in xorg. Though it doesn't occur with compositing disabled (as you all know), with any driver previous to v390, or when non-matching x and y position values are used for secondary display with it enabled.
Lösche doch mal diese display.xml und schaue, was beim nächsten Login passiert.
 

cabriofahrer

Well-Known Member
Themenstarter #3
Lösche doch mal diese display.xml und schaue, was beim nächsten Login passiert.
Die Datei wird beim nächsten Login offensichtlich sofort wieder erstellt, so dass das Problem bestehen bleibt. Ich gebe mal den Inhalt an:

Code:
$ more .config/xfce4/xfconf/xfce-perchannel-xml/displays.xml
<?xml version="1.0" encoding="UTF-8"?>

<channel name="displays" version="1.0">
  <property name="ActiveProfile" type="string" value="Default"/>
</channel>
$
 
#4
Guten Abend cabriofahrer.

Genau wie Du stocher ich im Nebel :D
Laut dem Forumsbeitrag wird wohl in die xorg.conf diese Zeile eingetragen:
"nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"
Falls die in Deiner xorg.conf drinsteht, kommentiere die doch bitte mal aus und schau mal nach, was dann passiert.
 

Alexander88207

Well-Known Member
#8
Ich nehme mal an das du auch slim benutzt, bei mir ist es so dass, das ausloggen bei manchen DM's funktioniert und bei manchen nicht.
 
Zuletzt bearbeitet:

cabriofahrer

Well-Known Member
Themenstarter #10
Guten Abend,

ist Deine UserID Mitglied in der Gruppe video - stand irgendwo in den unendlichen Weiten des Forumskosmos?
Ja, ist der Fall, obwohl bei nvidia nicht nötig.

Moin !

Warum nvidia-driver-304 , welche Grafikkarte hast du denn !

.....

Aktuell wäre nvidia-driver-440.64 .....

?

Gruss
Es handelt sich um einen Onboard-Grafik-Chip auf einem alten AM2-Mainboard. Das ist schon richtig. Im internationalen Forum behauptet jemand, das Problem würde nicht nur mit nvidia auftreten, sondern auch bei amdgpu.

Ich nehme mal an das du auch slim benutzt, bei mir ist es so dass, das ausloggen bei manchen DM's funktioniert und bei manchen nicht.
Nein, sddm. Aber das scheint keine Rolle zu spielen. Ich hatte an anderer Stelle schon mal erwähnt, dass das Problem auch auftritt, wenn man xfce ohne Loginmanager direkt mit xinit startet.
 
#11
Moin !

Hast du es schon mal mit "xrandr" probiert !

Mal mit dem Vesa-Treiber in XFCE4 einloggen und als
Autostartprogramm xrandr mit den entsprechenden
Werten angeben !

Als Beispiel mal mein Autostart bei Openbox :

sh -c 'xrandr --output DP-0 --mode 3840x1080 --rate 144.00'

Danach wieder mit dem Nvidia-Treiber antesten !

Versuch macht klug :ugly:

Gruss

P.S.: Deine Modi erhälst du mit :

bluescreen@fatcat:~$ xrandr
Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected primary (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 connected 3840x1080+0+0 (normal left inverted right x axis y axis) 1196mm x 336mm
3840x1080 144.00*+ 119.97 99.96 59.97
2560x1080 59.94
1920x1080 60.00 59.94 50.00
1680x1050 59.95
1600x900 60.00
1440x900 59.89
1280x1024 75.02 60.02
1280x800 59.81
1280x720 60.00 59.94 50.00
1152x864 75.00
1024x768 75.03 70.07 60.00
800x600 75.00 72.19 60.32 56.25
720x576 50.00
720x480 59.94
640x480 75.00 72.81 59.94
DP-1 disconnected (normal left inverted right x axis y axis)
 

cabriofahrer

Well-Known Member
Themenstarter #12
sh -c 'xrandr --output DP-0 --mode 3840x1080 --rate 144.00'
Wie kommst Du auf diese Auflösung? Die wäre bei mir viel zu hoch. Ich hatte aber mal die xorg.conf umbenann und somit den nvidia-driver umgangen. So hatte es tatsächlich funktioniert.
Laut dem Forumsbeitrag wird wohl in die xorg.conf diese Zeile eingetragen:
"nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"
Falls die in Deiner xorg.conf drinsteht, kommentiere die doch bitte mal aus und schau mal nach, was dann passiert.
Dieser Eintrag erscheint nicht in meiner xorg.conf, deswegen kann ich ihn auch nicht auskommentieren.
 

cabriofahrer

Well-Known Member
Themenstarter #15
Moin cabriofahrer,

poste bitte die /var/log/Xorg.0.log. Vielleicht ist etwas zu erkennen.
Grüßle
Das hatten wir schon mal an anderer Stelle. Es ist kein Fehler mit X. Das Problem liegt in xfwm4. Man kann nämlich in SDDM als Session z.B. openbox (oder auch fluxbox auswählen), dann bekommt man erstmal einen leeren Bildschirm. Öffnet man dann z.B. xterm und gibt darin xfce4-session & ein, lädt sich xfce4 komplett und scheint komplett funktional zu sein, außer z.B. "Window Tweaks" in "Settings", weil eben xfwm4 nicht geladen ist.

Ich nehme an, man könnte sich dann also eine .xinitrc mit dem Inhalt xfce4-session & erstellen und das Problem somit umgehen, bis die Verantwortlichen xfwm4 gefixt haben...