• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Scribus läuft nicht (ports)

Plage

Well-Known Member
Themenstarter #1
ich hab versucht scribus von den ports (pkg_add -r) installiert. nur startet scribus wegen einer fehlenden lib nicht. wie kann ich die libgnutls.so.13 nachinstallieren?

Code:
Password:
pcbsd# pkg_add -r scribus
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6.3-release/Latest/scribus.tbz... Done.
pkg_add: package 'scribus-1.3.3.8' or its older version already installed
pcbsd# pkg_add -r scribus
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6.3-release/Latest/scribus.tbz...^CSignal 2 received, cleaning up..
pcbsd# pkg_add -r -f scribus
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6.3-release/Latest/scribus.tbz... Done.
pkg_add: warning: package 'scribus-1.3.3.8' requires 'expat-2.0.0_1', but 'expat-2.0.1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'tcl-8.4.16,1', but 'tcl-8.4.18,1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'python25-2.5.1_1', but 'python25-2.5.2_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'png-1.2.22', but 'png-1.2.26' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'pkg-config-0.22_1', but 'pkg-config-0.23_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libart_lgpl-2.3.19,1', but 'libart_lgpl-2.3.20,1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXdmcp-1.0.2', but 'libXdmcp-1.0.2_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libICE-1.0.4,1', but 'libICE-1.0.4_1,1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libSM-1.0.3,1', but 'libSM-1.0.3_1,1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libX11-1.1.3,1', but 'libX11-1.1.3_1,1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'tk-8.4.16,2', but 'tk-8.4.18,2' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXrender-0.9.4', but 'libXrender-0.9.4_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXt-1.0.5', but 'libXt-1.0.5_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libxkbui-1.0.2', but 'libxkbui-1.0.2_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXfixes-4.0.3', but 'libXfixes-4.0.3_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXcursor-1.1.9', but 'libXcursor-1.1.9_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'ghostscript-gpl-8.60', but 'ghostscript-gpl-8.61_4' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libdmx-1.0.2', but 'libdmx-1.0.2_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXv-1.0.3,1', but 'libXv-1.0.3_1,1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXvMC-1.0.4', but 'libXvMC-1.0.4_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXtst-1.0.3', but 'libXtst-1.0.3_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXres-1.0.3_2', but 'libXres-1.0.3_3' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXrandr-1.2.2', but 'libXrandr-1.2.2_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXaw-1.0.4,1', but 'libXaw-1.0.4_1,1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libFS-1.0.0', but 'libFS-1.0.0_1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libXfont-1.3.1_1,1', but 'libXfont-1.3.1_3,1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'fontconfig-2.4.2_2,1', but 'fontconfig-2.5.0,1' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libxml2-2.6.30', but 'libxml2-2.6.31' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libgpg-error-1.5', but 'libgpg-error-1.6' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'libgcrypt-1.2.4_1', but 'libgcrypt-1.4.0' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'gnutls-2.0.2_1', but 'gnutls-2.2.2' is installed
pkg_add: warning: package 'scribus-1.3.3.8' requires 'cups-base-1.3.3_2', but 'cups-base-1.3.7_2' is installed
pcbsd# scribus
/libexec/ld-elf.so.1: Shared object "libgnutls.so.13" not found, required by "scribus"
pcbsd#
 

Plage

Well-Known Member
Themenstarter #3
hab zwischenzeitlich schon von nem kollegen nen tip bekommen das per "make install clean". danach hatte ich nen lerneffekt. ;-)
werde mir das mit der libmap.conf und selber bauen auch mal angucken.
 

Plage

Well-Known Member
Themenstarter #7
ich dachte immer das selber bauen heißt, man müsste nen compiler anwerfen und erstmal in den sourcen rumwursten bevor man erstmal compilen kann. aber ich hab ja auch nur nen befehl eingegeben. aber es funzt jetzt mit "make install clean".
 

mapet

Active OpenBSD User
#9
wenn du dir die ausgabe beim bauen eines ports genauer ansiehst, wirst du sehen, dass er dieses "compiler anwerfen" für dich übernimmt. er lädt die quellen aus dem netz, setzt die entsprechend configure-flags und wirft anschließend den compiler für dich an (je nach befehl in dem port verzeichnis "install"iert er das programm auch und säubert (clean) danach noch das verzeichnis von dem bauen). der vorteil von den ports ist, dass das automatisch passiert und auch selten schief geht, da die software auf freebsd abgestimmt wurde (bspw. gmake anstatt dem "normalen" bsd-make zu nehmen).
das handbuch sollte dir das genauer erläutern, was ports und was packages sind.

hth