• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Segmentation fault bei Videowiedergabe oder Spielen

Themenstarter #1
Hallo zusammen,

leider stürzen bei mir in letzter Zeit alle Programme ab, sobald sie grafisch etwas anspruchsvoller sind wie z.B. Videowiedergabe (vlc, mpv) oder Spiele (widelands). Ich weiß nicht genau, warum der Fehler auftritt. VLC gibt noch am meisten Infos aus, alle anderen Programme geben nur ein Segmentation fault zurück:

VLC media player 3.0.6 Vetinari (revision 3.0.6-0-g5803e85f73)
[0000000800900060] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
libva info: VA-API version 1.4.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/local/lib/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_4
libva info: va_openDriver() returns 0
[00000008100d6060] glconv_vaapi_x11 gl error: vaAcquireBufferHandle: invalid VABufferID
[00000008100d6060] glconv_vaapi_x11 gl error: vaReleaseBufferHandle: invalid VABufferID
[000000080f40b060] main video output error: video output creation failed
[000000080ead9760] main decoder error: failed to create video output
libva info: VA-API version 1.4.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/local/lib/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_4
libva info: va_openDriver() returns 0
zsh: segmentation fault vlc

Der Rechner ist ein betagter Thinkpad X201. Ich habe das Paket drm-legacy-kmod installiert. Habt Ihr eine Idee, wie ich das ganze wieder zum Laufen bekommen könnte?

Vielen Dank Euch
bastorran
 

mr44er

moderater Moderator
Mitarbeiter
#3
Klingt auch nach Überhitzung, wenn es bei Beanspruchung erst knallt. Evtl. zuviel Staub auf dem Kühler?
 
Themenstarter #4
Hallo!

Danke für Eure Rückmeldungen! Ein Hardwareschaden kann ich nicht ausschließen, zumal das Gerät inzwischen ja wirklich alt ist. Allerdings hatte ich eher den Eindruck, dass es mit einer neuen FreeBSD-Version (12.0/.1) oder neuen Grafiktreibern kam ... da ich wirklich selten Filme schaue bzw. Spiele anmachen, weiß ich aber auch nicht wirklich seitdem das passiert.

Mmh, ich denke nicht, dass es Überhitzung ist, da das Spiel/Film gar nicht erst startet, sondern gleich abstürzt. Eigentlich würde ich eher vermuten, dass es irgendein Treiber-Problem ist.