• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Setzen von Festplatten - QUOTAS

Dany

Well-Known Member
Themenstarter #1
Hallo alle zusammen,

habe hier ein kleines Problem mit den Festplattenquotas.

in meiner /etc/rc.conf habe ich folgende Einträge hinzugefügt:
enable_quotas="YES"
check_quotas="NO"

in der Datei /etc/fstab habe ich folgende Zeile drin:
/dev/da0s1f /tmp ufs rw 2 2
/dev/da1s2g /home ufs rw,userquota 1 2

Mir ist eigentlich nur das Verzeichnis /home wichtig, da möchte ich einen User auf 100 MB einschränken. Der User nutzt jetzt schon 80 MB. Wenn ich jetzt folgendes ausführe:

edquota -u test

öffnet sich der vi mit folgenden Inhalt:
/home: kbytes in use: 0, limits (soft = 0, hard = 0)
inodes in use: 0, limits (soft = 0, hard = 0)

Das stimmt doch gar nicht! Es wird doch schon Platz benutzt.

Bei der Eingabe quota -v -u test erhalte ich folgende Ausgabe
Disk quotas for user test (uid 1008): none

Kann ich irgendwie erreichen das die Datei fstab neu eingelesen und verarbeitet wird, ohne Neustart?
Da ich an der Datei erst heute die Zeile /home eingefügt habe.

Danke Dany
 

asg

push it, don´t hype
#2
edquota -u test

öffnet sich der vi mit folgenden Inhalt:
/home: kbytes in use: 0, limits (soft = 0, hard = 0)
inodes in use: 0, limits (soft = 0, hard = 0)

Das stimmt doch gar nicht! Es wird doch schon Platz benutzt.
Natürlich stimmt das. Du hast zwar Quotas eingerichtet, aber das Programm kann nunmal nicht Deine Gedanken lesen und Deine gedachten Werte selbstständig eintragen.
Du musst die Datei schon selbst editieren, daher öffnet sich das Ding auch in Deinem $Editor.

Quotas werden in Blöcke angegeben, ein Block hat 1024 kbyte.
Damit kannst Du Dir nun ausrechnen welche Werte Du angeben musst wenn Du "edquota" aufrufst.

Bei der Eingabe quota -v -u test erhalte ich folgende Ausgabe
Disk quotas for user test (uid 1008): none
Kann ich irgendwie erreichen das die Datei fstab neu eingelesen und verarbeitet wird, ohne Neustart?
Da ich an der Datei erst heute die Zeile /home eingefügt habe.
Das dort "none" steht ist logisch.
Die /etc/fstab neu einlesen: "mount -a"

All die Fragen kann man durch
a) das handbook
und
b) die manpages
klären.
 

Dany

Well-Known Member
Themenstarter #3
Hallo an alle,

ich kenne mich mit FreeBSD noch nicht so gut aus, aber die Quotas benötige ich.

Ich habe mir die Anleitung durchgelesen und mir ist aufgefallen, daß ich die QUOTAS nicht in der Kernel stehen habe. Wie bekomme ich jetzt am einfachsten diese eine Option in den Kerlnel, gibt es eine Möglichkeit dies zu erreichen ohne den ganzen Kernel neu zu bauen?

Kennt jemand eine gute Anleitung wo dies beschrieben ist?

Danke Dany