SMB-Share mounten

eanneser

Well-Known Member
Hallo,

ich habe jetzt so ziemlich jede Variante durch, beim Versuch ein SAMBA-Share zu mounten.
Erfolgreich war ich trotzdem nicht. Vielleicht kann mir jemand die korrekte Syntax mitteilen?

Ziel ist, als normaler User ein paar Shares von verschiedenen Servern zu mounten. Sollte an sich wohl nicht so schwer sein, ich bekomm's trotzdem nicht hin.

Versucht habe ich "alle" Varianten, die im gefunden habe, von

"mount_smbfs //xxx.xxx.xxx.xxx/share /home/edgar/mnt" bis hin zu
"mount_smbfs //edgar@xxx.xxx.xxx.xxx/share /home/edgar/mnt" ... mit diversen Varianten und Ergänzungen.

Alle möglichen Fehlermeldungen, aber kein Erfolg. (Ich liste das hier jetzt nicht auf - es muss ja eine saubere Möglichkeit geben, ein CIFS-Share einzubinden).

Danke und Gruss
Edgar
 

eanneser

Well-Known Member
Danke, beide durchprobiert.
Fehlermeldung: ~kein Shareordner angegeben (engl. natürlich; genaue Fehlermeldung kann ich gerade nicht liefern ...)

Gruss
Edgar
 

haegga

Well-Known Member
Du solltest keine IP Adresse hinter den @ angeben sondern den Netbios Name, wenn der Name nicht via DNS aufgeloesst werden kann, musst du noch option -I hinzufuegen

mount_smbfs -I xxx.xxx.xxx.xxx //UID@name/share /mountpoint
 

eanneser

Well-Known Member
mount_smbfs -l xxx.xxx.xxx.xxx //1000@verwaltung /home/edgar/mnt -> Meldung: "mount_smbfs: empty share name"

Gruss
Edgar
 

haegga

Well-Known Member
du hast ja nun auch den netbios name vergessen,
mount_smbfs -l xxx.xxx.xxx.xxx //1000@SERVERNAME/verwaltung /home/edgar/mnt
 

eanneser

Well-Known Member
mount_smbfs -l xxx.xxx.xxx.xxx //1000@buffalonas/verwaltung /home/edgar/dsvlan/verwaltung
oder
mount_smbfs -l xxx.xxx.xxx.xxx //1000@xxx.xxx.xxx.xxx/verwaltung /home/edgar/dsvlan/verwaltung

Meldung jeweils:Warning: no cfg file(s) found.
usage: mount_smbfs [-E cs1:cs2] [-I host] [-L locale] [-M crights:srights]
[-N] [-O cowner:cgroup/sowner:sgroup] [-R retrycount]
[-T timeout] [-W workgroup] [-c case] [-d mode] [-f mode]
[-g gid] [-n opt] [-u uid] [-U username] //user@server/share node

... scheinbar bin ich zu blöd dafür ...

Gruss
Edgar
 

eanneser

Well-Known Member
Ok, den Verdacht hatte ich vorher auch schon:
mount_smbfs -I xxx.xxx.xxx.xxx //1000@xxx.xxx.xxx.xxx/verwaltung /home/edgar/dsvlan/verwaltung (-I wie Indianer)

Warning: no cfg file(s) found.
mount_smbfs: can not setup kernel iconv table (ISO8859-1:tolower): syserr = Operation not permitted

Und wenn ich's als root versuche:
(nach Eingabe des angeforderten Passworts [für den User mit der UID 1000]:
mount_smbfs: unable to open connection: syserr = Authentication error

... wie ich sagte: ich glaube ich hab' Alles durch ...

Gruss
Edgar
 

haegga

Well-Known Member
Also ohne manuelle aenderung darfst du nur als Root mounten.
Also zu "Authentication error" fallen mir zwei gruende ein.
Du hast das Passwort falsch eingeben, oder du musst noch die Domain angeben.
[-W workgroup]
 

eanneser

Well-Known Member
... und welche "manuellen" Änderungen muss ich vornehmen, damit ich als User mounten kann? (ausser: vfs.usermount=1 in der /etc/sysctl.conf einzutragen)

Passwortfalscheingabe kann ich nach mehrmaligen Versuchen ausschliessen, -W WORKGROUP (die heisst wirklich so) ändert nichts an der Fehlermeldung.

Gruss
Edgar
 

haegga

Well-Known Member
Also ich wuerde es erstmal versuchen als root zu mounten, bis du die naechste Baustelle aufmachst. Zu "user mount" gibs hier auch genuegend Beitraege.

Und was ich gerade sehe, du probierst mit den UID zu mounten, das denke ich mal wird nicht klappen. Du musst den richtigen Username angeben. Deswegen bekommst auch "Authentication error"

In der hilfe steht schon alles drin
[-u uid] [-U username] //user@server/share node
wobei du -u UID nicht angeben brauchst und option -U auch nicht, wenn du schreibst //username@server

PS: ach ich sehe gerade ich hab oben geschrieben //UID@, das sollte eigenltich username heissen.
 

h^2

hat ne Keule +1
Also ich fand das ganze SMB-Zeugs mehr als unintuitiv und bin auch nicht zufrieden wie es funktioniert. So mounte ich, falls das weiterhilft:
Code:
mount_smbfs -f 750 -d 750 -M ${USERNAME}:${GROUP} -O ${USERNAME}:${GROUP} -u ${USERNAME} -g ${GROUP} -N //${USERNAME}@${serv}/${share} /smb/${serv}
Ohne setzen der Masken geht garnichts, trotzdem verlieren alle Dateien beim schreiben das execute-bit, das Locking funktioniert nicht richtig, d.h. immer wieder beim Schreiben heißt es ich habe keine Berechtigung, zwei Sekunden später geht es dann...

Den Fuse-Port hatte ich auch versucht, aber dessen Performance war so unterirdisch, dass man darauf kein git benutzen kann.
 

Kamikaze

Warrior of Sunlight
Ich verwende sysutils/fusefs-smbnetfs. Funktioniert ganz passabel so lange man eine stabile Verbindung hat.

Die Einrichtung am Anfang ist etwas umständlich und man sollte die ganzen Timeouts runter drehen, weil leider die komplette tmux Sitzung geblockt wird wenn es hängt (statt bloß der einen Shell-Instanz).
 

eanneser

Well-Known Member
Hallo,

ich häng' mich 'mal an den alten Thread d'ran:
nachdem ich immer noch daran scheitere, über mount_smbfs ein SMBFS-Share einzubinden, würde ich gerne fusefs-smbnetfs ausprobieren.
Leider finde ich nirgends eine Anleitung wie das gehen soll ..., nicht 'mal eine man-page.
Ich weiss, das ich irgendwo eine .smb-Config-Datei brauche, aber ich weiss nicht was da drin stehen soll.

Gruss
Edgar
 

pit234a

Well-Known Member
Hier nun keine Empfehlung zu diesem Thema und keine Ahnung, wie das geht, aber vielleicht dieser Hinweis dazu:

Konqueror (der Browser von KDE) (hat eine Unmenge Abhängigkeiten!), kann eine Art smb-Netzwerk-Protokoll.
Damit kann smb://dein_smb-server aufgerufen werden. Also analog zu ftp://dein_ftp-server oder sogar sftp://dein_sftp-server.
Es erscheint dann eine Ansicht aller auf dem Server frei gegebenen Shares und nach Auswahl eines solchen, wird nach zugehörigem Nutzername und Passwort gefragt.
Wenn das Erfolg hatte, kann der Inhalt des Shares angesehen und je nach Dateirechten auch benutzt und verändert werden. Dabei ist nichts gemountet. Die Performance ist nichts, worüber man reden sollte. Ob das an der Netzwerk-Technologie hapert oder an anderen Stellen, kann ich nicht sagen. KDE ist heute vorbereitet, möglichst viel vorher zu sehen und automatisch zu machen, wozu viele viele Helfer-Dienste starten. Deshalb wollte ich es auch nicht mehr, aber, wenn ich es mir auf moderner HW betrachte, dann geht es dort durchwegs flüssig und möglicherweise dann auch in dem hier beschriebenen Modus besser, als ich das bei mir erlebe.

Testen kann ich allerdings nur mit meinem FreeBSD smb-server. Nutzen tue ich das natürlich nie.
 

eanneser

Well-Known Member
Danke für den Tipp. Aber ich möchte nicht wirklich KDE-Pakete auf meinem Rechner installieren, nur um ein Share mounten zu können (ich bevorzuge ein eher puristisches Vorgehen).
fusefs-smbnetfs kapiere ich nicht!
Ich werde doch nicht der einzige sein, der auf die Nutzung von SMB-Shares angewiesen ist, oder?

Gruss
Edgar
 

Yamagi

Possessed With Psi Powers
Teammitglied
Du lädst erst fuse.ko. Seit FreeBSD 10.0 ist es im Basissystem, davor ein Port welcher bereits als Abhängigkeit installiert sein sollte. Dann erstellst du eine neue Konfigurationsdatei in ~/.smb/smbnetfs.conf:

Code:
samba_charset  "utf-8"
auth  "$username" "$pass"

Wobei du natürlich deine Zugangsdaten in die Domäne angibst. Nun mountest du:

Code:
smbnetfs ~/samba/

Wartest eine gute Minute und findest in ~/samba/ deine komplette Domäne, genauso wie in Windows "Netzwerkumgebung" aufgebaut. Man kann natürlich viel mehr damit machen, zum Beispiel verschiedene Nutzernamen für Shares definieren, die generierten Unix-Rechte beeinflussen und so weiter. Schaue am besten mal hier: http://wiki.ubuntuusers.de/Samba_Client_SMBNetFS
 
  • Like
Reaktionen: lme

lme

FreeBSD Committer
Du lädst erst fuse.ko. Seit FreeBSD 10.0 ist es im Basissystem, davor ein Port welcher bereits als Abhängigkeit installiert sein sollte. Dann erstellst du eine neue Konfigurationsdatei in ~/.smb/smbnetfs.conf:

Code:
samba_charset  "utf-8"
auth  "$username" "$pass"

Wobei du natürlich deine Zugangsdaten in die Domäne angibst. Nun mountest du:

Code:
smbnetfs ~/samba/

Wartest eine gute Minute und findest in ~/samba/ deine komplette Domäne, genauso wie in Windows "Netzwerkumgebung" aufgebaut. Man kann natürlich viel mehr damit machen, zum Beispiel verschiedene Nutzernamen für Shares definieren, die generierten Unix-Rechte beeinflussen und so weiter. Schaue am besten mal hier: http://wiki.ubuntuusers.de/Samba_Client_SMBNetFS

Welche Firewallregeln brauche ich denn dafür?
 
Oben