• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

smbfs mount viel zu langsam

Olodin

Reading User
Themenstarter #1
Hallo,

hab ein Problem mit dem Schreibzugriff auf einen WindowsXP Rechner.
Ich habe vor zwei Tagen meinen Server von 5.2p9 auf 5.4 gebracht: frische Installation, Neu-Konfiguration basierend auf den bestehenden Konfig-Files.

Läuft soweit ganz gut, nur diese eine Sache noch. Ich mache wöchentliche Backups auf meinen XP Rechner (zum Brennen auf DVD-Ram) mittels ein paar Skripten und mounte dazu eine Freigabe:

Eintrag in /etc/fstab:
Code:
[FONT="Courier New"]//backup@XP-Rechner/backup   /mnt/backup     smbfs   rw,noauto       0       0[/FONT]
Leider ist das ganze beim Schreiben auf die Windows Freigabe zu langsam, was bonnie auch in Zahlen ausdrückt:
Code:
[FONT="Courier New"]root@server# bonnie -s 20 -m test
File './Bonnie.9805', size: 20971520
Writing with putc()...done
Rewriting...done
Writing intelligently...done
Reading with getc()...done
Reading intelligently...done
Seeker 3...Seeker 1...Seeker 2...start 'em...done...done...done...
              -------Sequential Output-------- ---Sequential Input-- --Random--
              -Per Char- --Block--- -Rewrite-- -Per Char- --Block--- --Seeks---
Machine    MB K/sec %CPU K/sec %CPU K/sec %CPU K/sec %CPU K/sec %CPU  /sec %CPU
test       20  3085 30.7   278  0.5   193  0.7  3162 29.4  5685 14.8  58.7  1.7[/FONT]
/var/log/messages sagt nix.
Google sagt nicht viel. Die Probleme gibts wohl auch unter Linux, sind kernelabhängig. Aber ne Lösung habe ich nicht gefunden.

Infos:
-FreeBSD 5.4-RELEASE (GENERIC) #0: Sun May 8 10:21:06 UTC 2005
-mount_smbfs: version 1.1.0
-100Mbit Netzwerk
-Kopieren von XP Rechner auf SMB Share auf dem Server mit 6-7 MB/s
-Keinerlei Probleme mit der 5.2p9 installation!

Hat irgendwer ne Idee? Neuen Kernel kompilieren? Aber was ändern?

Gruß

-Björn
 

Olodin

Reading User
Themenstarter #2
Hab das Problem eingrenzen können:

Langsam wird der Zugriff nur, wenn ich mit tar direkt auf das smb-mount schreibe.
Sobald ich kopiere, verschiebe oder sonstige Dateioperationen darauf ausführe, ist es so schnell, wie es sein sollte.

Ich habe es so gelöst, dass ich jetzt auf eine USB 2.0 Platte sichere.
Das ging vorher nicht, weil 5.2p9 keine richtige Unterstützung hatte.


PS: Passt der Thread jetzt noch in die Kategorie?