• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Speicherbedarf bei sysbuild

meilenstein

Well-Known Member
Themenstarter #1
Guten Abend

habe heute einmal in der virtuellen Umgebung versucht das System über die Quelldateien zu aktualisieren.

Code:
# sysbuild build
Irgendwann ist der Vorgang abgebrochen, da mein Speicherplatz voll war.
Der Ordner sysbuild ist auf eine Größe von ca. 3,2GB angewachsen.

Klar könnte ich jetzt in der virtuellen Umgebung die Festplatte einfach größer dimensionieren aber ich wollte dies ja nur als "Übung" für den Raspberry durchführen.
Wie große wird denn dieser Ordner bei dieser Aktion? 1:1 wie das ursprüngliche System oder ...?
 

meilenstein

Well-Known Member
Themenstarter #2
Hab jetzt einfach NetBSD in der VirtualBox neu aufgesetzt und mit einer entsprechend größeren Festplatte ausgestattet.
Löst zwar meine Frage nicht, aber dann teste ich dies einfach einmal aus.
 

meilenstein

Well-Known Member
Themenstarter #4
Danke für den Hinweis :-)
Auch wenn es mir wirklich nur um den Lern-/Basteleffekt ging, so ist es doch um einiges einfacher gerade wenn man wenig Zeit hat.
 

meilenstein

Well-Known Member
Themenstarter #5
Ich habe jetzt eigentlich per sysupgrade von 7.0.1 auf 7.0.2 aktualisiert mit
Code:
sysupgrade auto ftp://ftp.NetBSD.org/pub/NetBSD/NetBSD-7.0.2/evbarm-earmv7hf
Beim login steht immer noch 7.0.1 obwohl ich angegeben hatte /etc/motd zu überschreiben.
Okay vielleicht nur ne Kleinigkeit, kann ich ja auch manuell anpassen, aber wie stelle ich jetzt fest welche NetBSD Version ich überhaupt installiert habe?
Code:
uname -a
NetBSD berlin 7.0.1 NetBSD 7.0.1 (RPI2.201605221355Z) evbarm
Ist irgendwas schief gelaufen und wenn ja wie stelle ich dies fest?
 

meilenstein

Well-Known Member
Themenstarter #7
Hallo Darktrym
habe am Wochenende das Update nochmal durchgeführt mit dem gleichen Ergebnis.
Während des Vorgangs wird folgendes angezeigt wurde:
Code:
    Data traffic for this session was 6543042 bytes in 1 file.
    Total traffic for this session was 6547981 bytes in 1 transfer.
221 Thank you for using the FTP service on ftp.NetBSD.org.
sysupgrade: I: Upgrading kernel modules
sysupgrade: I: Extracting modules into /
100% |*********************************************************************************************************|  3910 KiB    0.97 MiB/s    00:00 ETA
sysupgrade: I: Skipping kernel installation (KERNEL not set)
sysupgrade: I: Upgrading base system
sysupgrade: I: Extracting base into /
100% |*********************************************************************************************************|   188 MiB    1.64 MiB/s    00:00 ETA
sysupgrade: I: Extracting comp into /
Scheinbar wird die Kernel Installation übersprungen...
 

meilenstein

Well-Known Member
Themenstarter #8
Eben nochmal nur den Kernel probiert, gleiches Ergebnis:
Code:
# sysupgrade kernel
sysupgrade: I: Skipping kernel installation (KERNEL not set)
Werde mal versuchen herauszubekommen wie ich den Kernel manuell setzen kann
 

meilenstein

Well-Known Member
Themenstarter #10
Bin jetzt ein kleines Stück weiter gekommen.
Nach genauem Lesen der Man Page von sysupgrade und der dortigen Pfadangabe habe ich mir das zugehörige FTP Verzeichnis einmal für meine Architektur angesehen.
Somit kann ich den Kernel mit der schlichten und korrekten Bezeichnung RPI2 entsprechend vorgeben.

Aber auch wenn jetzt das Upgrade fehlerfrei durchläuft (sowohl im Modus "auto" wie auch manuell Schritt für Schritt) komme ich immer wieder zum gleichen Ergebnis:
Code:
uname -a
NetBSD berlin 7.0.1 NetBSD 7.0.1 (RPI2.201605221355Z) evbarm
Es scheint, dass irgendwo etwas immer noch schief läuft.
Für mein Verständnis wird ja nur das entpackte Verzeichnis nach / kopiert ... kann hier irgendwas schief laufen? Sprich irgendwelche Altbestände noch irgendwo liegen von meinem fehlgeschlagenen ersten Versuch auf 7.0.2 zu aktualisieren so dass er diese erkennt und diese dann erneut verwendet?

Werde bei Gelegenheit alles nochmal zusammen auf dem von Dir genannten Forum schreiben, mal sehen woran es liegt bzw. wo man ansetzen kann.
Leider finde ich bei Google auch nur meine eigenen Posts zu diesem Thema ... :ugly: