Stillstand im Bios nach Konfig von Zweiter SSD Platte

affefreebsd

Active Member
Hi Leute,
ich habe ein Problem was ich so überhaupt nicht verstehe. Ich habe mir einen Protonet Maya Miniserver gekönnt (2012) und diesen mit einer 64gb mATA SSD Karte (für openBSD) und einer 2,5 SANDISK 2000 (2TB) für Daten augerüstet.

Zustand A) openbsd ist installiert (sd0) und Sandisk 2000 (sd1) ist leer. Alles läuft. Festplatten werden im BIOS angezeigt.

Zustand B) openbsd ist installiert (sd0) und Sandisk 2000 (sd1) jetzt auch partioniert. Rechner bleibt im BIOS Bild (Protonet)
hängen UND ich kann den BIOS nicht betreten . F2 ohne wirkung. Erst wenn ich die SANDISK entferne geht wieder alles.
Löschen der SANDISK und schon läuft wieder alles!!!!

Hab MBR UND GPT ausprobiert. NIX funzt sobald die Platte von openBSD mit fdisk und labeldisk angefasst wurde!

Keine Ahnung was da schief geht!
Gruss
ape
 

CommanderZed

OpenBSD User
Teammitglied
Klingt für mich erstmal nach einem sehr speziellen Bios-Bug.

Taucht der Fehler auch auf wenn du nur die zweite, die Sandisk 2000 partioniert anschließt?
 

mr44er

moderater Moderator
Teammitglied
Ja, halte den Bug auch für wahrscheinlich.

Nach etwas Stöberei zu dem Teil und der Firma drängt sich der Gedanke auf, dass es eher darum ging mit der crowdfunding-Kampagne einen hip aussehenden Plastikwürfel zu verkaufen.

Hinsichtlich der Lage (BIOS-Updates nichtmal vorhanden) würde ich da keinen Gedanken weiter dran verschwenden und es zurückgeben, wenn das schon so anfängt. ;)
 

CommanderZed

OpenBSD User
Teammitglied
Das Ding scheint auch eher sekundär darauf ausgelegt zu sein da ein eigenes OS aufzuspielen, soweit ich das nachlesen konnte.
 

affefreebsd

Active Member
Hab das ganze Spiel nochmals mit einer normalen HD getestet. Sobald da ne Parti Table von BSD drauf ist steht das Ding.
Ganze Spiel mit Debian - keine Probleme - ich kotz ab. BIOS update kann ich nicht finden
 

CommanderZed

OpenBSD User
Teammitglied
Wenn du da nur eine Partition / Disklabel brauchst könntest du versuchen einen mbr oder gpt mit fdsik zu schreiben, dort eine "normale" Partition anlegen (Linux, fat32, whatever aber halt nicht als OpenBSD Partition makieren) und dann schauen ob die die dann einfach mit ffs beschreiben kannst, ich weiß nicht ob ffs zwingend das disklabel format da braucht.
 

affefreebsd

Active Member
@CommanderZed Hab ich probiert. Erst hatte ich ein softraid0 angelegt und die SSD mit bio verschlüsselt. Geht alles bis zum Neustart. Dann ohne Verschlüsselung. Kein Erfolg. Dann nur fdisk OHNE disklabel. Kein Erfolg. Da die SSD 2T ist mbr oder gpt egal. Beide Probiert. Kein Erfolg. Will eigentlich nicht zurück zu Linux und alles abdichten. Aber so etwas habe ich noch nie erlebt. Openbsd ist nicht das Schweizer Messer und auch damit hatte ich schon wildes Kernel konfigurieren - Aber einfach im BIOS Startbildschirm hängen zu bleiben - BULLSH*T Wo schau die ver****** AMI BIOS hin (p table?) und blockiert????
 

foxit

Well-Known Member
Kannst du nicht den Support anschreiben? Manchmal gibt es im BIOS/EFI eine Option wie CSM oder MBR emulation support. Das kann helfen.
 

affefreebsd

Active Member
Leider nein, die Firma wurde aufgelöst und machen jetzt nur noch Software (damals Hamburg - heute USA). MBR emu habe ich probiert - kein Effekt :-(
 

zoidb3rg

Well-Known Member
Kannst Du mal testweise im BIOS den SATA Modus von AHCI auf IDE umstellen und dann einen Neustart probieren?
 
Oben