• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Systemstart ohne loader.conf?

[KB]

Well-Known Member
Themenstarter #1
Hallo wiedermal,

nachdem ich nun in meinem letzten Thread gelernt habe, dass ein Update auf 11.1 notwendig ist, um seine Packages auf den neuesten Stand zu bringen, habe ich dann ein Update des FreeBSD-Kernels versucht.

Nach dem Herunterladen und Bauen des neuen Kernels (kein GENERIC) sowie Neustart des Systems gibt es eine Kernel-Panic.
Nicht weiter schlimm habe ich gedacht und mit altem Kernel neu gestartet. Doch nun mein fataler Fehler:

# rm /boot/kernel
# mv /boot/kernel.old /boot/kernel

GENERIC-Kernel gebaut.
Ein Neustart führte wiederum in ein Kernel-Panic (beim Laden des Vesa-Moduls).
Nur diesmal wurde keine Kopie des alten Kernels abgelegt, wahrscheinlich, weil das Verzeichnis kernel.old nicht mehr existierte.
Ein Neustart mit einem anderem Boot-Medium bringt mich jetzt auch nicht mehr an die ja noch vorhandenen aber mit geli verschlüsselten Partitionen.
Was ich jedoch festgestellt habe ist, dass ich das System mit entschlüsselter Boot-Partition bis zum Loader-Prompt bringen kann. Und dort konnte ich in der loader.conf die Anweisung entdecken:

vesa_load="yes"

Diese Anweisung würde ich jetzt gern während des Laden des System umgehen bzw. abschalten. Daher nun meine Fragen:

Kennt jemand eine Möglichkeit die loader.conf-Datei vom Loader-Prompt aus zu verändern?
Oder kann ich das Laden der loader.conf während des Systemstarts irgendwie umgehen?

Vielen Dank,
[KB]
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#2
Du kannst das Modul sperren:
Code:
# Alle schon geladenen Module rauswerfen, damit es definitiv weg ist
unload

# Und nun sperren
disable-module vesa

# Und booten
boot
 

[KB]

Well-Known Member
Themenstarter #3
Danke Yamagi,

wieder was gelernt. Hat funktioniert, bin wieder im Spiel...

Viele Grüsse,
[KB]