• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Umlaute im Terminal

jstillha

Der maskierte Rächer
Themenstarter #1
Hallo zusammen

Kennt jemand das Problem mit den Umlauten im Terminal. Es gibt zwar einige Posts im Netz (googeln) aber diese sind für die tcsh. Wie vieleicht einige von euch wissen ist auf Panther aber bash als Standart, was ich auch bevorzuge. Nun, weiss jemand wie man die Umlaute zum Laufen bringt?

Habe schon etliche Stunden daran rumgewurstelt, hatt aber nichts gebracht.

Gruss

jstillha
 

asg

push it, don´t hype
#2
xterm:
In der Shell LC_CTYPE=de_DE.ISO8859-1 (oder in .profile/ .bashrc eintragen)

Terminal:
Keine Ahnung. LC_CTYPE geht nicht.
Evtl.: ~/Library/Preferences/com.apple.Terminal.plist hier etwas einstellen?
 

indy

Der Hutträger
#3
Für die bash:

LANG=de_DE.ISO8859-1
export LANG
MM_CHARSET=ISO-8859-1
export MM_CHARSET

Funktioniert sowohl als auch ;)
 
#6
Hallo zusammen,

für die bash gibt es folgende Lösung:

1. Terminal > Einstellungen > xtermcolor auswählen.

2. Terminal > Fenstereinstellungen >Monitor > Zeichensatzkodierung > UTF-8 auswählen

3. Terminal > Fenstereinstellungen >Emulation > Nicht ASCII-Zeichen in Escape-Sequenz umwandeln - Haken setzen

4. Datei ~/.inputrc anlegen und folgenden Inhalt eingeben:
set meta-flag ON
set input-meta On
set conver-meta Off
set output-meta On
set show-all-if-ambiguous On
Das wars! Ab der nächsten bash Sitzung gehts

Die tcsh ist - soweit ich bisher weiss - unter OS X leider nicht 8-bit sicher.
Wenn jemand eine Anleitung hat -> bitte posten.
 

jstillha

Der maskierte Rächer
Themenstarter #8
Danke D.Mon

Bist wohl auch ein macuser foren besucher. Was mir noch aufgefallen ist. Man sollte ISO Latin9 anstatt UTF-8 verwenden sonst werden pro Umlaut 2 Bytes verwendet, was sich dann negativ auf das löschen einer Zeile auswirkt.
 
#9
Original geschrieben von jstillha
Danke D.Mon

Bist wohl auch ein macuser foren besucher. Was mir noch aufgefallen ist. Man sollte ISO Latin9 anstatt UTF-8 verwenden sonst werden pro Umlaut 2 Bytes verwendet, was sich dann negativ auf das löschen einer Zeile auswirkt.
Ja, habe erst später gemerkt, dass Du das bist.
und die email Benachrichtigung hatte ich in diesem Forum auch nicht an.
ich dödel

@D.Mon:

Danke, das klappt :-))
Hast Du auch ne Erklärung dafür??
hab ich in nem Buch gelesen (im Geschäft :D)
man kann bei der bash sehr viele parameter einstellen (bei der tch und der zsh übrigens auch), aber das ist ne Wissenschaft für sich.
 
Zuletzt bearbeitet: