Umlaute + newscons = Probleme

kraekers

Well-Known Member
Moin Kollegen,

ich habe leider das Problem das ich unter FreeBSD 10.01 und newscons keine Umlaute auf der Shell abbilden kann.

Was habe ich bis jetzt unternommen:

/boot/loader,.conf

Code:
kern.vty=vt

/etc/login.conf

Code:
# German User Accounts.
german|German User Accounts:\
                :charset=UTF-8:\
                :lang=de_DE.UTF-8:\
                :tc=default:

Code:
cap_mkdb /etc/login.conf
vipw

german zwischen :: eingefügt

.profile

Code:
LANG=de_DE.UTF-8
export LANG
MM_CHARSET=de_DET.UTF-8
export MM_CHARSET

.cshrc

Code:
setenv LANG de_DE.UTF-8
setenv MM_CHARSET de_DE.UTF-8

Ich weiß nicht was ich vergessen haben könnte. Sobald ich eine Umlauttaste drücke passiert gar nichts, d.h. es wird nichts angezeigt. Unter VirtualBox habe ich angefangen zu testen, dachte es wäre ein VirtualBox Problem, aber mein zweites Testsystem, ein realer Rechner (Desktop), zeigt das gleiche Problem.

Hat vielleicht jemand ein Tipp von Euch.

Vielen Dank im Voraus.

Beste Grüße
kraekers
 

NaWi

Well-Known Member
Welche keymap hast Du denn in /etc/rc.conf eingetragen ?

Edit : sollte

keymap="german.iso.acc.kbd"

oder

keymap="german.iso"

sein.
 

foxit

Well-Known Member
@NaWi sicher?

Ich glaube es ist eine von diesen /usr/share/vt/keymaps/:
Code:
-r--r--r--  1 root  wheel  8910 Nov 18  2014 de.acc.kbd
-r--r--r--  1 root  wheel  8398 Nov 18  2014 de.kbd
-r--r--r--  1 root  wheel  7725 Nov 18  2014 de.noacc.kbd
Sollte dann z.B. so heissen in der /etc/rc.conf:
Code:
keymap="de"
 

foxit

Well-Known Member
Also ich machs immer so. Ich lasse die /etc/login.conf wie sie ist und lege im HOME Verzeichnis des Users ich die Datei .login_conf an mit folgendem Inhalt:
Code:
me:\
  :charset=UTF-8:\
  :lang=en_US.UTF-8:

Zeig mal die komplette /etc/login.conf. Vielleicht hast du da einen "\" oder so vergessen.
 

kraekers

Well-Known Member
Meine /etc/login.conf sieht wie folgt aus:

Code:
# login.conf - login class capabilities database.
#
# Remember to rebuild the database after each change to this file:
#
#    cap_mkdb /etc/login.conf
#
# This file controls resource limits, accounting limits and
# default user environment settings.
#
# $FreeBSD: releng/10.1/etc/login.conf 246002 2013-01-27 21:55:01Z neel $
#

# Default settings effectively disable resource limits, see the
# examples below for a starting point to enable them.

# defaults
# These settings are used by login(1) by default for classless users
# Note that entries like "cputime" set both "cputime-cur" and "cputime-max"
#
# Note that since a colon ':' is used to separate capability entries,
# a \c escape sequence must be used to embed a literal colon in the
# value or name of a capability (see the ``CGETNUM AND CGETSTR SYNTAX
# AND SEMANTICS'' section of getcap(3) for more escape sequences).

default:\
    :passwd_format=sha512:\
    :copyright=/etc/COPYRIGHT:\
    :welcome=/etc/motd:\
    :setenv=MAIL=/var/mail/$,BLOCKSIZE=K:\
    :path=/sbin /bin /usr/sbin /usr/bin /usr/games /usr/local/sbin /usr/local/bin ~/bin:\
    :nologin=/var/run/nologin:\
    :cputime=unlimited:\
    :datasize=unlimited:\
    :stacksize=unlimited:\
    :memorylocked=64K:\
    :memoryuse=unlimited:\
    :filesize=unlimited:\
    :coredumpsize=unlimited:\
    :openfiles=unlimited:\
    :maxproc=unlimited:\
    :sbsize=unlimited:\
    :vmemoryuse=unlimited:\
    :swapuse=unlimited:\
    :pseudoterminals=unlimited:\
    :priority=0:\
    :ignoretime@:\
    :umask=022:


#
# A collection of common class names - forward them all to 'default'
# (login would normally do this anyway, but having a class name
#  here suppresses the diagnostic)
#
standard:\
    :tc=default:
xuser:\
    :tc=default:
staff:\
    :tc=default:
daemon:\
    :memorylocked=128M:\
    :tc=default:
news:\
    :tc=default:
dialer:\
    :tc=default:

#
# Root can always login
#
# N.B.  login_getpwclass(3) will use this entry for the root account,
#       in preference to 'default'.
root:\
    :ignorenologin:\
    :memorylocked=unlimited:\
    :tc=default:

#
# Russian Users Accounts. Setup proper environment variables.
#
russian|Russian Users Accounts:\
    :charset=KOI8-R:\
    :lang=ru_RU.KOI8-R:\
    :tc=default:


######################################################################
######################################################################
##
## Example entries
##
######################################################################
######################################################################

## Example defaults
## These settings are used by login(1) by default for classless users
## Note that entries like "cputime" set both "cputime-cur" and "cputime-max"
#
#default:\
#    :cputime=infinity:\
#    :datasize-cur=22M:\
#    :stacksize-cur=8M:\
#    :memorylocked-cur=10M:\
#    :memoryuse-cur=30M:\
#    :filesize=infinity:\
#    :coredumpsize=infinity:\
#    :maxproc-cur=64:\
#    :openfiles-cur=64:\
#    :priority=0:\
#    :requirehome@:\
#    :umask=022:\
#    :tc=auth-defaults:
#
#
##
## standard - standard user defaults
##
#standard:\
#    :copyright=/etc/COPYRIGHT:\
#    :welcome=/etc/motd:\
#    :setenv=MAIL=/var/mail/$,BLOCKSIZE=K:\
#    :path=~/bin /bin /usr/bin /usr/local/bin:\
#    :manpath=/usr/share/man /usr/local/man:\
#    :nologin=/var/run/nologin:\
#    :cputime=1h30m:\
#    :datasize=8M:\
#    :vmemoryuse=100M:\
#    :stacksize=2M:\
#    :memorylocked=4M:\
#    :memoryuse=8M:\
#    :filesize=8M:\
#    :coredumpsize=8M:\
#    :openfiles=24:\
#    :maxproc=32:\
#    :priority=0:\
#    :requirehome:\
#    :passwordtime=90d:\
#    :umask=002:\
#    :ignoretime@:\
#    :tc=default:
#
#
##
## users of X (needs more resources!)
##
#xuser:\
#    :manpath=/usr/share/man /usr/local/man:\
#    :cputime=4h:\
#    :datasize=12M:\
#    :vmemoryuse=infinity:\
#    :stacksize=4M:\
#    :filesize=8M:\
#    :memoryuse=16M:\
#    :openfiles=32:\
#    :maxproc=48:\
#    :tc=standard:
#
#
##
## Staff users - few restrictions and allow login anytime
##
#staff:\
#    :ignorenologin:\
#    :ignoretime:\
#    :requirehome@:\
#    :accounted@:\
#    :path=~/bin /bin /sbin /usr/bin /usr/sbin /usr/local/bin /usr/local/sbin:\
#    :umask=022:\
#    :tc=standard:
#
#
##
## root - fallback for root logins
##
#root:\
#    :path=~/bin /bin /sbin /usr/bin /usr/sbin /usr/local/bin /usr/local/sbin:\
#    :cputime=infinity:\
#    :datasize=infinity:\
#    :stacksize=infinity:\
#    :memorylocked=infinity:\
#    :memoryuse=infinity:\
#    :filesize=infinity:\
#    :coredumpsize=infinity:\
#    :openfiles=infinity:\
#    :maxproc=infinity:\
#    :memoryuse-cur=32M:\
#    :maxproc-cur=64:\
#    :openfiles-cur=1024:\
#    :priority=0:\
#    :requirehome@:\
#    :umask=022:\
#    :tc=auth-root-defaults:
#
#
##
## Settings used by /etc/rc
##
#daemon:\
#    :coredumpsize@:\
#    :coredumpsize-cur=0:\
#    :datasize=infinity:\
#    :datasize-cur@:\
#    :maxproc=512:\
#    :maxproc-cur@:\
#    :memoryuse-cur=64M:\
#    :memorylocked-cur=64M:\
#    :openfiles=1024:\
#    :openfiles-cur@:\
#    :stacksize=16M:\
#    :stacksize-cur@:\
#    :tc=default:
#
#
##
## Settings used by news subsystem
##
#news:\
#    :path=/usr/local/news/bin /bin /sbin /usr/bin /usr/sbin /usr/local/bin /usr/local/sbin:\
#    :cputime=infinity:\
#    :filesize=128M:\
#    :datasize-cur=64M:\
#    :stacksize-cur=32M:\
#    :coredumpsize-cur=0:\
#    :maxmemorysize-cur=128M:\
#    :memorylocked=32M:\
#    :maxproc=128:\
#    :openfiles=256:\
#    :tc=default:
#
#
##
## The dialer class should be used for a dialup PPP account
## Welcome messages/news suppressed
##
#dialer:\
#    :hushlogin:\
#    :requirehome@:\
#    :cputime=unlimited:\
#    :filesize=2M:\
#    :datasize=2M:\
#    :stacksize=4M:\
#    :coredumpsize=0:\
#    :memoryuse=4M:\
#    :memorylocked=1M:\
#    :maxproc=16:\
#    :openfiles=32:\
#    :tc=standard:
#
#
##
## Site full-time 24/7 PPP connection
## - no time accounting, restricted to access via dialin lines
##
#site:\
#    :ignoretime:\
#    :passwordtime@:\
#    :refreshtime@:\
#    :refreshperiod@:\
#    :sessionlimit@:\
#    :autodelete@:\
#    :expireperiod@:\
#    :graceexpire@:\
#    :gracetime@:\
#    :warnexpire@:\
#    :warnpassword@:\
#    :idletime@:\
#    :sessiontime@:\
#    :daytime@:\
#    :weektime@:\
#    :monthtime@:\
#    :warntime@:\
#    :accounted@:\
#    :tc=dialer:\
#    :tc=staff:
#
#
##
## Example standard accounting entries for subscriber levels
##
#
#subscriber|Subscribers:\
#    :accounted:\
#    :refreshtime=180d:\
#    :refreshperiod@:\
#    :sessionlimit@:\
#    :autodelete=30d:\
#    :expireperiod=180d:\
#    :graceexpire=7d:\
#    :gracetime=10m:\
#    :warnexpire=7d:\
#    :warnpassword=7d:\
#    :idletime=30m:\
#    :sessiontime=4h:\
#    :daytime=6h:\
#    :weektime=40h:\
#    :monthtime=120h:\
#    :warntime=4h:\
#    :tc=standard:
#
#
##
## Subscriber accounts. These accounts have their login times
## accounted and have access limits applied.
##
#subppp|PPP Subscriber Accounts:\
#    :tc=dialer:\
#    :tc=subscriber:
#
#
#subshell|Shell Subscriber Accounts:\
#    :tc=subscriber:
#
##
## If you want some of the accounts to use traditional UNIX DES based
## password hashes.
##
#des_users:\
#    :passwd_format=des:\
#    :tc=default:
#
#
german|German User Accounts:\
    :charset=UTF-8:\
    :lang=de_DE.UTF-8:\
    :tc=default:
 

NaWi

Well-Known Member
Hab ich auch so - hab mich an der russian Vorgabe orientiert.

Ich habe in /etc/rc.conf allerdings

keymap="german.iso"
 

kraekers

Well-Known Member
Ich habe mittlerweile alle Möglichkeiten durchprobiert, trotzdem keine Umlaute. Ist schon sehr merkwürdig. Zumal es auf allen meinen Systemen so ist. ich bin doch nicht blöd. Mensch das ärgert mich jetzt.
 

NaWi

Well-Known Member
Das ist immer so, dass Dinge nicht funktionieren obwohl sie es sollten.

Die Kiste neu gestartet ?
kbdmap probiert, um zu sehen, welche Keymaps verfügbar sind ?
Bekommst Du eigentlich überhaupt ein Zeichen, beim drücken einer Taste ?

Sind alles nur Ideen und, nicht böse gemeint.
 

kraekers

Well-Known Member
- die Kiste wurde neu gestartet
- kbdmap zeigt alle erforderlichen Keymaps an
- es werden alle Zeichen, bis auf Umlaute, dargestellt
- wenn die Kiste durchgestartet wird erfolgt ja die login-Abfrage, da habe ich einfach mal öäü gedrückt und die werden dann angezeigt, melde ich mich dann mit root an, funktioniert es nicht

Ich probiere jetzt alles im Büro über VirtualBox aus, kann es damit zusammenhängen? Hatte zwar auch schon alle Tipps zu Hause getestet, ohne Erfolg, aber vielleicht habe ich ja was zu Hause übersehen, was unter VirtualBox nicht geht.
 

NaWi

Well-Known Member
Hast Du mit vipw auch roots Login Klasse geändert ? Alternativ könttest Du auch die lang und charset Werte in die default oder root Klasse einfügen um es zu testen.
 

NaWi

Well-Known Member
Und, cap_mkdb /etc/login.conf nach jeder Änderung der login.conf ... mehr fällt mir momentan auch nicht ein - für ein edit war ich zu spät dran.
 

kraekers

Well-Known Member
Hatte ich alles gemacht. Ich danke Dir, werde weiter probieren und ggf. berichten.

Beste Grüße
Kraekers
 

kraekers

Well-Known Member
Danke, dass war es leider auch nicht. War auch nicht in meiner .profile so, hat sich wahrscheinlich durch abschreiben eingeschlichen.
 

NaWi

Well-Known Member
Das hört man gerne.
Das find ich sowieso irgendwie komisch, root verwendet per default csh und jeder per adduser neu angelegte Nutzer sh per default.
 
Oben