Verbindung zu Netzwerk trotz Verbot

Krull

Well-Known Member
Hallo,

mein Laptop verbindet sich hin und wieder gerne mal mit einem offenen WLAN in der Nähe, obwohl ich ihm das in der wpa_supplicant.conf eigentlich untersagt habe.

Code:
...
network={
    ssid="Telekom_FON"
    disabled=1
}
Was muss ich noch tun, damit er wirklich endlich damit aufhört?
 

Krull

Well-Known Member
Ah, ich sehe gerade, dass es bei mir sogar mehrere FON-Netze gibt. Evtl. kann man die nicht alle gleichzeitig mit einem ssid-Eintrag abwürgen? Ich probiere es mal mit bssid-Einträgen für jedes einzelne Netz. Mal schauen, ob's hilft...
 

Krull

Well-Known Member
Nee, mit einem bssid-Eintrag funktioniert es auch nicht.
Code:
...
network={
    bssid=78:ee:13:ba:ab:e3
    disabled=1
}
 

morromett

Well-Known Member
Ah, ich sehe gerade, dass es bei mir sogar mehrere FON-Netze gibt. Evtl. kann man die nicht alle gleichzeitig mit einem ssid-Eintrag abwürgen? Ich probiere es mal mit bssid-Einträgen für jedes einzelne Netz. Mal schauen, ob's hilft...
Versuch mal in der /etc/rc.conf mit (z. B. für das 2.4GHz-WLAN):
Code:
static_arp_pairs="gwrouter"
static_arp_gwrouter="<IP-Adresse-Router> <MAC-Adresse-Router>"
ifconfig_wlan0="up scan WPA DHCP channel <Frequenz>:ht/20 chanlist <Kanal>"
(IP-Adresse-Router, MAC-Adresse-Router, Frequenz und Kanal anpassen und ohne spitze Klammern).
 

empee

New Member
ist das noch aktuell?

Ich glaube mich zu erinnern, das man dem wpa_supplicant per Option generell vom Neuverbinden abhalten konnte - nicht nur per SSID. Wenn ihr wollt suche ich mal in meine Backups.
 

morromett

Well-Known Member
Ich glaube mich zu erinnern, das man dem wpa_supplicant per Option generell vom Neuverbinden abhalten konnte - nicht nur per SSID. Wenn ihr wollt suche ich mal in meine Backups.
Es geht ja nicht nur um das Neuverbinden. Es geht auch um das sofortige Verbinden nach dem Booten/Rebooten, mit einem offenen WLAN in der Nähe.

BTW: Wenn man dem wpa_supplicant das Neuverbinden "abgewöhnt", was passiert dann wenn die WLAN-Verbindung zum richtigen WLAN, aus welchen Gründen auch immer mal unterbrochen wird? ... der wpa_supplicant sollte sich dann doch erneut bzw. sofort mit dem richtigen WLAN wieder verbinden, oder?
 

empee

New Member
Es geht ja nicht nur um das Neuverbinden. Es geht auch um das sofortige Verbinden nach dem Booten/Rebooten, mit einem offenen WLAN in der Nähe.
Sorry ich hab mich unklar ausgedrückt. Ich dachte der OP hat dasselbe Problem wie ich vor etwa einem Jahr, als mein Stick jedes Mal wenn er den Connect verlor sich das nächste freie Wlan griff und sich verband.

Mit jener Option war damit Ruhe. Leider sind die Files mein letzes Backup vom FreeBSD Server eigentlich nicht das was ich erwartet hab, eigentlich unauffälliig:

rc.conf: wlans_ath0="wlan0" ifconfig_wlan0="WPA DHCP" create_args_wlan0="country DE regdomain NONE" wpa_supplicant.conf: ctrl_interface=/var/run/wpa_supplicant eapol_version=2 ap_scan=1 fast_reauth=1 network={ ssid="mysid" bssid=44:4e:6d:77:0c:c4 key_mgmt=WPA-PSK proto=RSN psk="bla" }
 

Kamikaze

Warrior of Sunlight
Es geht ja nicht nur um das Neuverbinden. Es geht auch um das sofortige Verbinden nach dem Booten/Rebooten, mit einem offenen WLAN in der Nähe.
Von alleine macht der wpa_supplicant eigentlich nichts was nicht in der Konfiguration steht.

Meine Theorie ist, dass Dir irgend ein Netzwerkdienst zum Beispiel von Deinem Desktop Environment rein pfuscht.
 

morromett

Well-Known Member
Meine Theorie ist, dass Dir irgend ein Netzwerkdienst zum Beispiel von Deinem Desktop Environment rein pfuscht.
Ja, genau so war es bzw. ist es. Der wifimgr und/oder der networkmgr sind das Problem (... wenn es um die Verbindung mit einem offenen WLAN geht).
Deshalb benutze ich auf dem Desktop zum herstellen der WLAN-Verbindung, nur wpa_supplicant, netif und die Konfiguration in der rc.conf.
 
Oben