• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

virtualbox und netzwerk....

kira12

Well-Known Member
Themenstarter #1
Hallo Leute,

ich habe virtualbox-no-x11 auf einem aktuellen FreeBSD 11.1 installiert und möchte das bridged Netzwerk nutzen. die beiden virtualbox Treiber sind geladen aber ich bekommen vom Guest (Win 2008R2) keinen Ping auf irgendwelche IPs ausser der vom Host. Muß ich da noch eine bridge erzeugen auf dem Host? In den howtos die ich gefunden hatte stand da nix :(

Gruß ré
 

das.chaos

Duracellhase 2.0
#2
V-Box stellt auch den "NAT-Mode" fuer Networking zur Verfuegung, aber "Bridged Networking" bedarf folgendes Set-up:
  1. Rollenwechsel [bspw.] per su(1).
  2. Einer Instanz von tap(4).
  3. Selbstredend, eine Instanz von physischer NIC.
  4. Einer Instanz von bridge(4).
  5. Set-up vom Paketfilter ggf. anpassen.
Ggf. sollten vorher die Kernelmodulen fuer bridge(4) sowie tap(4) geladen
Code:
kldload if_bridge if_tap
werden. Die Instanz tap(4) wird per
Code:
ifconfig tap0 create
initialisiert, aber die Zugriffsrechte fuer V-Box moechten angepasst
Code:
chmod 0666 /dev/tap0
sysctl net.link.tap.up_on_open=1
sysctl net.link.tap.user_open=1
werden. Dann wird bridge(4) per
Code:
ifconfig bridge0 create
initialisiert sowie die Instanz von physischer NIC [bspw. re0 oder was auch immer] und der von tap(4) in das Koppelfeld
Code:
ifconfig bridge0 addm re0 addm tap0 up
ifconfig re0 up
ifconfig tap0 up
integriert.
 
Zuletzt bearbeitet:

kira12

Well-Known Member
Themenstarter #3
Hallo Chaos,

danke für die sehr ausführliche Erklärung ;-) Ich werde das heute abend gleich mal testen....

Gruß ré
 

kira12

Well-Known Member
Themenstarter #4
Hallo,

soweit alles eingegeben, aber nun klappt gar nix mehr mit Netzwerk. Alles was an Kommunikation nach außen geht funktioniert nicht mehr.

Gruß ré
 

turrican

Well-Known Member
#5
ist bei der Host-NIC welche der Bridge zugeordnet ist, der 'Promiscous Mode' enabled und das (virtuelle) 'Cable connected'?
Hab die shell-Befehle dafür grad net parat (sorry, um 01:33am), aber in der VBox-Gui gabs das unter "Network" -> "Adapter" -> "Advanced"
 

kira12

Well-Known Member
Themenstarter #6
Hallo,

ja, promisc ist aktiviert an der Host Nic. Mit dem virtuellen Kabel habe ich nix gefunden.

Gruß ré
 

mr44er

Trödel-Troll
#9
Ewig nicht mehr gemacht, aber ich erinner mich noch...das war wichtig bei den betreffenden NICs in rc.conf:
ifconfig_em0="up"

Wie von das.chaos weiter oben ja schon gesagt.

Und dann ja....pf checken.
 

kira12

Well-Known Member
Themenstarter #10
Hallo Leute,

danke für eure Tipps, ich habe - dank spielereien mit lagg - die IP der bridge zugewiesen, das klappt nicht. Nun die IP wieder zurück an die NIC und nun klappts mit der Kommunikation mit dem Hostnetzwerk.

Gruß ré
 

kira12

Well-Known Member
Themenstarter #11
Hallo Leute,

irgendwie bekommt mein Windows Gast keine Netzwerkverbindung hin, was sollte ich einstellen in Windows für bridged Network. Ich habe schon die Hostnic und tap probiert....

Gruß ré
 
#12
Im Windows alles auf automatisch. Auf dem Host /virtualbox einfach nur bridged auf den richtigen Adapter. Dann sollte Windows an dem physikalischen Adapter 'aufliegen'.
Oder versteh ich den Aufbau nicht? :confused:


Ggf. reboot, ist halt Windows und dann an die Firewall vom Windows denken!