• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Von "current" zurück auf stable

meilenstein

Well-Known Member
Themenstarter #1
Hallo

ich hatte bei der Installation auf den Raspberry Pi 2 mich aus Unwissenheit für die current Version entschieden und würde jetzt gerne wieder den Schritt zurück machen. Grund sind Probleme bei der Installation mehrerer Anwendungen, bei welchen ich mich nicht mit den jeweiligen einzelnen Details (auch aus derzeitiger Unwissenheit) auseinandersetzen möchte. (zumindest noch nicht)

Reicht es hier aus wenn ich gemäß der Anleitung die Stable Version runterlade und "drüber" installiere?
Auf der Seite wird ja auch unterschieden in Release und Maintenance Branches.
Leider verstehe ich die Unterschiede nicht ganz zwischen diesen beiden Versionen, da ja auch das Release alle 3 Tage aktualisiert wird...

Ferner würde mich interessieren ob ich zwingend von einem US Server die Daten laden muss oder ob ich nicht einen Spiegelserver in Deutschland nutzen kann.
Nehme ich den ftp.de.NetBSD.org kann ich mit mget keine Dateien herunterladen, nehme ich den ftp7.de.NetBSD.org gibt es den passenden Pfad nicht einmal.

Und ja, natürlich kann ich mit einem FTP Programm die Daten herunterladen und dann per SSH wieder rüber kopieren auf den Raspberry, aber ich würde hier gerne mit den Boardmitteln weiterkommen. :-)
 

darktrym

Fahnenträger
#2
Ich kann dir nur vom ersten Punkt berichten, ein "Upgrade" auf's Release sollte klappen. Habs damals mit der sysinst Funktionalität bewerkstelligt, kann mich nicht an Probleme erinnern. Der bügelt praktisch nur die Daten drauf und konfiguriert Basic-Kram. Meine Anpassungen bspw. an ttys schienen davon ausgenommen zu sein.
 

meilenstein

Well-Known Member
Themenstarter #3
Danke für den Tip.
Leider war ich nicht erfolgreich, hatte allerdings nicht sysinst verwendet sondern sysupgrade, welches auch einen guten Eindruck vermittelt hatte.
Der Vorgang lief problemlos durch, und ich wurde auch für die Config Dateien jeweils gefragt welche Version ich verwenden möchte. Leider habe ich am Ende eine Fehlermeldung bekommen bzgl. einer Lib Datei. Hatte aus Zeitmangel mich hier entschieden aufzuhören und hab den Rechner heruntergefahren. Vermutlich war der Vorgang dann noch nicht 100% zu Ende, so dass der Rechner jetzt beim Hochfahren in einer Schleife mehr oder weniger hängt.
Werde einfach die Stable Version noch einmal neu installieren, hatte bis dato ja noch nicht viel auf dem Rechner.