• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Vorsicht bei libssh2 Update

hippodriver

Well-Known Member
Themenstarter #1
Das Update von libssh2 verändert die Versionsnummer der Bibliothek: libssh2.so.1 --> libssh2.so.0. Ein Neubau aller von libssh2 abhängigen Ports ist notwendig.
 

morromett

Well-Known Member
#2
Diese Änderung ist noch nicht bei allen abhängigen Ports angekommen. Z. B. curl verabschiedet sich mit:
Code:
..........................................
===>  Installing for libssh2-0.2,1
===>   libssh2-0.2,1 depends on file: /usr/local/lib/libcrypto.so.5 - found
===>   Generating temporary packing list
===>  Checking if security/libssh2 already installed
===>   libssh2-0.2,1 is already installed
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of security/libssh2
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/security/libssh2.
*** Error code 1

Stop in /usr/ports/ftp/curl.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.13514.0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=curl-7.19.2 UPGRADE_PORT_VER=7.19.2 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! ftp/curl (curl-7.19.2)        (unknown build error)
EDIT:

Code:
# pkg_info -R 'libssh2-0.2,1'
Information for libssh2-0.2,1:

Required by:
curl-7.19.2
gnupg-2.0.10_2
Mit gnupg hat es funktioniert.
 
Zuletzt bearbeitet:
#4
Probleme mit libssh2 bestehen...

Hi,

Habe eben nochmal ein cvsup laufen lassen.
aktuell laufe ich immer noch in Probleme..

Stell ich mich nur zu dumm an??

Habe die libssh2 per Hand neu installiert, da portupgrade nachdem es beim ersten Mal mit Fehlern abgebrochen hatte diese komplett aus der pkgdb entfernt hatte. Lief anfangs nicht, seit heute Abends allerdings läuft wenigstens die Installation der libssh2 durch.

Jetzt beim neustallieren von curl (portupgrade verhält sich identisch):

Code:
[root]@stardust /usr/ports/ftp/curl# make install
===>   curl-7.19.2 depends on file: /usr/local/bin/perl5.8.8 - found
===>   curl-7.19.2 depends on shared library: ssh2.1 - not found
===>    Verifying install for ssh2.1 in /usr/ports/security/libssh2
===>   Returning to build of curl-7.19.2
Error: shared library "ssh2.1" does not exist
*** Error code 1

Stop in /usr/ports/ftp/curl.
*** Error code 1

Stop in /usr/ports/ftp/curl.
[root]@stardust /usr/ports/ftp/curl#
centerim ist aktuell auch nicht mehr zu installieren und wenn mir die aktuell noch laufende Instanz abstürzt (was centerim hin und wieder mal macht) dann hab ich kein icq mehr.. Selbes Problem.. Sagt, er braucht curl.. curl braucht libssh2.. usw. :(

Weiß jmd. Rat?

gruß
snyke